Update to version 0.31.0; Fixes RHBZ#2181819

epel10
Fabio Valentini 11 months ago
parent 6d5cd14fa5
commit fdc68fb9cc
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -5,3 +5,4 @@
/rusqlite-0.26.1.crate /rusqlite-0.26.1.crate
/rusqlite-0.26.3.crate /rusqlite-0.26.3.crate
/rusqlite-0.28.0.crate /rusqlite-0.28.0.crate
/rusqlite-0.31.0.crate

@ -1,17 +1,27 @@
--- rusqlite-0.28.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- rusqlite-0.31.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rusqlite-0.28.0/Cargo.toml 2023-11-29T19:12:54.996906+00:00 +++ rusqlite-0.31.0/Cargo.toml 2024-04-09T16:34:26.176887+00:00
@@ -83,7 +83,7 @@ @@ -67,7 +67,6 @@
optional = true name = "load_extension"
required-features = [
"load_extension",
- "bundled",
"functions",
"trace",
]
@@ -114,10 +113,6 @@
[dependencies.fallible-iterator] [dependencies.libsqlite3-sys]
-version = "0.2" version = "0.28.0"
+version = "0.3" -
-[dependencies.rusqlite-macros]
-version = "0.2.0"
-optional = true
[dependencies.fallible-streaming-iterator] [dependencies.serde_json]
version = "0.1" version = "1.0"
@@ -149,23 +149,6 @@ @@ -170,23 +165,6 @@
backup = ["libsqlite3-sys/min_sqlite_version_3_6_23"] backup = []
blob = ["libsqlite3-sys/min_sqlite_version_3_7_7"] blob = []
buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"] buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"]
-bundled = [ -bundled = [
- "libsqlite3-sys/bundled", - "libsqlite3-sys/bundled",
@ -33,8 +43,8 @@
collation = [] collation = []
column_decltype = [] column_decltype = []
csvtab = [ csvtab = [
@@ -176,10 +159,6 @@ @@ -197,13 +175,8 @@
functions = ["libsqlite3-sys/min_sqlite_version_3_7_7"] functions = []
hooks = [] hooks = []
i128_blob = [] i128_blob = []
-in_gecko = [ -in_gecko = [
@ -43,23 +53,24 @@
-] -]
limits = [] limits = []
load_extension = [] load_extension = []
-loadable_extension = ["libsqlite3-sys/loadable_extension"]
modern-full = [ modern-full = [
@@ -207,7 +186,7 @@ "array",
"backup",
@@ -229,7 +202,7 @@
"vtab", "vtab",
"window", "window",
] ]
-modern_sqlite = ["libsqlite3-sys/bundled_bindings"] -modern_sqlite = ["libsqlite3-sys/bundled_bindings"]
+modern_sqlite = [] +modern_sqlite = []
release_memory = ["libsqlite3-sys/min_sqlite_version_3_7_16"] release_memory = []
serialize = ["modern_sqlite"]
series = ["vtab"] series = ["vtab"]
session = [ @@ -241,7 +214,6 @@
@@ -218,9 +197,7 @@ trace = []
trace = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
unlock_notify = ["libsqlite3-sys/unlock_notify"] unlock_notify = ["libsqlite3-sys/unlock_notify"]
vtab = ["libsqlite3-sys/min_sqlite_version_3_7_7"] vtab = []
-wasm32-wasi-vfs = ["libsqlite3-sys/wasm32-wasi-vfs"] -wasm32-wasi-vfs = ["libsqlite3-sys/wasm32-wasi-vfs"]
window = ["functions"] window = ["functions"]
-winsqlite3 = ["libsqlite3-sys/winsqlite3"]
with-asan = ["libsqlite3-sys/with-asan"] with-asan = ["libsqlite3-sys/with-asan"]
[badges.appveyor]

@ -1,11 +1,11 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 26
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate rusqlite %global crate rusqlite
Name: rust-rusqlite Name: rust-rusqlite
Version: 0.28.0 Version: 0.31.0
Release: %autorelease Release: %autorelease
Summary: Ergonomic wrapper for SQLite Summary: Ergonomic wrapper for SQLite
@ -13,12 +13,12 @@ License: MIT
URL: https://crates.io/crates/rusqlite URL: https://crates.io/crates/rusqlite
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * bump fallible-iterator dependency from 0.2 to 0.3
# * drop features for building with bundled dependencies # * drop features for building with bundled dependencies
# * drop Windows- and WASM-specific features and dependencies # * drop Windows- and WASM-specific features and dependencies
# * drop unused optional rusqlite_macros dependency
Patch: rusqlite-fix-metadata.diff Patch: rusqlite-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
Ergonomic wrapper for SQLite.} Ergonomic wrapper for SQLite.}
@ -207,18 +207,6 @@ use the "i128_blob" feature of the "%{crate}" crate.
%files -n %{name}+i128_blob-devel %files -n %{name}+i128_blob-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lazy_static-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lazy_static-devel %{_description}
This package contains library source intended for building other packages which
use the "lazy_static" feature of the "%{crate}" crate.
%files -n %{name}+lazy_static-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+limits-devel %package -n %{name}+limits-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -291,6 +279,18 @@ use the "serde_json" feature of the "%{crate}" crate.
%files -n %{name}+serde_json-devel %files -n %{name}+serde_json-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serialize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serialize-devel %{_description}
This package contains library source intended for building other packages which
use the "serialize" feature of the "%{crate}" crate.
%files -n %{name}+serialize-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+series-devel %package -n %{name}+series-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -424,7 +424,7 @@ use the "with-asan" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -1 +1 @@
SHA512 (rusqlite-0.28.0.crate) = a38205b2437ffb50bf8a14304b4a30a62993957a348f03b37d09fabb9269fcbdb35dafab496f7cecdcefb7353720ffc0580822d9b231e0f75cee23b6f7344857 SHA512 (rusqlite-0.31.0.crate) = 6d20b015ab72d3d75c363111c0cb41feae8bff83104ebdfcb8e5efc1bfb63eb48a17f6de2e6c96cb1e916b4795fea6d58466ab0820b151b12d1dc4c29800ba66

Loading…
Cancel
Save