Update to version 0.28.0; Fixes RHBZ#2059012

epel9
Fabio Valentini 2 years ago
parent a559062ae0
commit c2d9ed988a
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -4,3 +4,4 @@
/rusqlite-0.24.2.crate /rusqlite-0.24.2.crate
/rusqlite-0.26.1.crate /rusqlite-0.26.1.crate
/rusqlite-0.26.3.crate /rusqlite-0.26.3.crate
/rusqlite-0.28.0.crate

@ -1,40 +1,56 @@
--- rusqlite-0.26.3/Cargo.toml 1970-01-01T00:00:01+00:00 --- rusqlite-0.28.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rusqlite-0.26.3/Cargo.toml 2021-12-09T14:58:52.648947+00:00 +++ rusqlite-0.28.0/Cargo.toml 2023-03-07T15:19:02.944935+00:00
@@ -21,6 +21,7 @@ @@ -149,23 +149,6 @@
categories = ["database"]
license = "MIT"
repository = "https://github.com/rusqlite/rusqlite"
+exclude = ["appveyor.yml", "clippy.toml", "codecov.yml", "publish-ghp-docs.sh", "test.csv"]
[package.metadata.docs.rs]
all-features = false
default-target = "x86_64-unknown-linux-gnu"
@@ -135,11 +136,6 @@
backup = ["libsqlite3-sys/min_sqlite_version_3_6_23"] backup = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
blob = ["libsqlite3-sys/min_sqlite_version_3_7_7"] blob = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"] buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"]
-bundled = ["libsqlite3-sys/bundled", "modern_sqlite"] -bundled = [
-bundled-full = ["modern-full", "bundled"] - "libsqlite3-sys/bundled",
-bundled-sqlcipher = ["libsqlite3-sys/bundled-sqlcipher", "bundled"] - "modern_sqlite",
-bundled-sqlcipher-vendored-openssl = ["libsqlite3-sys/bundled-sqlcipher-vendored-openssl", "bundled-sqlcipher"] -]
-bundled-full = [
- "modern-full",
- "bundled",
-]
-bundled-sqlcipher = [
- "libsqlite3-sys/bundled-sqlcipher",
- "bundled",
-]
-bundled-sqlcipher-vendored-openssl = [
- "libsqlite3-sys/bundled-sqlcipher-vendored-openssl",
- "bundled-sqlcipher",
-]
-bundled-windows = ["libsqlite3-sys/bundled-windows"] -bundled-windows = ["libsqlite3-sys/bundled-windows"]
collation = [] collation = []
column_decltype = [] column_decltype = []
csvtab = ["csv", "vtab"] csvtab = [
@@ -151,16 +147,14 @@ @@ -176,10 +159,6 @@
functions = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
hooks = []
i128_blob = []
-in_gecko = [
- "modern_sqlite",
- "libsqlite3-sys/in_gecko",
-]
limits = [] limits = []
load_extension = [] load_extension = []
modern-full = ["array", "backup", "blob", "modern_sqlite", "chrono", "collation", "column_decltype", "csvtab", "extra_check", "functions", "hooks", "i128_blob", "limits", "load_extension", "serde_json", "series", "time", "trace", "unlock_notify", "url", "uuid", "vtab", "window"] modern-full = [
@@ -207,7 +186,7 @@
"vtab",
"window",
]
-modern_sqlite = ["libsqlite3-sys/bundled_bindings"] -modern_sqlite = ["libsqlite3-sys/bundled_bindings"]
+modern_sqlite = [] +modern_sqlite = []
release_memory = ["libsqlite3-sys/min_sqlite_version_3_7_16"]
series = ["vtab"] series = ["vtab"]
session = ["libsqlite3-sys/session", "hooks"] session = [
sqlcipher = ["libsqlite3-sys/sqlcipher"] @@ -218,9 +197,7 @@
trace = ["libsqlite3-sys/min_sqlite_version_3_6_23"] trace = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
unlock_notify = ["libsqlite3-sys/unlock_notify"] unlock_notify = ["libsqlite3-sys/unlock_notify"]
vtab = ["libsqlite3-sys/min_sqlite_version_3_7_7", "lazy_static"] vtab = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
-wasm32-wasi-vfs = ["libsqlite3-sys/wasm32-wasi-vfs"] -wasm32-wasi-vfs = ["libsqlite3-sys/wasm32-wasi-vfs"]
window = ["functions"] window = ["functions"]
-winsqlite3 = ["libsqlite3-sys/winsqlite3"] -winsqlite3 = ["libsqlite3-sys/winsqlite3"]
with-asan = ["libsqlite3-sys/with-asan"] with-asan = ["libsqlite3-sys/with-asan"]
[badges.appveyor] [badges.appveyor]
repository = "rusqlite/rusqlite"

@ -1,27 +1,23 @@
# Generated by rust2rpm 20 # Generated by rust2rpm 24
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate rusqlite %global crate rusqlite
Name: rust-%{crate} Name: rust-rusqlite
Version: 0.26.3 Version: 0.28.0
Release: %autorelease Release: %autorelease
Summary: Ergonomic wrapper for SQLite Summary: Ergonomic wrapper for SQLite
# Upstream license specification: MIT
License: MIT License: MIT
URL: https://crates.io/crates/rusqlite URL: https://crates.io/crates/rusqlite
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Manually created patch for downstream crate metadata changes
# * exclude some files only useful for upstream development and CI # * drop features for building with bundled dependencies
# * excise features for bundled sqlite (disabled in rust-libsqlite3-sys)
# * drop Windows- and WASM-specific features and dependencies # * drop Windows- and WASM-specific features and dependencies
Patch0: rusqlite-fix-metadata.diff Patch: rusqlite-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: rust-packaging >= 21
BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
Ergonomic wrapper for SQLite.} Ergonomic wrapper for SQLite.}
@ -38,9 +34,9 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE %license %{crate_instdir}/LICENSE
%doc Changelog.md README.md %doc %{crate_instdir}/README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -52,7 +48,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+array-devel %package -n %{name}+array-devel
Summary: %{summary} Summary: %{summary}
@ -64,7 +60,7 @@ This package contains library source intended for building other packages which
use the "array" feature of the "%{crate}" crate. use the "array" feature of the "%{crate}" crate.
%files -n %{name}+array-devel %files -n %{name}+array-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+backup-devel %package -n %{name}+backup-devel
Summary: %{summary} Summary: %{summary}
@ -76,7 +72,7 @@ This package contains library source intended for building other packages which
use the "backup" feature of the "%{crate}" crate. use the "backup" feature of the "%{crate}" crate.
%files -n %{name}+backup-devel %files -n %{name}+backup-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+blob-devel %package -n %{name}+blob-devel
Summary: %{summary} Summary: %{summary}
@ -88,7 +84,7 @@ This package contains library source intended for building other packages which
use the "blob" feature of the "%{crate}" crate. use the "blob" feature of the "%{crate}" crate.
%files -n %{name}+blob-devel %files -n %{name}+blob-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+buildtime_bindgen-devel %package -n %{name}+buildtime_bindgen-devel
Summary: %{summary} Summary: %{summary}
@ -100,19 +96,7 @@ This package contains library source intended for building other packages which
use the "buildtime_bindgen" feature of the "%{crate}" crate. use the "buildtime_bindgen" feature of the "%{crate}" crate.
%files -n %{name}+buildtime_bindgen-devel %files -n %{name}+buildtime_bindgen-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+byteorder-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+byteorder-devel %{_description}
This package contains library source intended for building other packages which
use the "byteorder" feature of the "%{crate}" crate.
%files -n %{name}+byteorder-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+chrono-devel %package -n %{name}+chrono-devel
Summary: %{summary} Summary: %{summary}
@ -124,7 +108,7 @@ This package contains library source intended for building other packages which
use the "chrono" feature of the "%{crate}" crate. use the "chrono" feature of the "%{crate}" crate.
%files -n %{name}+chrono-devel %files -n %{name}+chrono-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+collation-devel %package -n %{name}+collation-devel
Summary: %{summary} Summary: %{summary}
@ -136,7 +120,7 @@ This package contains library source intended for building other packages which
use the "collation" feature of the "%{crate}" crate. use the "collation" feature of the "%{crate}" crate.
%files -n %{name}+collation-devel %files -n %{name}+collation-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+column_decltype-devel %package -n %{name}+column_decltype-devel
Summary: %{summary} Summary: %{summary}
@ -148,7 +132,7 @@ This package contains library source intended for building other packages which
use the "column_decltype" feature of the "%{crate}" crate. use the "column_decltype" feature of the "%{crate}" crate.
%files -n %{name}+column_decltype-devel %files -n %{name}+column_decltype-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+csv-devel %package -n %{name}+csv-devel
Summary: %{summary} Summary: %{summary}
@ -160,7 +144,7 @@ This package contains library source intended for building other packages which
use the "csv" feature of the "%{crate}" crate. use the "csv" feature of the "%{crate}" crate.
%files -n %{name}+csv-devel %files -n %{name}+csv-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+csvtab-devel %package -n %{name}+csvtab-devel
Summary: %{summary} Summary: %{summary}
@ -172,7 +156,7 @@ This package contains library source intended for building other packages which
use the "csvtab" feature of the "%{crate}" crate. use the "csvtab" feature of the "%{crate}" crate.
%files -n %{name}+csvtab-devel %files -n %{name}+csvtab-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+extra_check-devel %package -n %{name}+extra_check-devel
Summary: %{summary} Summary: %{summary}
@ -184,7 +168,7 @@ This package contains library source intended for building other packages which
use the "extra_check" feature of the "%{crate}" crate. use the "extra_check" feature of the "%{crate}" crate.
%files -n %{name}+extra_check-devel %files -n %{name}+extra_check-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+functions-devel %package -n %{name}+functions-devel
Summary: %{summary} Summary: %{summary}
@ -196,7 +180,7 @@ This package contains library source intended for building other packages which
use the "functions" feature of the "%{crate}" crate. use the "functions" feature of the "%{crate}" crate.
%files -n %{name}+functions-devel %files -n %{name}+functions-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hooks-devel %package -n %{name}+hooks-devel
Summary: %{summary} Summary: %{summary}
@ -208,7 +192,7 @@ This package contains library source intended for building other packages which
use the "hooks" feature of the "%{crate}" crate. use the "hooks" feature of the "%{crate}" crate.
%files -n %{name}+hooks-devel %files -n %{name}+hooks-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+i128_blob-devel %package -n %{name}+i128_blob-devel
Summary: %{summary} Summary: %{summary}
@ -220,19 +204,7 @@ This package contains library source intended for building other packages which
use the "i128_blob" feature of the "%{crate}" crate. use the "i128_blob" feature of the "%{crate}" crate.
%files -n %{name}+i128_blob-devel %files -n %{name}+i128_blob-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+in_gecko-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+in_gecko-devel %{_description}
This package contains library source intended for building other packages which
use the "in_gecko" feature of the "%{crate}" crate.
%files -n %{name}+in_gecko-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+lazy_static-devel %package -n %{name}+lazy_static-devel
Summary: %{summary} Summary: %{summary}
@ -244,7 +216,7 @@ This package contains library source intended for building other packages which
use the "lazy_static" feature of the "%{crate}" crate. use the "lazy_static" feature of the "%{crate}" crate.
%files -n %{name}+lazy_static-devel %files -n %{name}+lazy_static-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+limits-devel %package -n %{name}+limits-devel
Summary: %{summary} Summary: %{summary}
@ -256,7 +228,7 @@ This package contains library source intended for building other packages which
use the "limits" feature of the "%{crate}" crate. use the "limits" feature of the "%{crate}" crate.
%files -n %{name}+limits-devel %files -n %{name}+limits-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+load_extension-devel %package -n %{name}+load_extension-devel
Summary: %{summary} Summary: %{summary}
@ -268,7 +240,7 @@ This package contains library source intended for building other packages which
use the "load_extension" feature of the "%{crate}" crate. use the "load_extension" feature of the "%{crate}" crate.
%files -n %{name}+load_extension-devel %files -n %{name}+load_extension-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+modern-full-devel %package -n %{name}+modern-full-devel
Summary: %{summary} Summary: %{summary}
@ -280,7 +252,7 @@ This package contains library source intended for building other packages which
use the "modern-full" feature of the "%{crate}" crate. use the "modern-full" feature of the "%{crate}" crate.
%files -n %{name}+modern-full-devel %files -n %{name}+modern-full-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+modern_sqlite-devel %package -n %{name}+modern_sqlite-devel
Summary: %{summary} Summary: %{summary}
@ -292,7 +264,19 @@ This package contains library source intended for building other packages which
use the "modern_sqlite" feature of the "%{crate}" crate. use the "modern_sqlite" feature of the "%{crate}" crate.
%files -n %{name}+modern_sqlite-devel %files -n %{name}+modern_sqlite-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+release_memory-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+release_memory-devel %{_description}
This package contains library source intended for building other packages which
use the "release_memory" feature of the "%{crate}" crate.
%files -n %{name}+release_memory-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_json-devel %package -n %{name}+serde_json-devel
Summary: %{summary} Summary: %{summary}
@ -304,7 +288,7 @@ This package contains library source intended for building other packages which
use the "serde_json" feature of the "%{crate}" crate. use the "serde_json" feature of the "%{crate}" crate.
%files -n %{name}+serde_json-devel %files -n %{name}+serde_json-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+series-devel %package -n %{name}+series-devel
Summary: %{summary} Summary: %{summary}
@ -316,7 +300,7 @@ This package contains library source intended for building other packages which
use the "series" feature of the "%{crate}" crate. use the "series" feature of the "%{crate}" crate.
%files -n %{name}+series-devel %files -n %{name}+series-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+session-devel %package -n %{name}+session-devel
Summary: %{summary} Summary: %{summary}
@ -328,7 +312,7 @@ This package contains library source intended for building other packages which
use the "session" feature of the "%{crate}" crate. use the "session" feature of the "%{crate}" crate.
%files -n %{name}+session-devel %files -n %{name}+session-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sqlcipher-devel %package -n %{name}+sqlcipher-devel
Summary: %{summary} Summary: %{summary}
@ -340,7 +324,7 @@ This package contains library source intended for building other packages which
use the "sqlcipher" feature of the "%{crate}" crate. use the "sqlcipher" feature of the "%{crate}" crate.
%files -n %{name}+sqlcipher-devel %files -n %{name}+sqlcipher-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+time-devel %package -n %{name}+time-devel
Summary: %{summary} Summary: %{summary}
@ -352,7 +336,7 @@ This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate. use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel %files -n %{name}+time-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+trace-devel %package -n %{name}+trace-devel
Summary: %{summary} Summary: %{summary}
@ -364,7 +348,7 @@ This package contains library source intended for building other packages which
use the "trace" feature of the "%{crate}" crate. use the "trace" feature of the "%{crate}" crate.
%files -n %{name}+trace-devel %files -n %{name}+trace-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unlock_notify-devel %package -n %{name}+unlock_notify-devel
Summary: %{summary} Summary: %{summary}
@ -376,7 +360,7 @@ This package contains library source intended for building other packages which
use the "unlock_notify" feature of the "%{crate}" crate. use the "unlock_notify" feature of the "%{crate}" crate.
%files -n %{name}+unlock_notify-devel %files -n %{name}+unlock_notify-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+url-devel %package -n %{name}+url-devel
Summary: %{summary} Summary: %{summary}
@ -388,7 +372,7 @@ This package contains library source intended for building other packages which
use the "url" feature of the "%{crate}" crate. use the "url" feature of the "%{crate}" crate.
%files -n %{name}+url-devel %files -n %{name}+url-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+uuid-devel %package -n %{name}+uuid-devel
Summary: %{summary} Summary: %{summary}
@ -400,7 +384,7 @@ This package contains library source intended for building other packages which
use the "uuid" feature of the "%{crate}" crate. use the "uuid" feature of the "%{crate}" crate.
%files -n %{name}+uuid-devel %files -n %{name}+uuid-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+vtab-devel %package -n %{name}+vtab-devel
Summary: %{summary} Summary: %{summary}
@ -412,7 +396,7 @@ This package contains library source intended for building other packages which
use the "vtab" feature of the "%{crate}" crate. use the "vtab" feature of the "%{crate}" crate.
%files -n %{name}+vtab-devel %files -n %{name}+vtab-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+window-devel %package -n %{name}+window-devel
Summary: %{summary} Summary: %{summary}
@ -424,7 +408,7 @@ This package contains library source intended for building other packages which
use the "window" feature of the "%{crate}" crate. use the "window" feature of the "%{crate}" crate.
%files -n %{name}+window-devel %files -n %{name}+window-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+with-asan-devel %package -n %{name}+with-asan-devel
Summary: %{summary} Summary: %{summary}
@ -436,7 +420,7 @@ This package contains library source intended for building other packages which
use the "with-asan" feature of the "%{crate}" crate. use the "with-asan" feature of the "%{crate}" crate.
%files -n %{name}+with-asan-devel %files -n %{name}+with-asan-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (rusqlite-0.26.3.crate) = 1d8ae38d3863530a941da111045a7d4e785c24e01ce34f38573eec9d8faad91ffdbe9ebd32e8f812522db304ea56c1dd08b3cb0482ae7a688ce56799df07239e SHA512 (rusqlite-0.28.0.crate) = a38205b2437ffb50bf8a14304b4a30a62993957a348f03b37d09fabb9269fcbdb35dafab496f7cecdcefb7353720ffc0580822d9b231e0f75cee23b6f7344857

Loading…
Cancel
Save