import rust-rusqlite-0.31.0-4.el10

i10ce changed/i10ce/rust-rusqlite-0.31.0-4.el10
MSVSphere Packaging Team 2 months ago
commit 3ea7ea6078
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/rusqlite-0.31.0.crate

@ -0,0 +1 @@
19526c6972ba6dc7c1805b78fc755ffe103b6609 SOURCES/rusqlite-0.31.0.crate

@ -0,0 +1,92 @@
--- rusqlite-0.31.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rusqlite-0.31.0/Cargo.toml 2024-09-29T18:29:36.129354+00:00
@@ -67,7 +67,6 @@
name = "load_extension"
required-features = [
"load_extension",
- "bundled",
"functions",
"trace",
]
@@ -114,10 +113,6 @@
[dependencies.libsqlite3-sys]
version = "0.28.0"
-
-[dependencies.rusqlite-macros]
-version = "0.2.0"
-optional = true
[dependencies.serde_json]
version = "1.0"
@@ -143,9 +138,6 @@
version = "1.0"
optional = true
-[dev-dependencies.bencher]
-version = "0.1"
-
[dev-dependencies.doc-comment]
version = "0.3"
@@ -170,23 +162,6 @@
backup = []
blob = []
buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"]
-bundled = [
- "libsqlite3-sys/bundled",
- "modern_sqlite",
-]
-bundled-full = [
- "modern-full",
- "bundled",
-]
-bundled-sqlcipher = [
- "libsqlite3-sys/bundled-sqlcipher",
- "bundled",
-]
-bundled-sqlcipher-vendored-openssl = [
- "libsqlite3-sys/bundled-sqlcipher-vendored-openssl",
- "bundled-sqlcipher",
-]
-bundled-windows = ["libsqlite3-sys/bundled-windows"]
collation = []
column_decltype = []
csvtab = [
@@ -197,13 +172,8 @@
functions = []
hooks = []
i128_blob = []
-in_gecko = [
- "modern_sqlite",
- "libsqlite3-sys/in_gecko",
-]
limits = []
load_extension = []
-loadable_extension = ["libsqlite3-sys/loadable_extension"]
modern-full = [
"array",
"backup",
@@ -229,7 +199,7 @@
"vtab",
"window",
]
-modern_sqlite = ["libsqlite3-sys/bundled_bindings"]
+modern_sqlite = []
release_memory = []
serialize = ["modern_sqlite"]
series = ["vtab"]
@@ -237,13 +207,10 @@
"libsqlite3-sys/session",
"hooks",
]
-sqlcipher = ["libsqlite3-sys/sqlcipher"]
trace = []
unlock_notify = ["libsqlite3-sys/unlock_notify"]
vtab = []
-wasm32-wasi-vfs = ["libsqlite3-sys/wasm32-wasi-vfs"]
window = ["functions"]
-with-asan = ["libsqlite3-sys/with-asan"]
[badges.appveyor]
repository = "rusqlite/rusqlite"

@ -0,0 +1,9 @@
[package]
cargo-toml-patch-comments = [
"drop features for building with bundled dependencies",
"drop Windows- and WASM-specific features and dependencies",
"drop unused optional rusqlite_macros dependency",
"drop unused support for sqlcipher",
"drop unused, benchmark-only bencher dev-dependency",
]

@ -0,0 +1,482 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.2)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 4;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate rusqlite
Name: rust-rusqlite
Version: 0.31.0
Release: %autorelease
Summary: Ergonomic wrapper for SQLite
License: MIT
URL: https://crates.io/crates/rusqlite
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop features for building with bundled dependencies
# * drop Windows- and WASM-specific features and dependencies
# * drop unused optional rusqlite_macros dependency
# * drop unused support for sqlcipher
# * drop unused, benchmark-only bencher dev-dependency
Patch: rusqlite-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Ergonomic wrapper for SQLite.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+array-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+array-devel %{_description}
This package contains library source intended for building other packages which
use the "array" feature of the "%{crate}" crate.
%files -n %{name}+array-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+backup-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+backup-devel %{_description}
This package contains library source intended for building other packages which
use the "backup" feature of the "%{crate}" crate.
%files -n %{name}+backup-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+blob-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+blob-devel %{_description}
This package contains library source intended for building other packages which
use the "blob" feature of the "%{crate}" crate.
%files -n %{name}+blob-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+buildtime_bindgen-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+buildtime_bindgen-devel %{_description}
This package contains library source intended for building other packages which
use the "buildtime_bindgen" feature of the "%{crate}" crate.
%files -n %{name}+buildtime_bindgen-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+chrono-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+chrono-devel %{_description}
This package contains library source intended for building other packages which
use the "chrono" feature of the "%{crate}" crate.
%files -n %{name}+chrono-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+collation-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+collation-devel %{_description}
This package contains library source intended for building other packages which
use the "collation" feature of the "%{crate}" crate.
%files -n %{name}+collation-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+column_decltype-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+column_decltype-devel %{_description}
This package contains library source intended for building other packages which
use the "column_decltype" feature of the "%{crate}" crate.
%files -n %{name}+column_decltype-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+csv-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+csv-devel %{_description}
This package contains library source intended for building other packages which
use the "csv" feature of the "%{crate}" crate.
%files -n %{name}+csv-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+csvtab-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+csvtab-devel %{_description}
This package contains library source intended for building other packages which
use the "csvtab" feature of the "%{crate}" crate.
%files -n %{name}+csvtab-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+extra_check-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+extra_check-devel %{_description}
This package contains library source intended for building other packages which
use the "extra_check" feature of the "%{crate}" crate.
%files -n %{name}+extra_check-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+functions-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+functions-devel %{_description}
This package contains library source intended for building other packages which
use the "functions" feature of the "%{crate}" crate.
%files -n %{name}+functions-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hooks-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hooks-devel %{_description}
This package contains library source intended for building other packages which
use the "hooks" feature of the "%{crate}" crate.
%files -n %{name}+hooks-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+i128_blob-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+i128_blob-devel %{_description}
This package contains library source intended for building other packages which
use the "i128_blob" feature of the "%{crate}" crate.
%files -n %{name}+i128_blob-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+limits-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+limits-devel %{_description}
This package contains library source intended for building other packages which
use the "limits" feature of the "%{crate}" crate.
%files -n %{name}+limits-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+load_extension-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+load_extension-devel %{_description}
This package contains library source intended for building other packages which
use the "load_extension" feature of the "%{crate}" crate.
%files -n %{name}+load_extension-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+modern-full-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+modern-full-devel %{_description}
This package contains library source intended for building other packages which
use the "modern-full" feature of the "%{crate}" crate.
%files -n %{name}+modern-full-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+modern_sqlite-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+modern_sqlite-devel %{_description}
This package contains library source intended for building other packages which
use the "modern_sqlite" feature of the "%{crate}" crate.
%files -n %{name}+modern_sqlite-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+release_memory-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+release_memory-devel %{_description}
This package contains library source intended for building other packages which
use the "release_memory" feature of the "%{crate}" crate.
%files -n %{name}+release_memory-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde_json-devel %{_description}
This package contains library source intended for building other packages which
use the "serde_json" feature of the "%{crate}" crate.
%files -n %{name}+serde_json-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serialize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serialize-devel %{_description}
This package contains library source intended for building other packages which
use the "serialize" feature of the "%{crate}" crate.
%files -n %{name}+serialize-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+series-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+series-devel %{_description}
This package contains library source intended for building other packages which
use the "series" feature of the "%{crate}" crate.
%files -n %{name}+series-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+session-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+session-devel %{_description}
This package contains library source intended for building other packages which
use the "session" feature of the "%{crate}" crate.
%files -n %{name}+session-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+time-devel %{_description}
This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+trace-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+trace-devel %{_description}
This package contains library source intended for building other packages which
use the "trace" feature of the "%{crate}" crate.
%files -n %{name}+trace-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unlock_notify-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unlock_notify-devel %{_description}
This package contains library source intended for building other packages which
use the "unlock_notify" feature of the "%{crate}" crate.
%files -n %{name}+unlock_notify-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+url-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+url-devel %{_description}
This package contains library source intended for building other packages which
use the "url" feature of the "%{crate}" crate.
%files -n %{name}+url-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+uuid-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+uuid-devel %{_description}
This package contains library source intended for building other packages which
use the "uuid" feature of the "%{crate}" crate.
%files -n %{name}+uuid-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+vtab-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+vtab-devel %{_description}
This package contains library source intended for building other packages which
use the "vtab" feature of the "%{crate}" crate.
%files -n %{name}+vtab-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+window-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+window-devel %{_description}
This package contains library source intended for building other packages which
use the "window" feature of the "%{crate}" crate.
%files -n %{name}+window-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.31.0-4
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Sun Sep 29 2024 Fabio Valentini <decathorpe@gmail.com> - 0.31.0-4
- Drop unused, benchmark-only bencher dev-dependency
* Sun Sep 29 2024 Fabio Valentini <decathorpe@gmail.com> - 0.31.0-3
- Drop unused support for sqlcipher
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.31.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Tue Apr 09 2024 Fabio Valentini <decathorpe@gmail.com> - 0.31.0-1
- Update to version 0.31.0; Fixes RHBZ#2181819
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.28.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Wed Nov 29 2023 Fabio Valentini <decathorpe@gmail.com> - 0.28.0-3
- Bump fallible-iterator dependency from 0.2 to 0.3
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.28.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Tue Mar 07 2023 Fabio Valentini <decathorpe@gmail.com> - 0.28.0-1
- Update to version 0.28.0; Fixes RHBZ#2059012
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.26.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.26.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.26.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Thu Dec 09 2021 Fabio Valentini <decathorpe@gmail.com> - 0.26.3-1
- Update to version 0.26.3; Fixes RHBZ#2030136
* Sat Nov 13 2021 Robert-André Mauchin <zebob.m@gmail.com> - 0.26.1-1
- Update to 0.26.1 Close: rhbz#1950008
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Thu Apr 08 2021 Fabio Valentini <decathorpe@gmail.com> - 0.24.2-1
- Initial package
## END: Generated by rpmautospec
Loading…
Cancel
Save