parent
2d69c5580f
commit
56de9c0711
@ -0,0 +1 @@
|
||||
/rtoolbox-0.0.1.crate
|
@ -0,0 +1,19 @@
|
||||
--- rtoolbox-0.0.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ rtoolbox-0.0.1/Cargo.toml 2023-03-12T13:42:14.316431+00:00
|
||||
@@ -36,16 +36,3 @@
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2"
|
||||
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3"
|
||||
-features = [
|
||||
- "std",
|
||||
- "winnt",
|
||||
- "fileapi",
|
||||
- "processenv",
|
||||
- "winbase",
|
||||
- "handleapi",
|
||||
- "consoleapi",
|
||||
- "minwindef",
|
||||
- "wincon",
|
||||
-]
|
@ -0,0 +1,11 @@
|
||||
--- rtoolbox-0.0.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ rtoolbox-0.0.1/Cargo.toml 2023-03-12T13:42:20.485442+00:00
|
||||
@@ -16,7 +16,7 @@
|
||||
authors = ["Conrad Kleinespel <conradk@conradk.com>"]
|
||||
description = "Utility functions for other crates, no backwards compatibility guarantees."
|
||||
readme = "README.md"
|
||||
-license = "Apache-2.0"
|
||||
+license = "Apache-2.0 AND MIT"
|
||||
|
||||
[dependencies.serde]
|
||||
version = "1.0"
|
@ -0,0 +1,88 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate rtoolbox
|
||||
|
||||
Name: rust-rtoolbox
|
||||
Version: 0.0.1
|
||||
Release: %autorelease
|
||||
Summary: Utility functions for other crates, no backwards compatibility guarantees
|
||||
|
||||
License: Apache-2.0 AND MIT
|
||||
URL: https://crates.io/crates/rtoolbox
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip foreign dependencies
|
||||
Patch: rtoolbox-fix-metadata-auto.diff
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * correct license in crate metadata:
|
||||
# https://github.com/conradkleinespel/duck/pull/51
|
||||
Patch: rtoolbox-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Utility functions for other crates, no backwards compatibility
|
||||
guarantees.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%doc %{crate_instdir}/CONTRIBUTING.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue