epel10
Peter Robinson 3 years ago
parent 50fb0bce5c
commit cdd0a0e4c4

@ -0,0 +1,20 @@
--- rsa-0.5.0/Cargo.toml.orig 2022-03-14 15:27:03.543900924 +0000
+++ rsa-0.5.0/Cargo.toml 2022-03-14 15:29:05.024682199 +0000
@@ -44,7 +44,7 @@
features = ["spin_no_std"]
[dependencies.num-bigint]
-version = "0.7.0"
+version = ">=0.7.0"
features = ["i128", "u64_digit", "prime", "zeroize"]
default-features = false
package = "num-bigint-dig"
@@ -87,7 +87,7 @@
default-features = false
[dependencies.zeroize]
-version = ">=1, <1.5"
+version = ">=1"
features = ["alloc", "zeroize_derive"]
[dev-dependencies.base64]
version = "0.13.0"

@ -1,23 +1,21 @@
# Generated by rust2rpm 13
# Generated by rust2rpm 20
%bcond_without check
%global debug_package %{nil}
%global crate rsa
Name: rust-%{crate}
Version: 0.3.0
Release: 5%{?dist}
Version: 0.5.0
Release: 1%{?dist}
Summary: Pure Rust RSA implementation
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/rsa
Source: %{crates_source}
Patch0: rsa-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
@ -32,8 +30,8 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
@ -46,20 +44,32 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+expose-internals-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+expose-internals-devel %{_description}
This package contains library source intended for building other packages
which use "expose-internals" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "expose-internals" feature of the "%{crate}" crate.
%files -n %{name}+expose-internals-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -70,8 +80,8 @@ BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages
which use "nightly" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -82,34 +92,34 @@ BuildArch: noarch
%description -n %{name}+pem-devel %{_description}
This package contains library source intended for building other packages
which use "pem" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "pem" feature of the "%{crate}" crate.
%files -n %{name}+pem-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel
%package -n %{name}+pkcs5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
%description -n %{name}+pkcs5-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "pkcs5" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%files -n %{name}+pkcs5-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde1-devel
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde1-devel %{_description}
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde1" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde1-devel
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde_crate-devel
@ -118,12 +128,24 @@ BuildArch: noarch
%description -n %{name}+serde_crate-devel %{_description}
This package contains library source intended for building other packages
which use "serde_crate" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "serde_crate" feature of the "%{crate}" crate.
%files -n %{name}+serde_crate-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
@ -143,6 +165,9 @@ which use "serde_crate" feature of "%{crate}" crate.
%endif
%changelog
* Sun Feb 13 2022 Peter Robinson <pbrobinson@fedoraproject.org> - 0.5.0-1
- Update to 0.5.0
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

@ -1 +1 @@
SHA512 (rsa-0.3.0.crate) = 04c58f7d07babf108b7c30df94de359c413c26d1e9f044aa4782e58e4278fa2b448dd659820235f857f68e7ad428fa4fc90d69f549105b56ffa71d924b6b6a01
SHA512 (rsa-0.5.0.crate) = 185c4d2c176f205d575b00e5fc917a31254bf6753eeadae37ce838ba8e9383c7fe6793aab1143e15f39b0bc4f37da4bddde1090212011f3bf4761bfb7d2ca8a3

Loading…
Cancel
Save