Regenerate with rust2rpm v24 and remove broken subpackage

epel10
Fabio Valentini 2 years ago
parent fa20788f8d
commit 08b9576f0c
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,3 +0,0 @@
# rust-rsa
The rust-rsa package

@ -0,0 +1,11 @@
--- rsa-0.5.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ rsa-0.5.0/Cargo.toml 2023-06-23T18:40:58.339813+00:00
@@ -87,7 +87,7 @@
default-features = false
[dependencies.zeroize]
-version = ">=1, <1.5"
+version = "1"
features = ["alloc", "zeroize_derive"]
[dev-dependencies.base64]
version = "0.13.0"

@ -1,20 +0,0 @@
--- rsa-0.5.0/Cargo.toml.orig 2022-03-14 15:27:03.543900924 +0000
+++ rsa-0.5.0/Cargo.toml 2022-03-14 15:29:05.024682199 +0000
@@ -44,7 +44,7 @@
features = ["spin_no_std"]
[dependencies.num-bigint]
-version = "0.7.0"
+version = ">=0.7.0"
features = ["i128", "u64_digit", "prime", "zeroize"]
default-features = false
package = "num-bigint-dig"
@@ -87,7 +87,7 @@
default-features = false
[dependencies.zeroize]
-version = ">=1, <1.5"
+version = ">=1"
features = ["alloc", "zeroize_derive"]
[dev-dependencies.base64]
version = "0.13.0"

@ -1,23 +1,22 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate rsa
Name: rust-%{crate}
Name: rust-rsa
Version: 0.5.0
Release: %autorelease
Summary: Pure Rust RSA implementation
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/rsa
Source: %{crates_source}
Patch0: rsa-metadata.diff
# Manually created patch for downstream crate metadata changes
# * relax zeroize dependency (MSRV is not relevant for Fedora packages)
Patch: rsa-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Pure Rust RSA implementation.}
@ -34,9 +33,10 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -48,7 +48,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
@ -60,7 +60,7 @@ This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+expose-internals-devel
Summary: %{summary}
@ -72,19 +72,7 @@ This package contains library source intended for building other packages which
use the "expose-internals" feature of the "%{crate}" crate.
%files -n %{name}+expose-internals-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages which
use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pem-devel
Summary: %{summary}
@ -96,7 +84,7 @@ This package contains library source intended for building other packages which
use the "pem" feature of the "%{crate}" crate.
%files -n %{name}+pem-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pkcs5-devel
Summary: %{summary}
@ -108,7 +96,7 @@ This package contains library source intended for building other packages which
use the "pkcs5" feature of the "%{crate}" crate.
%files -n %{name}+pkcs5-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
@ -120,7 +108,7 @@ This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_crate-devel
Summary: %{summary}
@ -132,7 +120,7 @@ This package contains library source intended for building other packages which
use the "serde_crate" feature of the "%{crate}" crate.
%files -n %{name}+serde_crate-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -144,7 +132,7 @@ This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -0,0 +1,3 @@
[DEFAULT]
unwanted-features =
nightly
Loading…
Cancel
Save