parent
16ebd71721
commit
540e218f58
@ -0,0 +1 @@
|
||||
/rpassword-2.1.0.crate
|
@ -0,0 +1,11 @@
|
||||
--- rpassword-2.1.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ rpassword-2.1.0/Cargo.toml 2019-03-13T18:19:26.659455+01:00
|
||||
@@ -23,8 +23,3 @@
|
||||
repository = "https://github.com/conradkdotcom/rpassword"
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2"
|
||||
-[target."cfg(windows)".dependencies.kernel32-sys]
|
||||
-version = "0.2"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.2"
|
@ -0,0 +1,73 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate rpassword
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 2.1.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Read passwords in console applications
|
||||
|
||||
# Upstream license specification: Apache-2.0
|
||||
License: ASL 2.0
|
||||
URL: https://crates.io/crates/rpassword
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * No windows
|
||||
Patch0: rpassword-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
BuildRequires: (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)
|
||||
|
||||
%global _description \
|
||||
Read passwords in console applications.
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-APACHE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Mar 13 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.1.0-1
|
||||
- Initial package
|
@ -0,0 +1 @@
|
||||
SHA512 (rpassword-2.1.0.crate) = 23871c81f400482ff55f4688977fd1ebafac892defa3f1ab019b121435316b93784cad730252eb385135a1a1574fb3de6e60a2f75159561184ec465162b86d85
|
@ -0,0 +1 @@
|
||||
1
|
@ -0,0 +1,5 @@
|
||||
---
|
||||
standard-inventory-qcow2:
|
||||
qemu:
|
||||
# `cargo test` usually eats more than 1G.
|
||||
m: 4G
|
@ -0,0 +1,13 @@
|
||||
---
|
||||
- hosts: localhost
|
||||
roles:
|
||||
- role: standard-test-basic
|
||||
tags:
|
||||
- classic
|
||||
repositories:
|
||||
- repo: "https://src.fedoraproject.org/tests/rust.git"
|
||||
dest: rust
|
||||
tests:
|
||||
- rust/cargo-test
|
||||
environment:
|
||||
pkg: rust-rpassword
|
Loading…
Reference in new issue