parent
480c39424b
commit
f30d29068f
@ -0,0 +1 @@
|
||||
/ron-0.7.1.crate
|
@ -0,0 +1,12 @@
|
||||
--- ron-0.7.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ ron-0.7.1/Cargo.toml 2023-03-15T14:15:18.108221+00:00
|
||||
@@ -53,9 +53,6 @@
|
||||
version = "1.0.60"
|
||||
features = ["serde_derive"]
|
||||
|
||||
-[dev-dependencies.option_set]
|
||||
-version = "0.1"
|
||||
-
|
||||
[dev-dependencies.serde_bytes]
|
||||
version = "0.11"
|
||||
|
@ -0,0 +1,88 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate ron
|
||||
|
||||
Name: rust-ron0.7
|
||||
Version: 0.7.1
|
||||
Release: %autorelease
|
||||
Summary: Rusty Object Notation
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/ron
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop missing option_set dev-dependency
|
||||
Patch: ron-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Rusty Object Notation.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+indexmap-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+indexmap-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "indexmap" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+indexmap-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
# drop the only test that requires option_set
|
||||
rm tests/152_bitflags.rs
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue