Update to 0.6.0

epel9
Josh Stone 5 years ago
parent 7746b2e074
commit fec221183e

1
.gitignore vendored

@ -1 +1,2 @@
/ron-0.5.1.crate
/ron-0.6.0.crate

@ -1,11 +0,0 @@
--- ron-0.5.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ ron-0.5.1/Cargo.toml 2019-05-12T06:30:37.537001+00:00
@@ -37,7 +37,7 @@
version = "1"
features = ["serde_derive"]
[dev-dependencies.serde_bytes]
-version = "0.10"
+version = "0.11"
[dev-dependencies.serde_json]
version = "1"

@ -1,38 +1,30 @@
# Generated by rust2rpm-9-1.fc31
# Generated by rust2rpm 13
%bcond_with check
%global debug_package %{nil}
%global crate ron
Name: rust-%{crate}
Version: 0.5.1
Release: 4%{?dist}
Version: 0.6.0
Release: 1%{?dist}
Summary: Rusty Object Notation
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/ron
Source: %{crates_source}
# Initial patched metadata
# * Update serde_bytes to 0.11, https://github.com/ron-rs/ron/pull/164
Patch0: ron-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: (crate(base64/default) >= 0.10.0 with crate(base64/default) < 0.11.0)
BuildRequires: (crate(bitflags/default) >= 1.0.0 with crate(bitflags/default) < 2.0.0)
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde/serde_derive) >= 1.0.0 with crate(serde/serde_derive) < 2.0.0)
%if %{with check}
BuildRequires: (crate(serde_bytes/default) >= 0.11.0 with crate(serde_bytes/default) < 0.12.0)
BuildRequires: (crate(serde_json/default) >= 1.0.0 with crate(serde_json/default) < 2.0.0)
%endif
%global _description \
RON is a simple readable data serialization format that looks similar to Rust\
syntax. It's designed to support all of Serde's data model, so structs, enums,\
tuples, arrays, generic maps, and primitive values.
%global _description %{expand:
RON is a simple readable data serialization format that looks similar to Rust
syntax. It's designed to support all of Serde's data model, so structs, enums,
tuples, arrays, generic maps, and primitive values.}
%description %{_description}
@ -48,7 +40,7 @@ which use "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -60,12 +52,27 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+indexmap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+indexmap-devel %{_description}
This package contains library source intended for building other packages
which use "indexmap" feature of "%{crate}" crate.
%files -n %{name}+indexmap-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
@ -78,6 +85,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Thu May 21 2020 Josh Stone <jistone@redhat.com> - 0.6.0-1
- Update to 0.6.0
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (ron-0.5.1.crate) = 63b0ad38121218ee382f2817a66c9d445449deeb263d4541689601aea45e8e4b2728011e8e33bff6792922860f728f99e2a36d6565dd0077a5cbdc29c5941c69
SHA512 (ron-0.6.0.crate) = e0d8581d77688301e0cb4ead981aecff3f3e570812b8798bb5c7deeb35f49fb0e37d8e8569a5ac2f83be5a1e7d75e63a48c4c818861885e462a235922a36b40b

Loading…
Cancel
Save