Update to version 0.2.1; Fixes RHBZ#2035335

epel9 imports/e9/rust-roff-0.2.1-1.el9
Fabio Valentini 2 years ago
parent fe98a9b7bf
commit f5c56a5353
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1 +1,2 @@
/roff-0.1.0.crate /roff-0.1.0.crate
/roff-0.2.1.crate

@ -1,3 +0,0 @@
# rust-roff
The rust-roff package

@ -1,12 +0,0 @@
diff -up roff-0.1.0/tests/demo.rs.orig roff-0.1.0/tests/demo.rs
--- roff-0.1.0/tests/demo.rs.orig 2018-04-18 23:09:27.000000000 +0200
+++ roff-0.1.0/tests/demo.rs 2019-09-27 12:45:29.912714021 +0200
@@ -4,7 +4,7 @@ extern crate duct;
fn roff_to_ascii(input: &str) -> String {
duct::cmd("troff", &["-a", "-mman"])
- .input(input)
+ .stdin_bytes(input)
.stdout_capture()
.read()
.unwrap()

@ -1,12 +0,0 @@
--- roff-0.1.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ roff-0.1.0/Cargo.toml 2019-07-07T14:28:50.760316+00:00
@@ -23,7 +23,7 @@
[dependencies]
[dev-dependencies.duct]
-version = "0.10.0"
+version = "0.13.0"
[dev-dependencies.pretty_assertions]
-version = "0.5.1"
+version = "0.6.1"

@ -1,31 +1,19 @@
# Generated by rust2rpm 10 # Generated by rust2rpm 24
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate roff %global crate roff
Name: rust-%{crate} Name: rust-roff
Version: 0.1.0 Version: 0.2.1
Release: %autorelease Release: %autorelease
Summary: ROFF (man page format) generation library Summary: (man page format) generation library
# Upstream license specification: MIT OR Apache-2.0 License: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/roff URL: https://crates.io/crates/roff
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * Update duct to 0.13, pretty_assertions to 0.6, https://github.com/rust-cli/roff-rs/pull/8
Patch0: roff-fix-metadata.diff
# Duct 0.13 compatibility:
# Renamed input to stdin_bytes
Patch1: roff-duct-0.13.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
ROFF (man page format) generation library.} ROFF (man page format) generation library.}
@ -38,13 +26,14 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%doc README.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version}/ %doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -52,11 +41,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -64,9 +53,6 @@ which use "default" feature of "%{crate}" crate.
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires %cargo_generate_buildrequires
%if %{with check}
echo '/usr/bin/troff'
%endif
%build %build
%cargo_build %cargo_build

@ -1 +1 @@
SHA512 (roff-0.1.0.crate) = 8e9bfd3eb5b8bbfb3b0b417446c69e17b5104e31cd82e0616a246acc8d474a50622d66c5336a0584d57fe353b503a6ba01f1ffe64f6ff1bbe4cca3e9edada3b9 SHA512 (roff-0.2.1.crate) = 001cbc21c5c8ca4362f91fb237b867966653e6f49fa20be1a6c3d3e8d9f2cca66c474eb0b59ecff1527c771554e8503cef94181295dcb007fbc1a50dab49ce0f

Loading…
Cancel
Save