import rust-rkyv0.7-0.7.45-1.el10

i10ce changed/i10ce/rust-rkyv0.7-0.7.45-1.el10
MSVSphere Packaging Team 2 months ago
commit 285a977dd9
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/rkyv-0.7.45.crate

@ -0,0 +1 @@
9b009e4e7673a49cadae14c908c9870bef3bc114 SOURCES/rkyv-0.7.45.crate

@ -0,0 +1,81 @@
--- rkyv-0.7.45/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rkyv-0.7.45/Cargo.toml 2024-10-08T13:41:20.124774+00:00
@@ -47,29 +47,14 @@
optional = true
default-features = false
-[dependencies.bitvec]
-version = "1.0"
-optional = true
-default-features = false
-
[dependencies.bytecheck]
version = "0.6.11"
optional = true
default-features = false
-[dependencies.bytes]
-version = "1.4.0"
+[dependencies.hashbrown]
+version = "0.14"
optional = true
-default-features = false
-
-[dependencies.hashbrown]
-version = "0.12"
-optional = true
-
-[dependencies.indexmap]
-version = "1.7"
-optional = true
-default-features = false
[dependencies.ptr_meta]
version = "~0.1.3"
@@ -86,31 +71,9 @@
[dependencies.seahash]
version = "4.0"
-[dependencies.smallvec]
-version = "1.7"
-optional = true
-default-features = false
-
-[dependencies.smol_str]
-version = "0.2"
-optional = true
-default-features = false
-
-[dependencies.tinyvec]
-version = "1.5"
-optional = true
-default-features = false
-
-[dependencies.uuid]
-version = "1.3"
-optional = true
-default-features = false
-
[features]
alloc = [
"hashbrown",
- "bitvec?/alloc",
- "tinyvec?/alloc",
]
arbitrary_enum_discriminant = ["rkyv_derive/arbitrary_enum_discriminant"]
archive_be = [
@@ -135,14 +98,8 @@
"bytecheck?/std",
"ptr_meta/std",
"rend?/std",
- "uuid?/std",
- "bytes?/std",
]
strict = ["rkyv_derive/strict"]
-uuid = [
- "dep:uuid",
- "bytecheck?/uuid",
-]
validation = [
"alloc",
"bytecheck",

@ -0,0 +1,6 @@
[package]
cargo-toml-patch-comments = [
"bump hashbrown dependency from 0.12 to 0.14",
"drop unused support for various third-party crates",
]

@ -0,0 +1,281 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate rkyv
Name: rust-rkyv0.7
Version: 0.7.45
Release: %autorelease
Summary: Zero-copy deserialization framework for Rust
License: MIT
URL: https://crates.io/crates/rkyv
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * bump hashbrown dependency from 0.12 to 0.14
# * drop unused support for various third-party crates
Patch: rkyv-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Zero-copy deserialization framework for Rust.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/crates-io.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arbitrary_enum_discriminant-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arbitrary_enum_discriminant-devel %{_description}
This package contains library source intended for building other packages which
use the "arbitrary_enum_discriminant" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary_enum_discriminant-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+archive_be-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+archive_be-devel %{_description}
This package contains library source intended for building other packages which
use the "archive_be" feature of the "%{crate}" crate.
%files -n %{name}+archive_be-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+archive_le-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+archive_le-devel %{_description}
This package contains library source intended for building other packages which
use the "archive_le" feature of the "%{crate}" crate.
%files -n %{name}+archive_le-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arrayvec-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arrayvec-devel %{_description}
This package contains library source intended for building other packages which
use the "arrayvec" feature of the "%{crate}" crate.
%files -n %{name}+arrayvec-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytecheck-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytecheck-devel %{_description}
This package contains library source intended for building other packages which
use the "bytecheck" feature of the "%{crate}" crate.
%files -n %{name}+bytecheck-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+copy-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+copy-devel %{_description}
This package contains library source intended for building other packages which
use the "copy" feature of the "%{crate}" crate.
%files -n %{name}+copy-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+copy_unsafe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+copy_unsafe-devel %{_description}
This package contains library source intended for building other packages which
use the "copy_unsafe" feature of the "%{crate}" crate.
%files -n %{name}+copy_unsafe-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hashbrown-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hashbrown-devel %{_description}
This package contains library source intended for building other packages which
use the "hashbrown" feature of the "%{crate}" crate.
%files -n %{name}+hashbrown-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rend-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rend-devel %{_description}
This package contains library source intended for building other packages which
use the "rend" feature of the "%{crate}" crate.
%files -n %{name}+rend-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+size_16-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+size_16-devel %{_description}
This package contains library source intended for building other packages which
use the "size_16" feature of the "%{crate}" crate.
%files -n %{name}+size_16-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+size_32-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+size_32-devel %{_description}
This package contains library source intended for building other packages which
use the "size_32" feature of the "%{crate}" crate.
%files -n %{name}+size_32-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+size_64-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+size_64-devel %{_description}
This package contains library source intended for building other packages which
use the "size_64" feature of the "%{crate}" crate.
%files -n %{name}+size_64-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+strict-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+strict-devel %{_description}
This package contains library source intended for building other packages which
use the "strict" feature of the "%{crate}" crate.
%files -n %{name}+strict-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+validation-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+validation-devel %{_description}
This package contains library source intended for building other packages which
use the "validation" feature of the "%{crate}" crate.
%files -n %{name}+validation-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.7.45-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Tue Oct 08 2024 Fabio Valentini <decathorpe@gmail.com> - 0.7.45-1
- Initial import (rkyv 0.7 compat package)
## END: Generated by rpmautospec
Loading…
Cancel
Save