commit
cef8115705
Binary file not shown.
@ -0,0 +1,11 @@
|
|||||||
|
--- rkyv-0.7.42/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ rkyv-0.7.42/Cargo.toml 2023-05-22T22:06:59.468045+00:00
|
||||||
|
@@ -45,7 +45,7 @@
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
[dependencies.bytecheck]
|
||||||
|
-version = "=0.6.11"
|
||||||
|
+version = "0.6.11"
|
||||||
|
optional = true
|
||||||
|
default-features = false
|
||||||
|
|
@ -0,0 +1,419 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate rkyv
|
||||||
|
|
||||||
|
Name: rust-rkyv
|
||||||
|
Version: 0.7.42
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Zero-copy deserialization framework for Rust
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/rkyv
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * relax bytecheck dependency from =0.6.11 to ^0.6.11
|
||||||
|
Patch: rkyv-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Zero-copy deserialization framework for Rust.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%doc %{crate_instdir}/crates-io.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+alloc-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+alloc-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "alloc" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+alloc-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+arbitrary_enum_discriminant-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+arbitrary_enum_discriminant-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "arbitrary_enum_discriminant" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+arbitrary_enum_discriminant-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+archive_be-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+archive_be-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "archive_be" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+archive_be-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+archive_le-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+archive_le-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "archive_le" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+archive_le-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+arrayvec-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+arrayvec-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "arrayvec" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+arrayvec-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+bitvec-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+bitvec-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "bitvec" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+bitvec-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+bytecheck-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+bytecheck-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "bytecheck" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+bytecheck-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+copy-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+copy-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "copy" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+copy-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+copy_unsafe-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+copy_unsafe-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "copy_unsafe" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+copy_unsafe-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+hashbrown-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+hashbrown-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "hashbrown" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+hashbrown-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+indexmap-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+indexmap-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "indexmap" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+indexmap-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+rend-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+rend-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "rend" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+rend-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+size_16-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+size_16-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "size_16" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+size_16-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+size_32-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+size_32-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "size_32" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+size_32-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+size_64-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+size_64-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "size_64" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+size_64-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+smallvec-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+smallvec-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "smallvec" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+smallvec-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+strict-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+strict-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "strict" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+strict-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+tinyvec-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+tinyvec-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "tinyvec" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+tinyvec-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+uuid-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+uuid-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "uuid" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+uuid-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+validation-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+validation-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "validation" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+validation-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Nov 20 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.7.42-1
|
||||||
|
- Rebuilt for MSVSphere 9.2
|
||||||
|
|
||||||
|
* Mon May 22 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.42-1
|
||||||
|
- Update to version 0.7.42; Fixes RHBZ#2203535
|
||||||
|
|
||||||
|
* Sun Apr 02 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.41-1
|
||||||
|
- Update to version 0.7.41; Fixes RHBZ#2183438
|
||||||
|
|
||||||
|
* Tue Feb 28 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.40-1
|
||||||
|
- Update to version 0.7.40; Fixes RHBZ#2169603
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.39-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.39-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 16 2022 Fabio Valentini <decathorpe@gmail.com> - 0.7.39-1
|
||||||
|
- Update to version 0.7.39; Fixes RHBZ#2101255
|
||||||
|
|
||||||
|
* Mon Jun 06 2022 Fabio Valentini <decathorpe@gmail.com> - 0.7.38-1
|
||||||
|
- Update to version 0.7.38; Fixes RHBZ#2064099
|
||||||
|
|
||||||
|
* Fri Apr 08 2022 Rémi <remilauzier@protonmail.com> - 0.7.37-1
|
||||||
|
- Update to version 0.7.37; Fixes RHBZ#2064099
|
||||||
|
|
||||||
|
* Fri Mar 04 2022 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.35-2
|
||||||
|
- Downgrade hashbrown to version 0.11
|
||||||
|
|
||||||
|
* Fri Mar 04 2022 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.35-1
|
||||||
|
- Update to version 0.7.35; Fixes RHBZ#2054999
|
||||||
|
|
||||||
|
* Thu Jan 27 2022 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.31-1
|
||||||
|
- Update to version 0.7.31; Fixes RHBZ#2046578
|
||||||
|
|
||||||
|
* Wed Jan 26 2022 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.30-1
|
||||||
|
- Update to version 0.7.30; Fixes RHBZ#2038518
|
||||||
|
|
||||||
|
* Tue Jan 25 2022 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.29-1
|
||||||
|
- Update to version 0.7.29; Fixes RHBZ#2038518
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.28-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Dec 28 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.28-1
|
||||||
|
- Update to version 0.7.28; Fixes RHBZ#2033937
|
||||||
|
|
||||||
|
* Sun Dec 19 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.27-2
|
||||||
|
- Disable doc-test for now
|
||||||
|
|
||||||
|
* Sat Dec 18 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.27-1
|
||||||
|
- Update to version 0.7.27; Fixes RHBZ#2028959
|
||||||
|
|
||||||
|
* Fri Dec 10 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.26-1
|
||||||
|
- Update to version 0.7.26; Fixes RHBZ#2028959
|
||||||
|
|
||||||
|
* Tue Nov 30 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.24-1
|
||||||
|
- Update to version 0.7.24; Fixes RHBZ#2025214
|
||||||
|
|
||||||
|
* Fri Oct 29 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.20-1
|
||||||
|
- Update to version 0.7.20; Fixes RHBZ#2011054
|
||||||
|
|
||||||
|
* Wed Sep 22 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.18-1
|
||||||
|
- Update to version 0.7.18; Fixes RHBZ#2004726
|
||||||
|
|
||||||
|
* Wed Sep 15 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.17-1
|
||||||
|
- Update to version 0.7.17; Fixes RHBZ#2003852
|
||||||
|
|
||||||
|
* Sun Sep 05 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.16-1
|
||||||
|
- Update to version 0.7.16; Fixes RHBZ#1998663
|
||||||
|
|
||||||
|
* Wed Aug 25 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.13-1
|
||||||
|
- Update to version 0.7.13; Fixes RHBZ#1996127
|
||||||
|
|
||||||
|
* Mon Aug 16 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.11-1
|
||||||
|
- Update to version 0.7.11; Fixes RHBZ#1990969
|
||||||
|
|
||||||
|
* Fri Aug 06 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.5-3
|
||||||
|
- Add the patch
|
||||||
|
|
||||||
|
* Fri Aug 06 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.5-2
|
||||||
|
- Deactivate test on s390x and armv7hl
|
||||||
|
|
||||||
|
* Thu Aug 05 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.5-1
|
||||||
|
- Initial import; Fixes RHBZ#1980592
|
Loading…
Reference in new issue