Revert "available as a module"

Unretiring for https://pagure.io/releng/issue/8266

This reverts commit 49b84dc1de.
epel9
Mohan Boddu 6 years ago
parent 49b84dc1de
commit e9e72dbf9f

5
.gitignore vendored

@ -0,0 +1,5 @@
/ripgrep-0.7.1.crate
/ripgrep-0.8.0.crate
/ripgrep-0.8.1.crate
/ripgrep-0.9.0.crate
/ripgrep-0.10.0.crate

@ -0,0 +1,29 @@
From eb18da04506b959c0251099eae83e16d22ce8bcb Mon Sep 17 00:00:00 2001
From: Andrew Gallant <jamslam@gmail.com>
Date: Sat, 8 Sep 2018 17:12:14 -0400
Subject: [PATCH] pcre2: use jit_if_available
This will allow PCRE2 to fall back to non-JIT matching when running on
platforms without JIT support.
ref https://github.com/BurntSushi/rust-pcre2/issues/3
---
src/args.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/args.rs b/src/args.rs
index 1a38d3e..7aed914 100644
--- a/src/args.rs
+++ b/src/args.rs
@@ -633,7 +633,7 @@ impl ArgMatches {
// For whatever reason, the JIT craps out during regex compilation with
// a "no more memory" error on 32 bit systems. So don't use it there.
if !cfg!(target_pointer_width = "32") {
- builder.jit(true);
+ builder.jit_if_available(true);
}
if self.pcre2_unicode() {
builder.utf(true).ucp(true);
--
2.19.0.rc1

@ -0,0 +1,3 @@
# rust-ripgrep
The rust-ripgrep package

@ -1 +0,0 @@
available as a module

@ -0,0 +1,21 @@
--- ripgrep-0.10.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ ripgrep-0.10.0/Cargo.toml 2018-10-28T08:59:07.921425+01:00
@@ -46,7 +46,7 @@
default-features = false
[dependencies.grep]
-version = "0.2.2"
+version = "0.2.3"
[dependencies.ignore]
version = "0.4.4"
@@ -82,9 +82,7 @@
version = "1.1.0"
[features]
-avx-accel = ["grep/avx-accel"]
pcre2 = ["grep/pcre2"]
-simd-accel = ["grep/simd-accel"]
[badges.appveyor]
repository = "BurntSushi/ripgrep"

@ -0,0 +1,201 @@
# Generated by rust2rpm
%bcond_without check
%global crate ripgrep
Name: rust-%{crate}
Version: 0.10.0
Release: 4%{?dist}
Summary: Line oriented search tool using Rust's regex library
# Upstream license specification: Unlicense OR MIT
License: Unlicense or MIT
URL: https://crates.io/crates/ripgrep
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No windows
# * No simd
# * Use jit_if_available, https://github.com/BurntSushi/ripgrep/commit/eb18da04506b959c0251099eae83e16d22ce8bcb
Patch0: ripgrep-fix-metadata.diff
# Really use jit_if_available
Patch0001: 0001-pcre2-use-jit_if_available.patch
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(clap/suggestions) >= 2.32.0 with crate(clap/suggestions) < 3.0.0)
BuildRequires: (crate(grep/default) >= 0.2.3 with crate(grep/default) < 0.3.0)
BuildRequires: (crate(grep/pcre2) >= 0.2.3 with crate(grep/pcre2) < 0.3.0)
BuildRequires: (crate(ignore/default) >= 0.4.4 with crate(ignore/default) < 0.5.0)
BuildRequires: (crate(lazy_static/default) >= 1.1.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires: (crate(log/default) >= 0.4.5 with crate(log/default) < 0.5.0)
BuildRequires: (crate(num_cpus/default) >= 1.8.0 with crate(num_cpus/default) < 2.0.0)
BuildRequires: (crate(regex/default) >= 1.0.5 with crate(regex/default) < 2.0.0)
BuildRequires: (crate(serde_json/default) >= 1.0.23 with crate(serde_json/default) < 2.0.0)
BuildRequires: (crate(termcolor/default) >= 1.0.3 with crate(termcolor/default) < 2.0.0)
%if %{with check}
BuildRequires: (crate(serde/default) >= 1.0.77 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.77 with crate(serde_derive/default) < 2.0.0)
%endif
BuildRequires: %{_bindir}/a2x
%global _description \
Line oriented search tool using Rust's regex library.\
Combines the raw performance of grep with the usability of the silver searcher.
%description %{_description}
%package -n %{crate}
Summary: %{summary}
%description -n %{crate} %{_description}
%files -n %{crate}
%license LICENSE-MIT UNLICENSE COPYING
%doc README.md CHANGELOG.md
%{_bindir}/rg
%{_mandir}/man1/rg.1*
%dir %{_datadir}/bash-completion
%dir %{_datadir}/bash-completion/completions
%{_datadir}/bash-completion/completions/rg.bash
%dir %{_datadir}/fish
%dir %{_datadir}/fish/vendor_functions.d
%{_datadir}/fish/vendor_functions.d/rg.fish
%dir %{_datadir}/zsh
%dir %{_datadir}/zsh/site-functions
%{_datadir}/zsh/site-functions/_rg
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%build
%cargo_build -a
%install
%cargo_install -a
%{__install} -Dpm0644 -t %{buildroot}%{_mandir}/man1 \
target/release/build/%{crate}-*/out/rg.1
%{__install} -Dpm0644 -t %{buildroot}%{_datadir}/bash-completion/completions \
target/release/build/%{crate}-*/out/rg.bash
%{__install} -Dpm0644 -t %{buildroot}%{_datadir}/fish/vendor_functions.d \
target/release/build/%{crate}-*/out/rg.fish
%{__install} -Dpm0644 -t %{buildroot}%{_datadir}/zsh/site-functions \
complete/_rg
%if %{with check}
%check
%cargo_test -a
%endif
%changelog
* Sun Oct 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.10.0-4
- Adapt to new packaging
* Sun Oct 07 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.10.0-3
- Infra can't run tests
* Sun Oct 07 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.10.0-2
- Run tests in infrastructure
* Sun Sep 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.10.0-1
- Update to 0.10.0
* Sat Aug 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.9.0-1
- Update to 0.9.0
* Tue Jul 31 2018 Florian Weimer <fweimer@redhat.com> - 0.8.1-10
- Rebuild with fixed binutils
* Sun Jul 29 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.1-9
- Run real tests
* Sun Jul 29 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.1-8
- Bump encoding_rs to 0.8
* Thu Jul 19 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.1-7
- Bump termcolor to 1
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Thu Jun 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.1-5
- Bump regex to 1
* Wed Apr 25 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org - 0.8.1-4
- Bump globset to 0.4
* Wed Mar 14 2018 Josh Stone <jistone@redhat.com> - 0.8.1-3
- Rebuild with new regex crates
* Fri Feb 23 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.1-2
- Restore spec
* Fri Feb 23 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.1-1
- Update to 0.8.1
* Mon Feb 12 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.0-1
- Update to 0.8.0
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Tue Jan 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-9
- Rebuild for bytecount 0.3.0
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-8
- Rebuild for rust-packaging v5
* Thu Nov 30 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-7
- Bump lazy_static to 1
* Tue Nov 28 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-6
- Rebuild for clap 2.28.0
* Thu Nov 23 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-5
- Fix bash completion
* Thu Nov 23 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-4
- Package completions
* Wed Nov 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-3
- Rebuild for dependency change
* Tue Nov 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-2
- Rebuild for dependency change
* Mon Nov 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-1
- Update to 0.7.1
* Wed Jul 05 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.2-3
- Rebuild for clap
* Thu Jun 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.2-2
- Bump encoding_rs to 0.6
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.2-1
- Update to 0.5.2
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-2
- Port to use rust-packaging
* Wed Mar 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-1
- Update to 0.5.0
* Sat Mar 11 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-6
- Rename with rust prefix
* Sun Feb 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-5
- Rebuild
* Sun Feb 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-4
- Ship manpage
* Sun Feb 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-3
- Rebuild (termcolor)
* Sun Feb 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-2
- Rebuild (memmap)
* Sun Feb 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-1
- Initial package

@ -0,0 +1 @@
SHA512 (ripgrep-0.10.0.crate) = d96c12be497999d0db777ca5fd33f907ed01cba121e3fb43a7a6a5f3176291f04b7bcd6e26f04f98b305cf50ac422a77a10d6a34c3a7510d233fa76228784576
Loading…
Cancel
Save