Update to 11.0.2

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 10314b8fcc
commit 9c854490fe
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -5,3 +5,4 @@
/ripgrep-0.10.0.crate
/ripgrep-11.0.0.crate
/ripgrep-11.0.1.crate
/ripgrep-11.0.2.crate

@ -1,25 +0,0 @@
From b93762ea7a397b54e9ccf589a45a2c6ad91bc390 Mon Sep 17 00:00:00 2001
From: Andrew Gallant <jamslam@gmail.com>
Date: Wed, 26 Jun 2019 16:47:33 -0400
Subject: [PATCH] bstr: update everything to bstr 0.2
---
src/config.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/config.rs b/src/config.rs
index f0f7929..3deade9 100644
--- a/src/config.rs
+++ b/src/config.rs
@@ -9,7 +9,7 @@ use std::io;
use std::ffi::OsString;
use std::path::{Path, PathBuf};
-use bstr::io::BufReadExt;
+use bstr::{io::BufReadExt, ByteSlice};
use log;
use crate::Result;
--
2.22.0

@ -1,19 +1,12 @@
--- ripgrep-11.0.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ ripgrep-11.0.1/Cargo.toml 2019-06-27T06:59:54.367815+00:00
@@ -43,7 +43,7 @@
name = "integration"
path = "tests/tests.rs"
[dependencies.bstr]
-version = "0.1.2"
+version = "0.2.0"
[dependencies.clap]
version = "2.32.0"
@@ -88,7 +88,6 @@
--- ripgrep-11.0.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ ripgrep-11.0.2/Cargo.toml 2019-08-03T12:42:56.325256+00:00
@@ -88,9 +88,6 @@
[features]
pcre2 = ["grep/pcre2"]
-simd-accel = ["grep/simd-accel"]
-[target."cfg(all(target_env = \"musl\", target_pointer_width = \"64\"))".dependencies.jemallocator]
-version = "0.3.0"
[badges.appveyor]
repository = "BurntSushi/ripgrep"

@ -5,8 +5,8 @@
%global crate ripgrep
Name: rust-%{crate}
Version: 11.0.1
Release: 5%{?dist}
Version: 11.0.2
Release: 1%{?dist}
Summary: Line oriented search tool using Rust's regex library
# Upstream license specification: Unlicense OR MIT
@ -15,10 +15,8 @@ URL: https://crates.io/crates/ripgrep
Source: %{crates_source}
# Initial patched metadata
# * No simd
# * Update bstr to 0.2, https://github.com/BurntSushi/ripgrep/commit/b93762ea7a397b54e9ccf589a45a2c6ad91bc390
# * No jemalloc
Patch0: ripgrep-fix-metadata.diff
# Finish bstr update
Patch0001: 0001-bstr-update-everything-to-bstr-0.2.patch
ExclusiveArch: %{rust_arches}
@ -79,6 +77,9 @@ install -Dpm0644 -t %{buildroot}%{_datadir}/zsh/site-functions \
%endif
%changelog
* Sat Aug 03 14:42:56 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 11.0.2-1
- Update to 11.0.2
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 11.0.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
SHA512 (ripgrep-11.0.1.crate) = 91a06a11e94cfd595ac1cc5ed6db481cff8b319de4fb09d1d29e800b60f75a4e696df75f97e0e29d53d7d68fc3fd7cebc5ae16b1329214fb1383d454fb2b0864
SHA512 (ripgrep-11.0.2.crate) = 8a9e75ad442bc12a6b189eca39b09e890a2bbf6d9b3b55515517c97201bea8577851da443a108fe7524ec4bbe35ea624aca9c872ab31d991baab282e7265383c

Loading…
Cancel
Save