Update to version 14.0.3; Fixes RHBZ#2251763

epel10
Fabio Valentini 1 year ago
parent 0a83e8f762
commit 7a79fecd62
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -11,3 +11,4 @@
/ripgrep-12.1.0.crate
/ripgrep-12.1.1.crate
/ripgrep-13.0.0.crate
/ripgrep-14.0.3.crate

@ -1,8 +1,8 @@
--- ripgrep-13.0.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ripgrep-13.0.0/Cargo.toml 2023-05-22T11:26:12.724117+00:00
@@ -91,5 +91,3 @@
[features]
--- ripgrep-14.0.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ripgrep-14.0.3/Cargo.toml 2023-12-31T18:20:38.204348+00:00
@@ -182,5 +182,3 @@
pcre2 = ["grep/pcre2"]
simd-accel = ["grep/simd-accel"]
-[target."cfg(all(target_env = \"musl\", target_pointer_width = \"64\"))".dependencies.jemallocator]
-version = "0.3.0"
-version = "0.5.0"

@ -1,7 +1,8 @@
--- ripgrep-13.0.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ripgrep-13.0.0/Cargo.toml 2023-05-22T11:26:26.249194+00:00
@@ -90,4 +90,3 @@
--- ripgrep-14.0.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ripgrep-14.0.3/Cargo.toml 2023-12-31T18:21:01.894425+00:00
@@ -180,5 +180,3 @@
[features]
pcre2 = ["grep/pcre2"]
-simd-accel = ["grep/simd-accel"]
-

@ -1,23 +1,23 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
%bcond_without check
%global crate ripgrep
Name: rust-ripgrep
Version: 13.0.0
Version: 14.0.3
Release: %autorelease
Summary: Line-oriented search tool
License: Unlicense OR MIT
URL: https://crates.io/crates/ripgrep
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
# Automatically generated patch to strip dependencies and normalize metadata
Patch: ripgrep-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unsupported SIMD feature
Patch: ripgrep-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Ripgrep is a line-oriented search tool that recursively searches the
@ -31,11 +31,10 @@ Summary: %{summary}
# (Apache-2.0 OR MIT) AND BSD-3-Clause
# (MIT OR Apache-2.0) AND Unicode-DFS-2016
# Apache-2.0 OR BSL-1.0
# Apache-2.0 OR MIT
# MIT
# MIT OR Apache-2.0
# Unlicense OR MIT
License: BSD-3-Clause AND MIT AND Unicode-DFS-2016 AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR MIT) AND (Unlicense OR MIT)
License: BSD-3-Clause AND MIT AND Unicode-DFS-2016 AND (Apache-2.0 OR BSL-1.0) AND (MIT OR Apache-2.0) AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown
%description -n %{crate} %{_description}
@ -57,30 +56,29 @@ License: BSD-3-Clause AND MIT AND Unicode-DFS-2016 AND (Apache-2.0 OR BSL
%{zsh_completions_dir}/_rg
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires -a
echo '/usr/bin/asciidoctor'
%build
%cargo_build -a
%cargo_license_summary -a
%{cargo_license_summary -a}
%{cargo_license -a} > LICENSE.dependencies
%install
%cargo_install -a
# install manpage
install -Dpm0644 -t %{buildroot}%{_mandir}/man1 \
target/release/build/%{crate}-*/out/rg.1
# install shell completions
install -Dpm0644 -t %{buildroot}%{bash_completions_dir} \
target/release/build/%{crate}-*/out/rg.bash
install -Dpm0644 -t %{buildroot}%{fish_completions_dir} \
target/release/build/%{crate}-*/out/rg.fish
install -Dpm0644 -t %{buildroot}%{zsh_completions_dir} \
complete/_rg
# generate and install manpage
target/release/rg --generate man > rg.1
install -Dpm 0644 rg.1 -t %{buildroot}/%{_mandir}/man1/
# generate and install shell completions
target/release/rg --generate complete-bash > rg.bash
target/release/rg --generate complete-fish > rg.fish
target/release/rg --generate complete-zsh > _rg
install -Dpm 0644 rg.bash -t %{buildroot}/%{bash_completions_dir}
install -Dpm 0644 rg.fish -t %{buildroot}/%{fish_completions_dir}
install -Dpm 0644 _rg -t %{buildroot}/%{zsh_completions_dir}
%if %{with check}
%check

@ -1,4 +0,0 @@
[DEFAULT]
all-features = true
buildrequires =
/usr/bin/asciidoctor

@ -0,0 +1,6 @@
[package]
summary = "Line-oriented search tool"
[features]
enable-all = true

@ -1 +1 @@
SHA512 (ripgrep-13.0.0.crate) = 5a8b42ae941a282cbc020ffe0a83d4c6f7b29a2a00a2ed2f3ae89b182a1576d9ce2ca3a1c00f666990604b6b5b37f39332698cf3ceaa3a21287ea6480415a42b
SHA512 (ripgrep-14.0.3.crate) = d52b9a89152a0f8f5c90d3bfe234a7f0c50b5803e46385903cf18027bf8a574a0587f79afde1a1ba70fe74c87c6a35d0649b9ab3dd410dff892ad13cb6b31bef

Loading…
Cancel
Save