bump lazy_static to 1

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 5f6675471e
commit 72a0bfe5ac

@ -1,5 +1,5 @@
--- ripgrep-0.7.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ ripgrep-0.7.1/Cargo.toml 2017-11-13T19:08:07.316443+01:00
+++ ripgrep-0.7.1/Cargo.toml 2017-11-30T23:33:01.940349+01:00
@@ -57,10 +57,10 @@
version = "0.1.7"
@ -13,6 +13,15 @@
[dependencies.num_cpus]
version = "1"
@@ -69,7 +69,7 @@
version = "2"
[dependencies.lazy_static]
-version = "0.2"
+version = "1"
[dependencies.env_logger]
version = "0.4"
@@ -90,8 +90,6 @@
version = "0.2"

@ -5,7 +5,7 @@
Name: rust-%{crate}
Version: 0.7.1
Release: 6%{?dist}
Release: 7%{?dist}
Summary: Line oriented search tool using Rust's regex library
License: Unlicense or MIT
@ -15,6 +15,7 @@ Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{
# * No simd
# * Bump memmap to 0.6, https://github.com/BurntSushi/ripgrep/pull/657
# * Bump bytecount to 0.2, https://github.com/BurntSushi/ripgrep/pull/679
# * Bump lazy_static to 1, https://github.com/BurntSushi/ripgrep/pull/699
Patch0: ripgrep-0.7.1-fix-metadata.diff
# Really make code compatible with memmap v0.6
Patch1: 0001-Update-to-memmap-0.6.patch
@ -30,7 +31,7 @@ BuildRequires: (crate(encoding_rs) >= 0.7.0 with crate(encoding_rs) < 0.8.0)
BuildRequires: (crate(env_logger) >= 0.4.0 with crate(env_logger) < 0.5.0)
BuildRequires: (crate(grep) >= 0.1.7 with crate(grep) < 0.2.0)
BuildRequires: (crate(ignore) >= 0.3.1 with crate(ignore) < 0.4.0)
BuildRequires: (crate(lazy_static) >= 0.2.0 with crate(lazy_static) < 0.3.0)
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
BuildRequires: (crate(log) >= 0.3.0 with crate(log) < 0.4.0)
BuildRequires: (crate(memchr) >= 2.0.0 with crate(memchr) < 3.0.0)
@ -91,6 +92,9 @@ the raw performance of grep with the usability of the silver searcher.
%{_datadir}/zsh/site-functions/_rg
%changelog
* Thu Nov 30 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-7
- Bump lazy_static to 1
* Tue Nov 28 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-6
- Rebuild for clap 2.28.0

Loading…
Cancel
Save