update to 11.0.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 3ce92c0730
commit 2c988849a2
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -3,3 +3,4 @@
/ripgrep-0.8.1.crate /ripgrep-0.8.1.crate
/ripgrep-0.9.0.crate /ripgrep-0.9.0.crate
/ripgrep-0.10.0.crate /ripgrep-0.10.0.crate
/ripgrep-11.0.0.crate

@ -1,29 +0,0 @@
From eb18da04506b959c0251099eae83e16d22ce8bcb Mon Sep 17 00:00:00 2001
From: Andrew Gallant <jamslam@gmail.com>
Date: Sat, 8 Sep 2018 17:12:14 -0400
Subject: [PATCH] pcre2: use jit_if_available
This will allow PCRE2 to fall back to non-JIT matching when running on
platforms without JIT support.
ref https://github.com/BurntSushi/rust-pcre2/issues/3
---
src/args.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/args.rs b/src/args.rs
index 1a38d3e..7aed914 100644
--- a/src/args.rs
+++ b/src/args.rs
@@ -633,7 +633,7 @@ impl ArgMatches {
// For whatever reason, the JIT craps out during regex compilation with
// a "no more memory" error on 32 bit systems. So don't use it there.
if !cfg!(target_pointer_width = "32") {
- builder.jit(true);
+ builder.jit_if_available(true);
}
if self.pcre2_unicode() {
builder.utf(true).ucp(true);
--
2.19.0.rc1

@ -1,19 +1,8 @@
--- ripgrep-0.10.0/Cargo.toml 1970-01-01T00:00:00+00:00 --- ripgrep-11.0.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ ripgrep-0.10.0/Cargo.toml 2019-03-18T20:02:51.294278+00:00 +++ ripgrep-11.0.0/Cargo.toml 2019-04-16T11:46:32.175110+00:00
@@ -46,7 +46,7 @@ @@ -88,7 +88,6 @@
default-features = false
[dependencies.grep]
-version = "0.2.2"
+version = "0.2.3"
[dependencies.ignore]
version = "0.4.4"
@@ -82,9 +82,7 @@
version = "1.1.0"
[features] [features]
-avx-accel = ["grep/avx-accel"]
pcre2 = ["grep/pcre2"] pcre2 = ["grep/pcre2"]
-simd-accel = ["grep/simd-accel"] -simd-accel = ["grep/simd-accel"]
[badges.appveyor] [badges.appveyor]

@ -4,8 +4,8 @@
%global crate ripgrep %global crate ripgrep
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.10.0 Version: 11.0.0
Release: 4%{?dist} Release: 1%{?dist}
Summary: Line oriented search tool using Rust's regex library Summary: Line oriented search tool using Rust's regex library
# Upstream license specification: Unlicense OR MIT # Upstream license specification: Unlicense OR MIT
@ -13,20 +13,17 @@ License: Unlicense or MIT
URL: https://crates.io/crates/ripgrep URL: https://crates.io/crates/ripgrep
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * No windows
# * No simd # * No simd
# * Use jit_if_available, https://github.com/BurntSushi/ripgrep/commit/eb18da04506b959c0251099eae83e16d22ce8bcb
Patch0: ripgrep-fix-metadata.diff Patch0: ripgrep-fix-metadata.diff
# Really use jit_if_available
Patch0001: 0001-pcre2-use-jit_if_available.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging
BuildRequires: (crate(bstr/default) >= 0.1.2 with crate(bstr/default) < 0.2.0)
BuildRequires: (crate(clap/suggestions) >= 2.32.0 with crate(clap/suggestions) < 3.0.0) BuildRequires: (crate(clap/suggestions) >= 2.32.0 with crate(clap/suggestions) < 3.0.0)
BuildRequires: (crate(grep/default) >= 0.2.3 with crate(grep/default) < 0.3.0) BuildRequires: (crate(grep/default) >= 0.2.4 with crate(grep/default) < 0.3.0)
BuildRequires: (crate(grep/pcre2) >= 0.2.3 with crate(grep/pcre2) < 0.3.0) BuildRequires: (crate(grep/pcre2) >= 0.2.4 with crate(grep/pcre2) < 0.3.0)
BuildRequires: (crate(ignore/default) >= 0.4.4 with crate(ignore/default) < 0.5.0) BuildRequires: (crate(ignore/default) >= 0.4.7 with crate(ignore/default) < 0.5.0)
BuildRequires: (crate(lazy_static/default) >= 1.1.0 with crate(lazy_static/default) < 2.0.0) BuildRequires: (crate(lazy_static/default) >= 1.1.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires: (crate(log/default) >= 0.4.5 with crate(log/default) < 0.5.0) BuildRequires: (crate(log/default) >= 0.4.5 with crate(log/default) < 0.5.0)
BuildRequires: (crate(num_cpus/default) >= 1.8.0 with crate(num_cpus/default) < 2.0.0) BuildRequires: (crate(num_cpus/default) >= 1.8.0 with crate(num_cpus/default) < 2.0.0)
@ -89,6 +86,9 @@ Summary: %{summary}
%endif %endif
%changelog %changelog
* Tue Apr 16 13:45:20 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 11.0.0-1
- Update to 11.0.0
* Sun Oct 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.10.0-4 * Sun Oct 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.10.0-4
- Adapt to new packaging - Adapt to new packaging

@ -1 +1 @@
SHA512 (ripgrep-0.10.0.crate) = d96c12be497999d0db777ca5fd33f907ed01cba121e3fb43a7a6a5f3176291f04b7bcd6e26f04f98b305cf50ac422a77a10d6a34c3a7510d233fa76228784576 SHA512 (ripgrep-11.0.0.crate) = 22046f36c23d4d17f3108f49596777d8d1332ee2ab16ad980079f97450ecb77b170534357b5b74455a4eb5197121f5090c398e590061f0ddf0d03ea8fe2e6588

Loading…
Cancel
Save