parent
844193e373
commit
1269748895
@ -0,0 +1,29 @@
|
|||||||
|
From eb18da04506b959c0251099eae83e16d22ce8bcb Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Gallant <jamslam@gmail.com>
|
||||||
|
Date: Sat, 8 Sep 2018 17:12:14 -0400
|
||||||
|
Subject: [PATCH] pcre2: use jit_if_available
|
||||||
|
|
||||||
|
This will allow PCRE2 to fall back to non-JIT matching when running on
|
||||||
|
platforms without JIT support.
|
||||||
|
|
||||||
|
ref https://github.com/BurntSushi/rust-pcre2/issues/3
|
||||||
|
---
|
||||||
|
src/args.rs | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/args.rs b/src/args.rs
|
||||||
|
index 1a38d3e..7aed914 100644
|
||||||
|
--- a/src/args.rs
|
||||||
|
+++ b/src/args.rs
|
||||||
|
@@ -633,7 +633,7 @@ impl ArgMatches {
|
||||||
|
// For whatever reason, the JIT craps out during regex compilation with
|
||||||
|
// a "no more memory" error on 32 bit systems. So don't use it there.
|
||||||
|
if !cfg!(target_pointer_width = "32") {
|
||||||
|
- builder.jit(true);
|
||||||
|
+ builder.jit_if_available(true);
|
||||||
|
}
|
||||||
|
if self.pcre2_unicode() {
|
||||||
|
builder.utf(true).ucp(true);
|
||||||
|
--
|
||||||
|
2.19.0.rc1
|
||||||
|
|
@ -1,16 +0,0 @@
|
|||||||
--- ripgrep-0.9.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
|
||||||
+++ ripgrep-0.9.0/Cargo.toml 2018-08-04T15:54:39.175546+02:00
|
|
||||||
@@ -95,13 +95,6 @@
|
|
||||||
|
|
||||||
[build-dependencies.lazy_static]
|
|
||||||
version = "1"
|
|
||||||
-
|
|
||||||
-[features]
|
|
||||||
-avx-accel = ["bytecount/avx-accel"]
|
|
||||||
-simd-accel = ["bytecount/simd-accel", "encoding_rs/simd-accel"]
|
|
||||||
-[target."cfg(windows)".dependencies.winapi]
|
|
||||||
-version = "0.3"
|
|
||||||
-features = ["std", "winnt"]
|
|
||||||
[badges.appveyor]
|
|
||||||
repository = "BurntSushi/ripgrep"
|
|
||||||
|
|
@ -0,0 +1,21 @@
|
|||||||
|
--- ripgrep-0.10.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ ripgrep-0.10.0/Cargo.toml 2018-09-09T00:13:34.769746+02:00
|
||||||
|
@@ -46,7 +46,7 @@
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
[dependencies.grep]
|
||||||
|
-version = "0.2.2"
|
||||||
|
+version = "0.2.3"
|
||||||
|
|
||||||
|
[dependencies.ignore]
|
||||||
|
version = "0.4.4"
|
||||||
|
@@ -82,9 +82,7 @@
|
||||||
|
version = "1.1.0"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
-avx-accel = ["grep/avx-accel"]
|
||||||
|
pcre2 = ["grep/pcre2"]
|
||||||
|
-simd-accel = ["grep/simd-accel"]
|
||||||
|
[badges.appveyor]
|
||||||
|
repository = "BurntSushi/ripgrep"
|
||||||
|
|
@ -1 +1 @@
|
|||||||
SHA512 (ripgrep-0.9.0.crate) = 8adab0f95421e853b813d74d6c45cfbcf6fe9485f445fc79e34fe53ac59f81dce727d1551a2a99effdf8b7c479681927c1dbeba86bce55dab8353e8a7e0db60b
|
SHA512 (ripgrep-0.10.0.crate) = d96c12be497999d0db777ca5fd33f907ed01cba121e3fb43a7a6a5f3176291f04b7bcd6e26f04f98b305cf50ac422a77a10d6a34c3a7510d233fa76228784576
|
||||||
|
Loading…
Reference in new issue