import rust-ring-0.17.6-1.el9

i9ce changed/i9ce/rust-ring-0.17.6-1.el9
Arkady L. Shane 1 year ago
commit 8498f962be
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

Binary file not shown.

@ -0,0 +1,25 @@
--- ring-0.17.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ring-0.17.6/Cargo.toml 2023-11-30T11:36:38.885312+00:00
@@ -219,17 +219,6 @@
version = "0.2.148"
default-features = false
-[target."cfg(all(target_arch = \"aarch64\", target_os = \"windows\"))".dependencies.windows-sys]
-version = "0.48"
-features = [
- "Win32_Foundation",
- "Win32_System_Threading",
-]
-
-[target."cfg(all(target_arch = \"wasm32\", target_os = \"unknown\"))".dev-dependencies.wasm-bindgen-test]
-version = "0.3.37"
-default-features = false
-
[target."cfg(any(target_arch = \"x86\",target_arch = \"x86_64\", all(any(target_arch = \"aarch64\", target_arch = \"arm\"), any(target_os = \"android\", target_os = \"fuchsia\", target_os = \"linux\", target_os = \"windows\"))))".dependencies.spin]
version = "0.9.8"
features = ["once"]
@@ -238,3 +227,4 @@
[target."cfg(any(unix, windows, target_os = \"wasi\"))".dev-dependencies.libc]
version = "0.2.148"
default-features = false
+

@ -0,0 +1,21 @@
--- ring-0.17.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ring-0.17.6/Cargo.toml 2023-11-30T11:37:21.742455+00:00
@@ -165,7 +165,7 @@
"cryptography",
"no-std",
]
-license-file = "LICENSE"
+license = "ISC AND MIT AND OpenSSL"
repository = "https://github.com/briansmith/ring"
[package.metadata.docs.rs]
@@ -211,9 +211,6 @@
slow_tests = []
std = ["alloc"]
test_logging = []
-unstable-testing-arm-no-hw = []
-unstable-testing-arm-no-neon = []
-wasm32_unknown_unknown_js = ["getrandom/js"]
[target."cfg(all(any(target_os = \"android\", target_os = \"linux\"), any(target_arch = \"aarch64\", target_arch = \"arm\")))".dependencies.libc]
version = "0.2.148"

@ -0,0 +1,202 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 25
# * test fixtures are not included in published crates
%bcond_with check
%global debug_package %{nil}
%global crate ring
Name: rust-ring
Version: 0.17.6
Release: %autorelease
Summary: Safe, fast, small crypto using Rust
License: ISC AND MIT AND OpenSSL
URL: https://crates.io/crates/ring
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: ring-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * set package.license in metadata to match package license
# * drop unstable / WASM-only features
Patch: ring-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Safe, fast, small crypto using Rust.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%license %{crate_instdir}/third_party/fiat/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dev_urandom_fallback-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dev_urandom_fallback-devel %{_description}
This package contains library source intended for building other packages which
use the "dev_urandom_fallback" feature of the "%{crate}" crate.
%files -n %{name}+dev_urandom_fallback-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+less-safe-getrandom-custom-or-rdrand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+less-safe-getrandom-custom-or-rdrand-devel %{_description}
This package contains library source intended for building other packages which
use the "less-safe-getrandom-custom-or-rdrand" feature of the "%{crate}" crate.
%files -n %{name}+less-safe-getrandom-custom-or-rdrand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+slow_tests-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+slow_tests-devel %{_description}
This package contains library source intended for building other packages which
use the "slow_tests" feature of the "%{crate}" crate.
%files -n %{name}+slow_tests-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+test_logging-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+test_logging-devel %{_description}
This package contains library source intended for building other packages which
use the "test_logging" feature of the "%{crate}" crate.
%files -n %{name}+test_logging-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.17.6-1
- Rebuilt for MSVSphere 9.3
* Thu Nov 30 2023 Fabio Valentini <decathorpe@gmail.com> - 0.17.6-1
- Update to version 0.17.6; Fixes RHBZ#2251978
* Fri Oct 27 2023 Fabio Valentini <decathorpe@gmail.com> - 0.17.5-1
- Update to version 0.17.5; Fixes RHBZ#2241702
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.20-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sat Apr 01 2023 Fabio Valentini <decathorpe@gmail.com> - 0.16.20-7
- Remove ExcludeArch but only compile on supported architectures
* Sat Mar 18 2023 Fabio Valentini <decathorpe@gmail.com> - 0.16.20-6
- Regenerate with rust2rpm v24 and fix package.license in metadata
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.20-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.20-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.20-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Thu Jan 06 2022 Fabio Valentini <decathorpe@gmail.com> - 0.16.20-2
- Skip doctests on i686 to work around LLVM codegen issues
* Thu Jan 06 2022 Fabio Valentini <decathorpe@gmail.com> - 0.16.20-1
- Update to version 0.16.20; Fixes RHBZ#2033456
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.19-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.19-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Sun Jan 03 15:05:55 CET 2021 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.16.19-1
- Update to 0.16.19
* Thu Jul 30 2020 Peter Robinson <pbrobinson@fedorapeople.org> - 0.16.15-1
- Initial package
Loading…
Cancel
Save