parent
0849b68bd3
commit
4203d54451
@ -0,0 +1,31 @@
|
|||||||
|
--- ring-0.16.20/Cargo.toml 2021-02-01T22:20:41+00:00
|
||||||
|
+++ ring-0.16.20/Cargo.toml 2023-03-18T22:05:06.357486+00:00
|
||||||
|
@@ -60,10 +60,6 @@
|
||||||
|
std = ["alloc"]
|
||||||
|
test_logging = []
|
||||||
|
wasm32_c = []
|
||||||
|
-[target."cfg(all(target_arch = \"wasm32\", target_vendor = \"unknown\", target_os = \"unknown\", target_env = \"\"))".dependencies.web-sys]
|
||||||
|
-version = "0.3.37"
|
||||||
|
-features = ["Crypto", "Window"]
|
||||||
|
-default-features = false
|
||||||
|
[target."cfg(any(target_arch = \"x86\",target_arch = \"x86_64\", all(any(target_arch = \"aarch64\", target_arch = \"arm\"), any(target_os = \"android\", target_os = \"fuchsia\", target_os = \"linux\"))))".dependencies.spin]
|
||||||
|
version = "0.5.2"
|
||||||
|
default-features = false
|
||||||
|
@@ -76,17 +72,6 @@
|
||||||
|
features = ["std"]
|
||||||
|
optional = true
|
||||||
|
default-features = false
|
||||||
|
-[target."cfg(any(target_os = \"dragonfly\", target_os = \"freebsd\", target_os = \"illumos\", target_os = \"netbsd\", target_os = \"openbsd\", target_os = \"solaris\"))".dependencies.once_cell]
|
||||||
|
-version = "1.5.2"
|
||||||
|
-features = ["std"]
|
||||||
|
-default-features = false
|
||||||
|
[target."cfg(any(unix, windows))".dev-dependencies.libc]
|
||||||
|
version = "0.2.80"
|
||||||
|
default-features = false
|
||||||
|
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
|
||||||
|
-version = "0.3.18"
|
||||||
|
-default-features = false
|
||||||
|
-[target."cfg(target_os = \"windows\")".dependencies.winapi]
|
||||||
|
-version = "0.3.8"
|
||||||
|
-features = ["ntsecapi", "wtypesbase"]
|
||||||
|
-default-features = false
|
@ -1,31 +1,29 @@
|
|||||||
--- ring-0.16.20/Cargo.toml 2021-02-01T22:20:41+00:00
|
--- ring-0.16.20/Cargo.toml 2021-02-01T22:20:41+00:00
|
||||||
+++ ring-0.16.20/Cargo.toml 2022-01-06T21:12:48.064914+00:00
|
+++ ring-0.16.20/Cargo.toml 2023-03-18T22:06:09.210728+00:00
|
||||||
@@ -60,10 +60,6 @@
|
@@ -23,25 +23,10 @@
|
||||||
std = ["alloc"]
|
readme = "doc/link-to-readme.md"
|
||||||
test_logging = []
|
keywords = ["crypto", "cryptography", "rand", "ECC", "RSA"]
|
||||||
wasm32_c = []
|
categories = ["cryptography", "no-std"]
|
||||||
-[target."cfg(all(target_arch = \"wasm32\", target_vendor = \"unknown\", target_os = \"unknown\", target_env = \"\"))".dependencies.web-sys]
|
-license-file = "LICENSE"
|
||||||
-version = "0.3.37"
|
+license = "ISC AND OpenSSL AND MIT"
|
||||||
-features = ["Crypto", "Window"]
|
repository = "https://github.com/briansmith/ring"
|
||||||
-default-features = false
|
[package.metadata.docs.rs]
|
||||||
[target."cfg(any(target_arch = \"x86\",target_arch = \"x86_64\", all(any(target_arch = \"aarch64\", target_arch = \"arm\"), any(target_os = \"android\", target_os = \"fuchsia\", target_os = \"linux\"))))".dependencies.spin]
|
all-features = true
|
||||||
version = "0.5.2"
|
-[profile.bench]
|
||||||
default-features = false
|
-opt-level = 3
|
||||||
@@ -76,17 +72,6 @@
|
-lto = true
|
||||||
features = ["std"]
|
-codegen-units = 1
|
||||||
optional = true
|
-debug = false
|
||||||
default-features = false
|
-debug-assertions = false
|
||||||
-[target."cfg(any(target_os = \"dragonfly\", target_os = \"freebsd\", target_os = \"illumos\", target_os = \"netbsd\", target_os = \"openbsd\", target_os = \"solaris\"))".dependencies.once_cell]
|
-rpath = false
|
||||||
-version = "1.5.2"
|
-
|
||||||
-features = ["std"]
|
-[profile.release]
|
||||||
-default-features = false
|
-opt-level = 3
|
||||||
[target."cfg(any(unix, windows))".dev-dependencies.libc]
|
-lto = true
|
||||||
version = "0.2.80"
|
-codegen-units = 1
|
||||||
default-features = false
|
-debug = false
|
||||||
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
|
-debug-assertions = false
|
||||||
-version = "0.3.18"
|
-rpath = false
|
||||||
-default-features = false
|
|
||||||
-[target."cfg(target_os = \"windows\")".dependencies.winapi]
|
[lib]
|
||||||
-version = "0.3.8"
|
name = "ring"
|
||||||
-features = ["ntsecapi", "wtypesbase"]
|
|
||||||
-default-features = false
|
|
||||||
|
Loading…
Reference in new issue