Update to version 0.17.5; Fixes RHBZ#2241702

epel9
Fabio Valentini 1 year ago
parent e73111c1fd
commit 2bebab6bd0
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,31 +1,25 @@
--- ring-0.16.20/Cargo.toml 2021-02-01T22:20:41+00:00 --- ring-0.17.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ring-0.16.20/Cargo.toml 2023-04-01T14:08:54.743609+00:00 +++ ring-0.17.5/Cargo.toml 2023-10-25T13:04:09.102675+00:00
@@ -60,10 +60,6 @@ @@ -214,17 +214,6 @@
std = ["alloc"] unstable-testing-arm-no-neon = []
test_logging = [] wasm32_unknown_unknown_js = ["getrandom/js"]
wasm32_c = []
-[target."cfg(all(target_arch = \"wasm32\", target_vendor = \"unknown\", target_os = \"unknown\", target_env = \"\"))".dependencies.web-sys] -[target."cfg(all(target_arch = \"aarch64\", target_os = \"windows\"))".dependencies.windows-sys]
-version = "0.48"
-features = [
- "Win32_Foundation",
- "Win32_System_Threading",
-]
-
-[target."cfg(all(target_arch = \"wasm32\", target_os = \"unknown\"))".dev-dependencies.wasm-bindgen-test]
-version = "0.3.37" -version = "0.3.37"
-features = ["Crypto", "Window"]
-default-features = false -default-features = false
[target."cfg(any(target_arch = \"x86\",target_arch = \"x86_64\", all(any(target_arch = \"aarch64\", target_arch = \"arm\"), any(target_os = \"android\", target_os = \"fuchsia\", target_os = \"linux\"))))".dependencies.spin] -
version = "0.5.2" [target."cfg(any(target_arch = \"x86\",target_arch = \"x86_64\", all(any(target_arch = \"aarch64\", target_arch = \"arm\"), any(target_os = \"android\", target_os = \"fuchsia\", target_os = \"linux\", target_os = \"windows\"))))".dependencies.spin]
version = "0.9.8"
features = ["once"]
@@ -237,3 +226,4 @@
[target."cfg(any(unix, windows, target_os = \"wasi\"))".dev-dependencies.libc]
version = "0.2.148"
default-features = false default-features = false
@@ -76,17 +72,6 @@ +
features = ["std"]
optional = true
default-features = false
-[target."cfg(any(target_os = \"dragonfly\", target_os = \"freebsd\", target_os = \"illumos\", target_os = \"netbsd\", target_os = \"openbsd\", target_os = \"solaris\"))".dependencies.once_cell]
-version = "1.5.2"
-features = ["std"]
-default-features = false
[target."cfg(any(unix, windows))".dev-dependencies.libc]
version = "0.2.80"
default-features = false
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
-version = "0.3.18"
-default-features = false
-[target."cfg(target_os = \"windows\")".dependencies.winapi]
-version = "0.3.8"
-features = ["ntsecapi", "wtypesbase"]
-default-features = false

@ -1,29 +1,21 @@
--- ring-0.16.20/Cargo.toml 2021-02-01T22:20:41+00:00 --- ring-0.17.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ring-0.16.20/Cargo.toml 2023-04-01T14:09:25.801749+00:00 +++ ring-0.17.5/Cargo.toml 2023-10-25T13:04:28.092749+00:00
@@ -23,25 +23,10 @@ @@ -165,7 +165,7 @@
readme = "doc/link-to-readme.md" "cryptography",
keywords = ["crypto", "cryptography", "rand", "ECC", "RSA"] "no-std",
categories = ["cryptography", "no-std"] ]
-license-file = "LICENSE" -license-file = "LICENSE"
+license = "ISC AND OpenSSL AND MIT" +license = "ISC AND MIT AND OpenSSL"
repository = "https://github.com/briansmith/ring" repository = "https://github.com/briansmith/ring"
[package.metadata.docs.rs] [package.metadata.docs.rs]
all-features = true @@ -210,9 +210,6 @@
-[profile.bench] slow_tests = []
-opt-level = 3 std = ["alloc"]
-lto = true test_logging = []
-codegen-units = 1 -unstable-testing-arm-no-hw = []
-debug = false -unstable-testing-arm-no-neon = []
-debug-assertions = false -wasm32_unknown_unknown_js = ["getrandom/js"]
-rpath = false
-
-[profile.release]
-opt-level = 3
-lto = true
-codegen-units = 1
-debug = false
-debug-assertions = false
-rpath = false
[lib] [target."cfg(any(target_arch = \"x86\",target_arch = \"x86_64\", all(any(target_arch = \"aarch64\", target_arch = \"arm\"), any(target_os = \"android\", target_os = \"fuchsia\", target_os = \"linux\", target_os = \"windows\"))))".dependencies.spin]
name = "ring" version = "0.9.8"

@ -1,30 +1,26 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check # * test fixtures are not included in published crates
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate ring %global crate ring
# compile and run tests only on supported architectures
# https://bugzilla.redhat.com/show_bug.cgi?id=1869980
%global supported_arches x86_64 %{ix86} aarch64 %{arm}
Name: rust-ring Name: rust-ring
Version: 0.16.20 Version: 0.17.5
Release: %autorelease Release: %autorelease
Summary: Safe, fast, small crypto using Rust Summary: Safe, fast, small crypto using Rust
# https://github.com/briansmith/ring/issues/902 License: ISC AND MIT AND OpenSSL
License: ISC AND OpenSSL AND MIT
URL: https://crates.io/crates/ring URL: https://crates.io/crates/ring
Source: %{crates_source} Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies # Automatically generated patch to strip dependencies and normalize metadata
Patch: ring-fix-metadata-auto.diff Patch: ring-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * drop profiles that set compiler flags that are incompatible with packaging
# * set package.license in metadata to match package license # * set package.license in metadata to match package license
# * drop unstable / WASM-only features
Patch: ring-fix-metadata.diff Patch: ring-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
Safe, fast, small crypto using Rust.} Safe, fast, small crypto using Rust.}
@ -43,6 +39,7 @@ use the "%{crate}" crate.
%files devel %files devel
%license %{crate_instdir}/LICENSE %license %{crate_instdir}/LICENSE
%license %{crate_instdir}/third_party/fiat/LICENSE %license %{crate_instdir}/third_party/fiat/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/ %{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
@ -81,30 +78,6 @@ use the "dev_urandom_fallback" feature of the "%{crate}" crate.
%files -n %{name}+dev_urandom_fallback-devel %files -n %{name}+dev_urandom_fallback-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+internal_benches-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+internal_benches-devel %{_description}
This package contains library source intended for building other packages which
use the "internal_benches" feature of the "%{crate}" crate.
%files -n %{name}+internal_benches-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+once_cell-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+once_cell-devel %{_description}
This package contains library source intended for building other packages which
use the "once_cell" feature of the "%{crate}" crate.
%files -n %{name}+once_cell-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+slow_tests-devel %package -n %{name}+slow_tests-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -141,40 +114,22 @@ use the "test_logging" feature of the "%{crate}" crate.
%files -n %{name}+test_logging-devel %files -n %{name}+test_logging-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+wasm32_c-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+wasm32_c-devel %{_description}
This package contains library source intended for building other packages which
use the "wasm32_c" feature of the "%{crate}" crate.
%files -n %{name}+wasm32_c-devel
%ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires %cargo_generate_buildrequires
%build %build
%ifarch %{supported_arches}
%cargo_build %cargo_build
%endif
%install %install
%cargo_install %cargo_install
%if %{with check} %if %{with check}
%ifarch %{supported_arches}
%check %check
# * files needed for integration tests are not included in published crates %cargo_test
%cargo_test -- --lib
%cargo_test -- --doc
%endif
%endif %endif
%changelog %changelog

@ -1,6 +0,0 @@
[DEFAULT]
supported-arches =
x86_64
%{ix86}
aarch64
%{arm}

@ -0,0 +1,4 @@
[tests]
run = ["none"]
comments = ["test fixtures are not included in published crates"]

@ -1 +1 @@
SHA512 (ring-0.16.20.crate) = d97d1b08eb796d4c107426ff2c015ab1f221612500c8a57fca8e3f064e8c0f5ae2a5e6071d013313cd9f4be8fed4ba03beae84bd446f56b2b2ca5d483c328191 SHA512 (ring-0.17.5.crate) = d4fe515031ee3545d257651d07fd23c670b313c64a26af33fe93bbdd006219908c1d2ff1b382ebfe3a85e8aae1a69f0693ccb640edc0a1f51a3af783c20b6df2

Loading…
Cancel
Save