Update to version 0.16.20; Fixes RHBZ#2033456

epel9
Fabio Valentini 3 years ago
parent 688e82fb66
commit 1892de0e56
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,6 +1,6 @@
--- ring-0.16.19/Cargo.toml 2020-12-02T02:20:32+00:00 --- ring-0.16.20/Cargo.toml 2021-02-01T22:20:41+00:00
+++ ring-0.16.19/Cargo.toml 2021-01-03T14:05:55.472720+00:00 +++ ring-0.16.20/Cargo.toml 2022-01-06T21:12:48.064914+00:00
@@ -58,10 +58,6 @@ @@ -60,10 +60,6 @@
std = ["alloc"] std = ["alloc"]
test_logging = [] test_logging = []
wasm32_c = [] wasm32_c = []
@ -11,7 +11,7 @@
[target."cfg(any(target_arch = \"x86\",target_arch = \"x86_64\", all(any(target_arch = \"aarch64\", target_arch = \"arm\"), any(target_os = \"android\", target_os = \"fuchsia\", target_os = \"linux\"))))".dependencies.spin] [target."cfg(any(target_arch = \"x86\",target_arch = \"x86_64\", all(any(target_arch = \"aarch64\", target_arch = \"arm\"), any(target_os = \"android\", target_os = \"fuchsia\", target_os = \"linux\"))))".dependencies.spin]
version = "0.5.2" version = "0.5.2"
default-features = false default-features = false
@@ -74,17 +70,6 @@ @@ -76,17 +72,6 @@
features = ["std"] features = ["std"]
optional = true optional = true
default-features = false default-features = false

@ -1,11 +1,11 @@
# Generated by rust2rpm 17 # Generated by rust2rpm 20
%bcond_with check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate ring %global crate ring
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.16.19 Version: 0.16.20
Release: %autorelease Release: %autorelease
Summary: Safe, fast, small crypto using Rust Summary: Safe, fast, small crypto using Rust
@ -15,14 +15,13 @@ License: ISC and OpenSSL and MIT
URL: https://crates.io/crates/ring URL: https://crates.io/crates/ring
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * drop dependencies that are specific to non-linux targets
Patch0: ring-fix-metadata.diff Patch0: ring-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
# RHBZ 1869980 # ring does not support s390x and ppc64le:
# https://bugzilla.redhat.com/show_bug.cgi?id=1869980
ExcludeArch: s390x %{power64} ExcludeArch: s390x %{power64}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
@ -37,12 +36,11 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE %license LICENSE LICENSE-fiat
%doc doc/link-to-readme.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
@ -51,8 +49,8 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -63,8 +61,8 @@ BuildArch: noarch
%description -n %{name}+alloc-devel %{_description} %description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "alloc" feature of "%{crate}" crate. use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel %files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -75,8 +73,8 @@ BuildArch: noarch
%description -n %{name}+dev_urandom_fallback-devel %{_description} %description -n %{name}+dev_urandom_fallback-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "dev_urandom_fallback" feature of "%{crate}" crate. use the "dev_urandom_fallback" feature of the "%{crate}" crate.
%files -n %{name}+dev_urandom_fallback-devel %files -n %{name}+dev_urandom_fallback-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -87,8 +85,8 @@ BuildArch: noarch
%description -n %{name}+internal_benches-devel %{_description} %description -n %{name}+internal_benches-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "internal_benches" feature of "%{crate}" crate. use the "internal_benches" feature of the "%{crate}" crate.
%files -n %{name}+internal_benches-devel %files -n %{name}+internal_benches-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -99,8 +97,8 @@ BuildArch: noarch
%description -n %{name}+once_cell-devel %{_description} %description -n %{name}+once_cell-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "once_cell" feature of "%{crate}" crate. use the "once_cell" feature of the "%{crate}" crate.
%files -n %{name}+once_cell-devel %files -n %{name}+once_cell-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -111,8 +109,8 @@ BuildArch: noarch
%description -n %{name}+slow_tests-devel %{_description} %description -n %{name}+slow_tests-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "slow_tests" feature of "%{crate}" crate. use the "slow_tests" feature of the "%{crate}" crate.
%files -n %{name}+slow_tests-devel %files -n %{name}+slow_tests-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -123,8 +121,8 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description} %description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "std" feature of "%{crate}" crate. use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -135,8 +133,8 @@ BuildArch: noarch
%description -n %{name}+test_logging-devel %{_description} %description -n %{name}+test_logging-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "test_logging" feature of "%{crate}" crate. use the "test_logging" feature of the "%{crate}" crate.
%files -n %{name}+test_logging-devel %files -n %{name}+test_logging-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -147,8 +145,8 @@ BuildArch: noarch
%description -n %{name}+wasm32_c-devel %{_description} %description -n %{name}+wasm32_c-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "wasm32_c" feature of "%{crate}" crate. use the "wasm32_c" feature of the "%{crate}" crate.
%files -n %{name}+wasm32_c-devel %files -n %{name}+wasm32_c-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -156,6 +154,7 @@ which use "wasm32_c" feature of "%{crate}" crate.
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
cp third_party/fiat/LICENSE LICENSE-fiat
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires %cargo_generate_buildrequires
@ -168,7 +167,9 @@ which use "wasm32_c" feature of "%{crate}" crate.
%if %{with check} %if %{with check}
%check %check
%cargo_test # * test files for some integration tests are not included in published crates
%cargo_test -- --lib
%cargo_test -- --doc
%endif %endif
%changelog %changelog

@ -1 +1 @@
SHA512 (ring-0.16.19.crate) = 86dff6211232c6175c395d8716dc767929841efc34af5f2892d1661e794dffd20bd7df3cb1f68f1fef57ae4636398f9d0be8ad0c2925067545e6bad2d3f023bb SHA512 (ring-0.16.20.crate) = d97d1b08eb796d4c107426ff2c015ab1f221612500c8a57fca8e3f064e8c0f5ae2a5e6071d013313cd9f4be8fed4ba03beae84bd446f56b2b2ca5d483c328191

Loading…
Cancel
Save