update to version 0.11.1

epel9
Fabio Valentini 4 years ago
parent b35750eb7d
commit cb3facc586
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -11,3 +11,4 @@
/reqwest-0.10.6.crate
/reqwest-0.10.8.crate
/reqwest-0.10.9.crate
/reqwest-0.11.1.crate

@ -1,8 +1,8 @@
--- reqwest-0.10.9/Cargo.toml 2020-11-20T00:04:44+00:00
+++ reqwest-0.10.9/Cargo.toml 2020-11-20T11:13:26.629492+00:00
@@ -251,21 +251,3 @@
version = "0.2.0"
features = ["macros"]
--- reqwest-0.11.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ reqwest-0.11.1/Cargo.toml 2021-03-06T21:31:58.165069+00:00
@@ -266,20 +266,3 @@
version = "1.0"
features = ["macros", "rt-multi-thread"]
default-features = false
-[target."cfg(target_arch = \"wasm32\")".dependencies.js-sys]
-version = "0.3.45"
@ -14,11 +14,10 @@
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen-futures]
-version = "0.4.18"
-
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
-version = "0.3.25"
-features = ["Headers", "Request", "RequestInit", "RequestMode", "Response", "Window", "FormData", "Blob", "BlobPropertyBag", "ServiceWorkerGlobalScope"]
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-[target."cfg(windows)".dependencies.winreg]
-version = "0.7"

@ -5,8 +5,8 @@
%global crate reqwest
Name: rust-%{crate}
Version: 0.10.9
Release: 2%{?dist}
Version: 0.11.1
Release: 1%{?dist}
Summary: Higher level HTTP client library
# Upstream license specification: MIT/Apache-2.0
@ -199,6 +199,30 @@ which use "json" feature of "%{crate}" crate.
%files -n %{name}+json-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+mime_guess-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mime_guess-devel %{_description}
This package contains library source intended for building other packages
which use "mime_guess" feature of "%{crate}" crate.
%files -n %{name}+mime_guess-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+multipart-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+multipart-devel %{_description}
This package contains library source intended for building other packages
which use "multipart" feature of "%{crate}" crate.
%files -n %{name}+multipart-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+native-tls-devel
Summary: %{summary}
BuildArch: noarch
@ -271,6 +295,18 @@ which use "time" feature of "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tokio-native-tls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-native-tls-devel %{_description}
This package contains library source intended for building other packages
which use "tokio-native-tls" feature of "%{crate}" crate.
%files -n %{name}+tokio-native-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tokio-socks-devel
Summary: %{summary}
BuildArch: noarch
@ -283,16 +319,16 @@ which use "tokio-socks" feature of "%{crate}" crate.
%files -n %{name}+tokio-socks-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tokio-tls-devel
%package -n %{name}+tokio-util-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-tls-devel %{_description}
%description -n %{name}+tokio-util-devel %{_description}
This package contains library source intended for building other packages
which use "tokio-tls" feature of "%{crate}" crate.
which use "tokio-util" feature of "%{crate}" crate.
%files -n %{name}+tokio-tls-devel
%files -n %{name}+tokio-util-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+trust-dns-devel
@ -334,11 +370,20 @@ which use "trust-dns-resolver" feature of "%{crate}" crate.
%if %{with check}
%check
# Skip tests requiring network and one depending on Cargo.lock being present
%cargo_test -- -- --skip test_badssl_modern --skip test_badssl_self_signed --skip test_badssl_wrong_host --skip file
# * skip tests which require internet access
# * skip "file" test which depends on Cargo.lock being present
%cargo_test -- -- \
--skip test_allowed_methods \
--skip test_badssl_modern \
--skip test_badssl_self_signed \
--skip test_badssl_wrong_host \
--skip file
%endif
%changelog
* Sat Mar 06 2021 Fabio Valentini <decathorpe@gmail.com> - 0.11.1-1
- Update to version 0.11.1.
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

@ -1 +1 @@
SHA512 (reqwest-0.10.9.crate) = c129314de154691dff132da7b58c8279183b1f96b6de14ad07105fd1cfcedefd819a26f2487dde184b93166ae11d4df001646d7a77227845bff849f753a6c52e
SHA512 (reqwest-0.11.1.crate) = 063b92ffb57dcc4d79a776a97b1cd2ed29c3ab686e49e3c1395589e4e2425154ab2eb7ad10785d1f904fdce4e50d8efe815f2bcc81a18d0d7e0a21af4898bae4

Loading…
Cancel
Save