Update to 0.10.1

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 5 years ago
parent 6d446925cc
commit b9b0a3ce33
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -4,3 +4,4 @@
/reqwest-0.9.12.crate
/reqwest-0.9.13.crate
/reqwest-0.9.24.crate
/reqwest-0.10.1.crate

@ -1,8 +1,29 @@
--- reqwest-0.9.24/Cargo.toml 2019-12-11T19:58:39+00:00
+++ reqwest-0.9.24/Cargo.toml 2019-12-26T06:19:05.477504+00:00
@@ -166,5 +166,3 @@
rustls-tls = ["hyper-rustls", "tokio-rustls", "webpki-roots", "rustls", "tls"]
tls = []
trust-dns = ["trust-dns-resolver"]
--- reqwest-0.10.1/Cargo.toml 2020-01-09T21:51:06+00:00
+++ reqwest-0.10.1/Cargo.toml 2020-02-11T09:17:33.799855+00:00
@@ -82,7 +82,6 @@
gzip = ["async-compression"]
json = ["serde_json"]
native-tls = ["default-tls"]
-native-tls-vendored = ["native-tls", "native-tls-crate/vendored"]
rustls-tls = ["hyper-rustls", "tokio-rustls", "webpki-roots", "rustls", "__tls"]
socks = ["tokio-socks"]
stream = []
@@ -214,18 +213,3 @@
version = "0.2.0"
features = ["macros"]
default-features = false
-[target."cfg(target_arch = \"wasm32\")".dependencies.js-sys]
-version = "0.3.28"
-
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen]
-version = "0.2.51"
-features = ["serde-serialize"]
-
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen-futures]
-version = "0.4.1"
-
-[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
-version = "0.3.25"
-features = ["Headers", "Request", "RequestInit", "RequestMode", "Response", "Window"]
-[target."cfg(windows)".dependencies.winreg]
-version = "0.6"

@ -5,8 +5,8 @@
%global crate reqwest
Name: rust-%{crate}
Version: 0.9.24
Release: 2%{?dist}
Version: 0.10.1
Release: 1%{?dist}
Summary: Higher level HTTP client library
# Upstream license specification: MIT/Apache-2.0
@ -14,7 +14,7 @@ License: MIT or ASL 2.0
URL: https://crates.io/crates/reqwest
Source: %{crates_source}
# Initial patched metadata
# * No windows
# * No windows/wasm32
Patch0: reqwest-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -55,40 +55,112 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+default-tls-devel
%package -n %{name}+__internal_proxy_sys_no_cache-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-tls-devel %{_description}
%description -n %{name}+__internal_proxy_sys_no_cache-devel %{_description}
This package contains library source intended for building other packages
which use "default-tls" feature of "%{crate}" crate.
which use "__internal_proxy_sys_no_cache" feature of "%{crate}" crate.
%files -n %{name}+default-tls-devel
%files -n %{name}+__internal_proxy_sys_no_cache-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+hyper-011-devel
%package -n %{name}+__tls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hyper-011-devel %{_description}
%description -n %{name}+__tls-devel %{_description}
This package contains library source intended for building other packages
which use "hyper-011" feature of "%{crate}" crate.
which use "__tls" feature of "%{crate}" crate.
%files -n %{name}+hyper-011-devel
%files -n %{name}+__tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+hyper-old-types-devel
%package -n %{name}+async-compression-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hyper-old-types-devel %{_description}
%description -n %{name}+async-compression-devel %{_description}
This package contains library source intended for building other packages
which use "hyper-old-types" feature of "%{crate}" crate.
which use "async-compression" feature of "%{crate}" crate.
%files -n %{name}+hyper-old-types-devel
%files -n %{name}+async-compression-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+blocking-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+blocking-devel %{_description}
This package contains library source intended for building other packages
which use "blocking" feature of "%{crate}" crate.
%files -n %{name}+blocking-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+cookie_crate-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cookie_crate-devel %{_description}
This package contains library source intended for building other packages
which use "cookie_crate" feature of "%{crate}" crate.
%files -n %{name}+cookie_crate-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+cookie_store-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cookie_store-devel %{_description}
This package contains library source intended for building other packages
which use "cookie_store" feature of "%{crate}" crate.
%files -n %{name}+cookie_store-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+cookies-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cookies-devel %{_description}
This package contains library source intended for building other packages
which use "cookies" feature of "%{crate}" crate.
%files -n %{name}+cookies-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+default-tls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-tls-devel %{_description}
This package contains library source intended for building other packages
which use "default-tls" feature of "%{crate}" crate.
%files -n %{name}+default-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+gzip-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+gzip-devel %{_description}
This package contains library source intended for building other packages
which use "gzip" feature of "%{crate}" crate.
%files -n %{name}+gzip-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+hyper-rustls-devel
@ -115,6 +187,18 @@ which use "hyper-tls" feature of "%{crate}" crate.
%files -n %{name}+hyper-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+json-devel %{_description}
This package contains library source intended for building other packages
which use "json" feature of "%{crate}" crate.
%files -n %{name}+json-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+native-tls-devel
Summary: %{summary}
BuildArch: noarch
@ -127,6 +211,18 @@ which use "native-tls" feature of "%{crate}" crate.
%files -n %{name}+native-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+native-tls-crate-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+native-tls-crate-devel %{_description}
This package contains library source intended for building other packages
which use "native-tls-crate" feature of "%{crate}" crate.
%files -n %{name}+native-tls-crate-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustls-devel
Summary: %{summary}
BuildArch: noarch
@ -151,6 +247,18 @@ which use "rustls-tls" feature of "%{crate}" crate.
%files -n %{name}+rustls-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde_json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde_json-devel %{_description}
This package contains library source intended for building other packages
which use "serde_json" feature of "%{crate}" crate.
%files -n %{name}+serde_json-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+socks-devel
Summary: %{summary}
BuildArch: noarch
@ -163,16 +271,16 @@ which use "socks" feature of "%{crate}" crate.
%files -n %{name}+socks-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tls-devel
%package -n %{name}+stream-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tls-devel %{_description}
%description -n %{name}+stream-devel %{_description}
This package contains library source intended for building other packages
which use "tls" feature of "%{crate}" crate.
which use "stream" feature of "%{crate}" crate.
%files -n %{name}+tls-devel
%files -n %{name}+stream-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tokio-rustls-devel
@ -187,28 +295,28 @@ which use "tokio-rustls" feature of "%{crate}" crate.
%files -n %{name}+tokio-rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+trust-dns-devel
%package -n %{name}+tokio-socks-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+trust-dns-devel %{_description}
%description -n %{name}+tokio-socks-devel %{_description}
This package contains library source intended for building other packages
which use "trust-dns" feature of "%{crate}" crate.
which use "tokio-socks" feature of "%{crate}" crate.
%files -n %{name}+trust-dns-devel
%files -n %{name}+tokio-socks-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+trust-dns-resolver-devel
%package -n %{name}+tokio-tls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+trust-dns-resolver-devel %{_description}
%description -n %{name}+tokio-tls-devel %{_description}
This package contains library source intended for building other packages
which use "trust-dns-resolver" feature of "%{crate}" crate.
which use "tokio-tls" feature of "%{crate}" crate.
%files -n %{name}+trust-dns-resolver-devel
%files -n %{name}+tokio-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+webpki-roots-devel
@ -243,6 +351,9 @@ which use "webpki-roots" feature of "%{crate}" crate.
%endif
%changelog
* Tue Feb 11 10:17:33 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.10.1-1
- Update to 0.10.1
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.24-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (reqwest-0.9.24.crate) = 3e486eeb02bda662ec70ad8c987611f8fb4c4c6c0ac6454e0e0dad66a73c6a6667512e1c89e786d1fed4a7e077a09e3026bd19d7ec087008daeee6c1d3c2b09e
SHA512 (reqwest-0.10.1.crate) = 2248bece374214682a8b09c7ee0bc0ab097b380d90d2240c7f9511c4e5528f17afb5f55c89b4c86ea51fbfe057932721a18753d45b242756107e6d84abf5175c

Loading…
Cancel
Save