Enable features for Rustls support

epel9
Fabio Valentini 1 year ago
parent 71a7d9cdcd
commit 8d46c6b7eb
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,5 +1,5 @@
--- reqwest-0.11.22/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.11.22/Cargo.toml 2023-10-07T13:12:01.568658+00:00
+++ reqwest-0.11.22/Cargo.toml 2023-10-28T00:08:11.596301+00:00
@@ -221,7 +221,6 @@
stream = [
"tokio/fs",

@ -15,7 +15,7 @@ Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: reqwest-fix-metadata-auto.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Higher level HTTP client library.}
@ -62,6 +62,18 @@ use the "__internal_proxy_sys_no_cache" feature of the "%{crate}" crate.
%files -n %{name}+__internal_proxy_sys_no_cache-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+__rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+__rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "__rustls" feature of the "%{crate}" crate.
%files -n %{name}+__rustls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+__tls-devel
Summary: %{summary}
BuildArch: noarch
@ -182,6 +194,18 @@ use the "gzip" feature of the "%{crate}" crate.
%files -n %{name}+gzip-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hyper-rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hyper-rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "hyper-rustls" feature of the "%{crate}" crate.
%files -n %{name}+hyper-rustls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hyper-tls-devel
Summary: %{summary}
BuildArch: noarch
@ -266,6 +290,90 @@ use the "native-tls-crate" feature of the "%{crate}" crate.
%files -n %{name}+native-tls-crate-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls" feature of the "%{crate}" crate.
%files -n %{name}+rustls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-native-certs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-native-certs-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-native-certs" feature of the "%{crate}" crate.
%files -n %{name}+rustls-native-certs-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-pemfile-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-pemfile-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-pemfile" feature of the "%{crate}" crate.
%files -n %{name}+rustls-pemfile-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-tls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-tls-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-tls" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-tls-manual-roots-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-tls-manual-roots-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-tls-manual-roots" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-manual-roots-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-tls-native-roots-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-tls-native-roots-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-tls-native-roots" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-native-roots-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-tls-webpki-roots-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-tls-webpki-roots-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-tls-webpki-roots" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-webpki-roots-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_json-devel
Summary: %{summary}
BuildArch: noarch
@ -314,6 +422,18 @@ use the "tokio-native-tls" feature of the "%{crate}" crate.
%files -n %{name}+tokio-native-tls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio-rustls" feature of the "%{crate}" crate.
%files -n %{name}+tokio-rustls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-socks-devel
Summary: %{summary}
BuildArch: noarch
@ -362,6 +482,18 @@ use the "trust-dns-resolver" feature of the "%{crate}" crate.
%files -n %{name}+trust-dns-resolver-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+webpki-roots-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+webpki-roots-devel %{_description}
This package contains library source intended for building other packages which
use the "webpki-roots" feature of the "%{crate}" crate.
%files -n %{name}+webpki-roots-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

@ -1,22 +1,11 @@
[features]
hide = [
"__rustls",
"futures-channel",
"h3",
"h3-quinn",
"http3",
"hyper-rustls",
"native-tls-vendored",
"quinn",
"rustls",
"rustls-native-certs",
"rustls-pemfile",
"rustls-tls",
"rustls-tls-manual-roots",
"rustls-tls-native-roots",
"rustls-tls-webpki-roots",
"tokio-rustls",
"webpki-roots",
]
[tests]

Loading…
Cancel
Save