Update to version 0.11.22; Fixes RHBZ#2241801

epel9
Fabio Valentini 1 year ago
parent 0e5bb04a56
commit 71a7d9cdcd
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -26,3 +26,4 @@
/reqwest-0.11.18.crate
/reqwest-0.11.19.crate
/reqwest-0.11.20.crate
/reqwest-0.11.22.crate

@ -1,5 +1,5 @@
--- reqwest-0.11.20/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.11.20/Cargo.toml 2023-08-24T18:05:47.438274+00:00
--- reqwest-0.11.22/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.11.22/Cargo.toml 2023-10-07T13:12:01.568658+00:00
@@ -221,7 +221,6 @@
stream = [
"tokio/fs",
@ -8,7 +8,7 @@
]
trust-dns = ["trust-dns-resolver"]
@@ -402,48 +401,3 @@
@@ -403,51 +402,3 @@
]
default-features = false
@ -55,5 +55,8 @@
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target."cfg(target_os = \"macos\")".dependencies.system-configuration]
-version = "0.5.1"
-
-[target."cfg(windows)".dependencies.winreg]
-version = "0.50.0"

@ -1,18 +1,18 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate reqwest
Name: rust-reqwest
Version: 0.11.20
Version: 0.11.22
Release: %autorelease
Summary: Higher level HTTP client library
License: MIT OR Apache-2.0
URL: https://crates.io/crates/reqwest
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
# Automatically generated patch to strip dependencies and normalize metadata
Patch: reqwest-fix-metadata-auto.diff
BuildRequires: rust-packaging >= 21
@ -363,7 +363,7 @@ use the "trust-dns-resolver" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
@ -378,7 +378,7 @@ use the "trust-dns-resolver" feature of the "%{crate}" crate.
%if %{with check}
%check
# * skip tests which require internet access
%cargo_test -- -- --skip test_allowed_methods --skip test_badssl_modern --skip test_badssl_self_signed
%cargo_test -- -- --exact --skip test_allowed_methods --skip test_badssl_modern --skip test_badssl_self_signed --skip test_tls_info
%endif
%changelog

@ -1,19 +0,0 @@
[DEFAULT]
unwanted-features =
__rustls
futures-channel
h3
h3-quinn
http3
hyper-rustls
native-tls-vendored
quinn
rustls
rustls-native-certs
rustls-pemfile
rustls-tls
rustls-tls-manual-roots
rustls-tls-native-roots
rustls-tls-webpki-roots
tokio-rustls
webpki-roots

@ -0,0 +1,31 @@
[features]
hide = [
"__rustls",
"futures-channel",
"h3",
"h3-quinn",
"http3",
"hyper-rustls",
"native-tls-vendored",
"quinn",
"rustls",
"rustls-native-certs",
"rustls-pemfile",
"rustls-tls",
"rustls-tls-manual-roots",
"rustls-tls-native-roots",
"rustls-tls-webpki-roots",
"tokio-rustls",
"webpki-roots",
]
[tests]
skip = [
"test_allowed_methods",
"test_badssl_modern",
"test_badssl_self_signed",
"test_tls_info",
]
skip-exact = true
comments = ["skip tests which require internet access"]

@ -1 +1 @@
SHA512 (reqwest-0.11.20.crate) = 0cd5fcaf8f3997683f39aec422c3cd5f37a5f0b3b7ffacae7d97008b0de93e21ab7318fba9a9eebbb677a5bc4289610d5153e8ac1e8fe94aac9da2c2ede94c6d
SHA512 (reqwest-0.11.22.crate) = aaf1218a239a9c979b7a14198bbc1ffada80237a0d05a63242f8486d416c3dce636dbaf205976da4655973ddc5168a3e8d4ad341e2f042c5f239a7af35c7c5d2

Loading…
Cancel
Save