|
|
|
@ -1,5 +1,5 @@
|
|
|
|
|
--- reqwest-0.12.5/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
|
+++ reqwest-0.12.5/Cargo.toml 2024-07-03T21:36:21.631788+00:00
|
|
|
|
|
--- reqwest-0.12.7/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
|
+++ reqwest-0.12.7/Cargo.toml 2024-09-18T16:59:08.747838+00:00
|
|
|
|
|
@@ -70,10 +70,6 @@
|
|
|
|
|
path = "examples/form.rs"
|
|
|
|
|
|
|
|
|
@ -26,7 +26,7 @@
|
|
|
|
|
|
|
|
|
|
[[test]]
|
|
|
|
|
name = "client"
|
|
|
|
|
@@ -222,7 +210,6 @@
|
|
|
|
|
@@ -223,7 +211,6 @@
|
|
|
|
|
"hyper-rustls?/ring",
|
|
|
|
|
"tokio-rustls?/ring",
|
|
|
|
|
"rustls?/ring",
|
|
|
|
@ -34,7 +34,7 @@
|
|
|
|
|
]
|
|
|
|
|
__tls = [
|
|
|
|
|
"dep:rustls-pemfile",
|
|
|
|
|
@@ -235,11 +222,6 @@
|
|
|
|
|
@@ -236,11 +223,6 @@
|
|
|
|
|
"futures-util/sink",
|
|
|
|
|
"tokio/sync",
|
|
|
|
|
]
|
|
|
|
@ -46,7 +46,7 @@
|
|
|
|
|
charset = ["dep:encoding_rs"]
|
|
|
|
|
cookies = [
|
|
|
|
|
"dep:cookie_crate",
|
|
|
|
|
@@ -249,7 +231,6 @@
|
|
|
|
|
@@ -250,7 +232,6 @@
|
|
|
|
|
"default-tls",
|
|
|
|
|
"charset",
|
|
|
|
|
"http2",
|
|
|
|
@ -54,7 +54,7 @@
|
|
|
|
|
]
|
|
|
|
|
default-tls = [
|
|
|
|
|
"dep:hyper-tls",
|
|
|
|
|
@@ -274,16 +255,7 @@
|
|
|
|
|
@@ -275,16 +256,7 @@
|
|
|
|
|
"hyper-util/http2",
|
|
|
|
|
"hyper-rustls?/http2",
|
|
|
|
|
]
|
|
|
|
@ -71,7 +71,7 @@
|
|
|
|
|
multipart = ["dep:mime_guess"]
|
|
|
|
|
native-tls = ["default-tls"]
|
|
|
|
|
native-tls-alpn = [
|
|
|
|
|
@@ -291,10 +263,6 @@
|
|
|
|
|
@@ -292,10 +264,6 @@
|
|
|
|
|
"native-tls-crate?/alpn",
|
|
|
|
|
"hyper-tls?/alpn",
|
|
|
|
|
]
|
|
|
|
@ -82,22 +82,22 @@
|
|
|
|
|
rustls-tls = ["rustls-tls-webpki-roots"]
|
|
|
|
|
rustls-tls-manual-roots = [
|
|
|
|
|
"__rustls",
|
|
|
|
|
@@ -353,14 +321,6 @@
|
|
|
|
|
@@ -354,14 +322,6 @@
|
|
|
|
|
version = "0.4"
|
|
|
|
|
optional = true
|
|
|
|
|
|
|
|
|
|
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies.h3]
|
|
|
|
|
-version = "0.0.5"
|
|
|
|
|
-version = "0.0.6"
|
|
|
|
|
-optional = true
|
|
|
|
|
-
|
|
|
|
|
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies.h3-quinn]
|
|
|
|
|
-version = "0.0.6"
|
|
|
|
|
-version = "0.0.7"
|
|
|
|
|
-optional = true
|
|
|
|
|
-
|
|
|
|
|
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.hickory-resolver]
|
|
|
|
|
version = "0.24"
|
|
|
|
|
features = ["tokio-runtime"]
|
|
|
|
|
@@ -424,15 +384,6 @@
|
|
|
|
|
@@ -425,15 +385,6 @@
|
|
|
|
|
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.pin-project-lite]
|
|
|
|
|
version = "0.2.11"
|
|
|
|
|
|
|
|
|
@ -113,13 +113,13 @@
|
|
|
|
|
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.rustls]
|
|
|
|
|
version = "0.23.4"
|
|
|
|
|
features = [
|
|
|
|
|
@@ -493,10 +444,6 @@
|
|
|
|
|
@@ -494,10 +445,6 @@
|
|
|
|
|
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.webpki-roots]
|
|
|
|
|
version = "0.26.0"
|
|
|
|
|
optional = true
|
|
|
|
|
-
|
|
|
|
|
-[target.'cfg(not(target_arch = "wasm32"))'.dev-dependencies.brotli_crate]
|
|
|
|
|
-version = "3.3.0"
|
|
|
|
|
-version = "6.0.0"
|
|
|
|
|
-package = "brotli"
|
|
|
|
|
|
|
|
|
|
[target.'cfg(not(target_arch = "wasm32"))'.dev-dependencies.doc-comment]
|
|
|
|
|