Update to version 0.11.10; Fixes RHBZ#2011969

epel9
Fabio Valentini 3 years ago
parent d6b9f98b0b
commit 50196d6422
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -16,3 +16,4 @@
/reqwest-0.11.3.crate
/reqwest-0.11.4.crate
/reqwest-0.11.6.crate
/reqwest-0.11.10.crate

@ -1,3 +1,14 @@
[DEFAULT]
unwanted-features =
__rustls
hyper-rustls
native-tls-vendored
rustls
rustls-native-certs
rustls-pemfile
rustls-tls
rustls-tls-manual-roots
rustls-tls-native-roots
rustls-tls-webpki-roots
tokio-rustls
webpki-roots

@ -1,9 +1,10 @@
--- reqwest-0.11.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.11.6/Cargo.toml 2022-01-05T20:20:12.361925+00:00
@@ -272,26 +272,3 @@
version = "1.0"
features = ["macros", "rt-multi-thread"]
--- reqwest-0.11.10/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.11.10/Cargo.toml 2022-03-18T19:00:01.935814+00:00
@@ -370,42 +370,3 @@
"rt-multi-thread",
]
default-features = false
-
-[target."cfg(target_arch = \"wasm32\")".dependencies.js-sys]
-version = "0.3.45"
-
@ -18,12 +19,27 @@
-
-[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
-version = "0.3.25"
-features = ["Headers", "Request", "RequestInit", "RequestMode", "Response", "Window", "FormData", "Blob", "BlobPropertyBag", "ServiceWorkerGlobalScope", "RequestCredentials"]
-features = [
- "Headers",
- "Request",
- "RequestInit",
- "RequestMode",
- "Response",
- "Window",
- "FormData",
- "Blob",
- "BlobPropertyBag",
- "ServiceWorkerGlobalScope",
- "RequestCredentials",
- "File",
-]
-
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen]
-version = "0.2.68"
-features = ["serde-serialize"]
-
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target."cfg(windows)".dependencies.winreg]
-version = "0.7"
-version = "0.10"

@ -1,11 +1,11 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate reqwest
Name: rust-%{crate}
Version: 0.11.6
Version: 0.11.10
Release: %autorelease
Summary: Higher level HTTP client library
@ -15,11 +15,12 @@ URL: https://crates.io/crates/reqwest
Source: %{crates_source}
# Initial patched metadata
# * drop windows- and WASM-specific dependencies
# * temporarily drop unused RusTLS features
Patch0: reqwest-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Higher level HTTP client library.}
@ -36,9 +37,11 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -50,7 +53,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+__internal_proxy_sys_no_cache-devel
Summary: %{summary}
@ -62,19 +65,7 @@ This package contains library source intended for building other packages which
use the "__internal_proxy_sys_no_cache" feature of the "%{crate}" crate.
%files -n %{name}+__internal_proxy_sys_no_cache-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+__rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+__rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "__rustls" feature of the "%{crate}" crate.
%files -n %{name}+__rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+__tls-devel
Summary: %{summary}
@ -86,7 +77,7 @@ This package contains library source intended for building other packages which
use the "__tls" feature of the "%{crate}" crate.
%files -n %{name}+__tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-compression-devel
Summary: %{summary}
@ -98,7 +89,7 @@ This package contains library source intended for building other packages which
use the "async-compression" feature of the "%{crate}" crate.
%files -n %{name}+async-compression-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+blocking-devel
Summary: %{summary}
@ -110,7 +101,7 @@ This package contains library source intended for building other packages which
use the "blocking" feature of the "%{crate}" crate.
%files -n %{name}+blocking-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+brotli-devel
Summary: %{summary}
@ -122,7 +113,7 @@ This package contains library source intended for building other packages which
use the "brotli" feature of the "%{crate}" crate.
%files -n %{name}+brotli-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cookie_crate-devel
Summary: %{summary}
@ -134,7 +125,7 @@ This package contains library source intended for building other packages which
use the "cookie_crate" feature of the "%{crate}" crate.
%files -n %{name}+cookie_crate-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cookie_store-devel
Summary: %{summary}
@ -146,7 +137,7 @@ This package contains library source intended for building other packages which
use the "cookie_store" feature of the "%{crate}" crate.
%files -n %{name}+cookie_store-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cookies-devel
Summary: %{summary}
@ -158,7 +149,7 @@ This package contains library source intended for building other packages which
use the "cookies" feature of the "%{crate}" crate.
%files -n %{name}+cookies-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+default-tls-devel
Summary: %{summary}
@ -170,7 +161,7 @@ This package contains library source intended for building other packages which
use the "default-tls" feature of the "%{crate}" crate.
%files -n %{name}+default-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+deflate-devel
Summary: %{summary}
@ -182,7 +173,7 @@ This package contains library source intended for building other packages which
use the "deflate" feature of the "%{crate}" crate.
%files -n %{name}+deflate-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+gzip-devel
Summary: %{summary}
@ -194,19 +185,7 @@ This package contains library source intended for building other packages which
use the "gzip" feature of the "%{crate}" crate.
%files -n %{name}+gzip-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+hyper-rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hyper-rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "hyper-rustls" feature of the "%{crate}" crate.
%files -n %{name}+hyper-rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hyper-tls-devel
Summary: %{summary}
@ -218,7 +197,7 @@ This package contains library source intended for building other packages which
use the "hyper-tls" feature of the "%{crate}" crate.
%files -n %{name}+hyper-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+json-devel
Summary: %{summary}
@ -230,7 +209,7 @@ This package contains library source intended for building other packages which
use the "json" feature of the "%{crate}" crate.
%files -n %{name}+json-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mime_guess-devel
Summary: %{summary}
@ -242,7 +221,7 @@ This package contains library source intended for building other packages which
use the "mime_guess" feature of the "%{crate}" crate.
%files -n %{name}+mime_guess-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+multipart-devel
Summary: %{summary}
@ -254,7 +233,7 @@ This package contains library source intended for building other packages which
use the "multipart" feature of the "%{crate}" crate.
%files -n %{name}+multipart-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+native-tls-devel
Summary: %{summary}
@ -266,7 +245,7 @@ This package contains library source intended for building other packages which
use the "native-tls" feature of the "%{crate}" crate.
%files -n %{name}+native-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+native-tls-alpn-devel
Summary: %{summary}
@ -278,7 +257,7 @@ This package contains library source intended for building other packages which
use the "native-tls-alpn" feature of the "%{crate}" crate.
%files -n %{name}+native-tls-alpn-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+native-tls-crate-devel
Summary: %{summary}
@ -290,79 +269,19 @@ This package contains library source intended for building other packages which
use the "native-tls-crate" feature of the "%{crate}" crate.
%files -n %{name}+native-tls-crate-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls" feature of the "%{crate}" crate.
%files -n %{name}+rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustls-native-certs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-native-certs-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-native-certs" feature of the "%{crate}" crate.
%files -n %{name}+rustls-native-certs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustls-tls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-tls-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-tls" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-tls-manual-roots-devel
%package -n %{name}+proc-macro-hack-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-tls-manual-roots-devel %{_description}
%description -n %{name}+proc-macro-hack-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-tls-manual-roots" feature of the "%{crate}" crate.
use the "proc-macro-hack" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-manual-roots-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustls-tls-native-roots-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-tls-native-roots-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-tls-native-roots" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-native-roots-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustls-tls-webpki-roots-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-tls-webpki-roots-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-tls-webpki-roots" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-webpki-roots-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%files -n %{name}+proc-macro-hack-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_json-devel
Summary: %{summary}
@ -374,7 +293,7 @@ This package contains library source intended for building other packages which
use the "serde_json" feature of the "%{crate}" crate.
%files -n %{name}+serde_json-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+socks-devel
Summary: %{summary}
@ -386,7 +305,7 @@ This package contains library source intended for building other packages which
use the "socks" feature of the "%{crate}" crate.
%files -n %{name}+socks-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+stream-devel
Summary: %{summary}
@ -398,19 +317,7 @@ This package contains library source intended for building other packages which
use the "stream" feature of the "%{crate}" crate.
%files -n %{name}+stream-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+time-devel %{_description}
This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-native-tls-devel
Summary: %{summary}
@ -422,19 +329,7 @@ This package contains library source intended for building other packages which
use the "tokio-native-tls" feature of the "%{crate}" crate.
%files -n %{name}+tokio-native-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tokio-rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio-rustls" feature of the "%{crate}" crate.
%files -n %{name}+tokio-rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-socks-devel
Summary: %{summary}
@ -446,7 +341,7 @@ This package contains library source intended for building other packages which
use the "tokio-socks" feature of the "%{crate}" crate.
%files -n %{name}+tokio-socks-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-util-devel
Summary: %{summary}
@ -458,7 +353,7 @@ This package contains library source intended for building other packages which
use the "tokio-util" feature of the "%{crate}" crate.
%files -n %{name}+tokio-util-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+trust-dns-devel
Summary: %{summary}
@ -470,7 +365,7 @@ This package contains library source intended for building other packages which
use the "trust-dns" feature of the "%{crate}" crate.
%files -n %{name}+trust-dns-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+trust-dns-resolver-devel
Summary: %{summary}
@ -482,19 +377,7 @@ This package contains library source intended for building other packages which
use the "trust-dns-resolver" feature of the "%{crate}" crate.
%files -n %{name}+trust-dns-resolver-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+webpki-roots-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+webpki-roots-devel %{_description}
This package contains library source intended for building other packages which
use the "webpki-roots" feature of the "%{crate}" crate.
%files -n %{name}+webpki-roots-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (reqwest-0.11.6.crate) = 39a76ec1667fb83c5315f5d49c2a4325e14c5fc46c23d5d519449cb2284be3e24313d91007274626e473f1cc663594c018004b9ed1f912292550bed15e0fab1b
SHA512 (reqwest-0.11.10.crate) = 17727bd585b244c65ec5857899e2cddab7a4284cd17f8fe0066f203bc2f57a2aedc33bf734e02d06a059983e1eecf7c689f2b0a40b7ffd0225302b7ef72a8daa

Loading…
Cancel
Save