Update to version 0.11.6

epel9
Fabio Valentini 3 years ago
parent 25b745720a
commit 1c7d23ab1a
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -15,3 +15,4 @@
/reqwest-0.11.2.crate
/reqwest-0.11.3.crate
/reqwest-0.11.4.crate
/reqwest-0.11.6.crate

@ -1,15 +1,17 @@
--- reqwest-0.11.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.11.4/Cargo.toml 2021-06-22T08:48:22.926298+00:00
@@ -273,20 +273,3 @@
--- reqwest-0.11.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.11.6/Cargo.toml 2022-01-05T20:20:12.361925+00:00
@@ -272,26 +272,3 @@
version = "1.0"
features = ["macros", "rt-multi-thread"]
default-features = false
-[target."cfg(target_arch = \"wasm32\")".dependencies.js-sys]
-version = "0.3.45"
-
-[target."cfg(target_arch = \"wasm32\")".dependencies.serde_json]
-version = "1.0"
-
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen]
-version = "0.2.68"
-features = ["serde-serialize"]
-
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen-futures]
-version = "0.4.18"
@ -17,6 +19,10 @@
-[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
-version = "0.3.25"
-features = ["Headers", "Request", "RequestInit", "RequestMode", "Response", "Window", "FormData", "Blob", "BlobPropertyBag", "ServiceWorkerGlobalScope", "RequestCredentials"]
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen]
-version = "0.2.68"
-features = ["serde-serialize"]
-
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-[target."cfg(windows)".dependencies.winreg]

@ -1,11 +1,11 @@
# Generated by rust2rpm 17
# Generated by rust2rpm 20
%bcond_without check
%global debug_package %{nil}
%global crate reqwest
Name: rust-%{crate}
Version: 0.11.4
Version: 0.11.6
Release: %autorelease
Summary: Higher level HTTP client library
@ -18,9 +18,6 @@ Source: %{crates_source}
Patch0: reqwest-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
@ -35,12 +32,12 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md
%license LICENSE-APACHE LICENSE-MIT
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
@ -49,8 +46,8 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -61,8 +58,8 @@ BuildArch: noarch
%description -n %{name}+__internal_proxy_sys_no_cache-devel %{_description}
This package contains library source intended for building other packages
which use "__internal_proxy_sys_no_cache" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "__internal_proxy_sys_no_cache" feature of the "%{crate}" crate.
%files -n %{name}+__internal_proxy_sys_no_cache-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -73,8 +70,8 @@ BuildArch: noarch
%description -n %{name}+__rustls-devel %{_description}
This package contains library source intended for building other packages
which use "__rustls" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "__rustls" feature of the "%{crate}" crate.
%files -n %{name}+__rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -85,8 +82,8 @@ BuildArch: noarch
%description -n %{name}+__tls-devel %{_description}
This package contains library source intended for building other packages
which use "__tls" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "__tls" feature of the "%{crate}" crate.
%files -n %{name}+__tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -97,8 +94,8 @@ BuildArch: noarch
%description -n %{name}+async-compression-devel %{_description}
This package contains library source intended for building other packages
which use "async-compression" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "async-compression" feature of the "%{crate}" crate.
%files -n %{name}+async-compression-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -109,8 +106,8 @@ BuildArch: noarch
%description -n %{name}+blocking-devel %{_description}
This package contains library source intended for building other packages
which use "blocking" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "blocking" feature of the "%{crate}" crate.
%files -n %{name}+blocking-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -121,8 +118,8 @@ BuildArch: noarch
%description -n %{name}+brotli-devel %{_description}
This package contains library source intended for building other packages
which use "brotli" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "brotli" feature of the "%{crate}" crate.
%files -n %{name}+brotli-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -133,8 +130,8 @@ BuildArch: noarch
%description -n %{name}+cookie_crate-devel %{_description}
This package contains library source intended for building other packages
which use "cookie_crate" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "cookie_crate" feature of the "%{crate}" crate.
%files -n %{name}+cookie_crate-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -145,8 +142,8 @@ BuildArch: noarch
%description -n %{name}+cookie_store-devel %{_description}
This package contains library source intended for building other packages
which use "cookie_store" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "cookie_store" feature of the "%{crate}" crate.
%files -n %{name}+cookie_store-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -157,8 +154,8 @@ BuildArch: noarch
%description -n %{name}+cookies-devel %{_description}
This package contains library source intended for building other packages
which use "cookies" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "cookies" feature of the "%{crate}" crate.
%files -n %{name}+cookies-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -169,8 +166,8 @@ BuildArch: noarch
%description -n %{name}+default-tls-devel %{_description}
This package contains library source intended for building other packages
which use "default-tls" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default-tls" feature of the "%{crate}" crate.
%files -n %{name}+default-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -181,8 +178,8 @@ BuildArch: noarch
%description -n %{name}+deflate-devel %{_description}
This package contains library source intended for building other packages
which use "deflate" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "deflate" feature of the "%{crate}" crate.
%files -n %{name}+deflate-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -193,8 +190,8 @@ BuildArch: noarch
%description -n %{name}+gzip-devel %{_description}
This package contains library source intended for building other packages
which use "gzip" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "gzip" feature of the "%{crate}" crate.
%files -n %{name}+gzip-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -205,8 +202,8 @@ BuildArch: noarch
%description -n %{name}+hyper-rustls-devel %{_description}
This package contains library source intended for building other packages
which use "hyper-rustls" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "hyper-rustls" feature of the "%{crate}" crate.
%files -n %{name}+hyper-rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -217,8 +214,8 @@ BuildArch: noarch
%description -n %{name}+hyper-tls-devel %{_description}
This package contains library source intended for building other packages
which use "hyper-tls" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "hyper-tls" feature of the "%{crate}" crate.
%files -n %{name}+hyper-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -229,8 +226,8 @@ BuildArch: noarch
%description -n %{name}+json-devel %{_description}
This package contains library source intended for building other packages
which use "json" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "json" feature of the "%{crate}" crate.
%files -n %{name}+json-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -241,8 +238,8 @@ BuildArch: noarch
%description -n %{name}+mime_guess-devel %{_description}
This package contains library source intended for building other packages
which use "mime_guess" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "mime_guess" feature of the "%{crate}" crate.
%files -n %{name}+mime_guess-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -253,8 +250,8 @@ BuildArch: noarch
%description -n %{name}+multipart-devel %{_description}
This package contains library source intended for building other packages
which use "multipart" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "multipart" feature of the "%{crate}" crate.
%files -n %{name}+multipart-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -265,8 +262,8 @@ BuildArch: noarch
%description -n %{name}+native-tls-devel %{_description}
This package contains library source intended for building other packages
which use "native-tls" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "native-tls" feature of the "%{crate}" crate.
%files -n %{name}+native-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -277,8 +274,8 @@ BuildArch: noarch
%description -n %{name}+native-tls-alpn-devel %{_description}
This package contains library source intended for building other packages
which use "native-tls-alpn" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "native-tls-alpn" feature of the "%{crate}" crate.
%files -n %{name}+native-tls-alpn-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -289,8 +286,8 @@ BuildArch: noarch
%description -n %{name}+native-tls-crate-devel %{_description}
This package contains library source intended for building other packages
which use "native-tls-crate" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "native-tls-crate" feature of the "%{crate}" crate.
%files -n %{name}+native-tls-crate-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -301,8 +298,8 @@ BuildArch: noarch
%description -n %{name}+rustls-devel %{_description}
This package contains library source intended for building other packages
which use "rustls" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rustls" feature of the "%{crate}" crate.
%files -n %{name}+rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -313,8 +310,8 @@ BuildArch: noarch
%description -n %{name}+rustls-native-certs-devel %{_description}
This package contains library source intended for building other packages
which use "rustls-native-certs" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rustls-native-certs" feature of the "%{crate}" crate.
%files -n %{name}+rustls-native-certs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -325,8 +322,8 @@ BuildArch: noarch
%description -n %{name}+rustls-tls-devel %{_description}
This package contains library source intended for building other packages
which use "rustls-tls" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rustls-tls" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -337,8 +334,8 @@ BuildArch: noarch
%description -n %{name}+rustls-tls-manual-roots-devel %{_description}
This package contains library source intended for building other packages
which use "rustls-tls-manual-roots" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rustls-tls-manual-roots" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-manual-roots-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -349,8 +346,8 @@ BuildArch: noarch
%description -n %{name}+rustls-tls-native-roots-devel %{_description}
This package contains library source intended for building other packages
which use "rustls-tls-native-roots" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rustls-tls-native-roots" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-native-roots-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -361,8 +358,8 @@ BuildArch: noarch
%description -n %{name}+rustls-tls-webpki-roots-devel %{_description}
This package contains library source intended for building other packages
which use "rustls-tls-webpki-roots" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rustls-tls-webpki-roots" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-webpki-roots-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -373,8 +370,8 @@ BuildArch: noarch
%description -n %{name}+serde_json-devel %{_description}
This package contains library source intended for building other packages
which use "serde_json" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "serde_json" feature of the "%{crate}" crate.
%files -n %{name}+serde_json-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -385,8 +382,8 @@ BuildArch: noarch
%description -n %{name}+socks-devel %{_description}
This package contains library source intended for building other packages
which use "socks" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "socks" feature of the "%{crate}" crate.
%files -n %{name}+socks-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -397,8 +394,8 @@ BuildArch: noarch
%description -n %{name}+stream-devel %{_description}
This package contains library source intended for building other packages
which use "stream" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "stream" feature of the "%{crate}" crate.
%files -n %{name}+stream-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -409,8 +406,8 @@ BuildArch: noarch
%description -n %{name}+time-devel %{_description}
This package contains library source intended for building other packages
which use "time" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -421,8 +418,8 @@ BuildArch: noarch
%description -n %{name}+tokio-native-tls-devel %{_description}
This package contains library source intended for building other packages
which use "tokio-native-tls" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "tokio-native-tls" feature of the "%{crate}" crate.
%files -n %{name}+tokio-native-tls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -433,8 +430,8 @@ BuildArch: noarch
%description -n %{name}+tokio-rustls-devel %{_description}
This package contains library source intended for building other packages
which use "tokio-rustls" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "tokio-rustls" feature of the "%{crate}" crate.
%files -n %{name}+tokio-rustls-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -445,8 +442,8 @@ BuildArch: noarch
%description -n %{name}+tokio-socks-devel %{_description}
This package contains library source intended for building other packages
which use "tokio-socks" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "tokio-socks" feature of the "%{crate}" crate.
%files -n %{name}+tokio-socks-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -457,8 +454,8 @@ BuildArch: noarch
%description -n %{name}+tokio-util-devel %{_description}
This package contains library source intended for building other packages
which use "tokio-util" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "tokio-util" feature of the "%{crate}" crate.
%files -n %{name}+tokio-util-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -469,8 +466,8 @@ BuildArch: noarch
%description -n %{name}+trust-dns-devel %{_description}
This package contains library source intended for building other packages
which use "trust-dns" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "trust-dns" feature of the "%{crate}" crate.
%files -n %{name}+trust-dns-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -481,8 +478,8 @@ BuildArch: noarch
%description -n %{name}+trust-dns-resolver-devel %{_description}
This package contains library source intended for building other packages
which use "trust-dns-resolver" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "trust-dns-resolver" feature of the "%{crate}" crate.
%files -n %{name}+trust-dns-resolver-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -493,8 +490,8 @@ BuildArch: noarch
%description -n %{name}+webpki-roots-devel %{_description}
This package contains library source intended for building other packages
which use "webpki-roots" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "webpki-roots" feature of the "%{crate}" crate.
%files -n %{name}+webpki-roots-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -515,13 +512,7 @@ which use "webpki-roots" feature of "%{crate}" crate.
%if %{with check}
%check
# * skip tests which require internet access
# * skip "file" test which depends on Cargo.lock being present
%cargo_test -- -- \
--skip test_allowed_methods \
--skip test_badssl_modern \
--skip test_badssl_self_signed \
--skip test_badssl_wrong_host \
--skip file
%cargo_test -- -- --skip test_allowed_methods --skip test_badssl_modern --skip test_badssl_self_signed
%endif
%changelog

@ -1 +1 @@
SHA512 (reqwest-0.11.4.crate) = 89bc5ce3658d90b090dbc7952faffc0045304a7d4e1f59a0f7b0c266d2dcae0bc8c5174f4b3b74ceab7b5b8638b5f10ed2b60831ce91972360d849328647e1e1
SHA512 (reqwest-0.11.6.crate) = 39a76ec1667fb83c5315f5d49c2a4325e14c5fc46c23d5d519449cb2284be3e24313d91007274626e473f1cc663594c018004b9ed1f912292550bed15e0fab1b

Loading…
Cancel
Save