Update to version 0.12.9; Fixes RHBZ#2322174

epel10
Fabio Valentini 3 months ago
parent 8cb81aa0fd
commit 0eed6f4924
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -34,3 +34,4 @@
/reqwest-0.12.5.crate /reqwest-0.12.5.crate
/reqwest-0.12.7.crate /reqwest-0.12.7.crate
/reqwest-0.12.8.crate /reqwest-0.12.8.crate
/reqwest-0.12.9.crate

@ -1,6 +1,6 @@
--- reqwest-0.12.8/Cargo.toml 1970-01-01T00:00:01+00:00 --- reqwest-0.12.9/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.12.8/Cargo.toml 2024-10-05T13:29:58.448823+00:00 +++ reqwest-0.12.9/Cargo.toml 2024-10-30T22:19:12.691722+00:00
@@ -284,7 +284,7 @@ @@ -285,7 +285,7 @@
"dep:futures-channel", "dep:futures-channel",
] ]
json = ["dep:serde_json"] json = ["dep:serde_json"]
@ -9,7 +9,7 @@
multipart = ["dep:mime_guess"] multipart = ["dep:mime_guess"]
native-tls = ["default-tls"] native-tls = ["default-tls"]
native-tls-alpn = [ native-tls-alpn = [
@@ -319,7 +319,6 @@ @@ -326,7 +326,6 @@
stream = [ stream = [
"tokio/fs", "tokio/fs",
"dep:tokio-util", "dep:tokio-util",
@ -17,7 +17,7 @@
] ]
trust-dns = [] trust-dns = []
zstd = [ zstd = [
@@ -559,57 +558,8 @@ @@ -566,57 +565,8 @@
version = "0.13" version = "0.13"
package = "zstd" package = "zstd"

@ -1,6 +1,6 @@
--- reqwest-0.12.8/Cargo.toml 1970-01-01T00:00:01+00:00 --- reqwest-0.12.9/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.12.8/Cargo.toml 2024-10-05T13:31:31.292289+00:00 +++ reqwest-0.12.9/Cargo.toml 2024-10-30T22:21:02.376394+00:00
@@ -70,10 +70,6 @@ @@ -71,10 +71,6 @@
path = "examples/form.rs" path = "examples/form.rs"
[[example]] [[example]]
@ -11,7 +11,7 @@
name = "json_dynamic" name = "json_dynamic"
path = "examples/json_dynamic.rs" path = "examples/json_dynamic.rs"
required-features = ["json"] required-features = ["json"]
@@ -100,14 +96,6 @@ @@ -101,14 +97,6 @@
name = "blocking" name = "blocking"
path = "tests/blocking.rs" path = "tests/blocking.rs"
required-features = ["blocking"] required-features = ["blocking"]
@ -26,7 +26,7 @@
[[test]] [[test]]
name = "client" name = "client"
@@ -223,7 +211,6 @@ @@ -224,7 +212,6 @@
"hyper-rustls?/ring", "hyper-rustls?/ring",
"tokio-rustls?/ring", "tokio-rustls?/ring",
"rustls?/ring", "rustls?/ring",
@ -34,7 +34,7 @@
] ]
__tls = [ __tls = [
"dep:rustls-pemfile", "dep:rustls-pemfile",
@@ -236,11 +223,6 @@ @@ -237,11 +224,6 @@
"futures-util/sink", "futures-util/sink",
"tokio/sync", "tokio/sync",
] ]
@ -46,7 +46,7 @@
charset = ["dep:encoding_rs"] charset = ["dep:encoding_rs"]
cookies = [ cookies = [
"dep:cookie_crate", "dep:cookie_crate",
@@ -250,7 +232,6 @@ @@ -251,7 +233,6 @@
"default-tls", "default-tls",
"charset", "charset",
"http2", "http2",
@ -54,7 +54,7 @@
] ]
default-tls = [ default-tls = [
"dep:hyper-tls", "dep:hyper-tls",
@@ -275,16 +256,7 @@ @@ -276,16 +257,7 @@
"hyper-util/http2", "hyper-util/http2",
"hyper-rustls?/http2", "hyper-rustls?/http2",
] ]
@ -71,7 +71,7 @@
multipart = ["dep:mime_guess"] multipart = ["dep:mime_guess"]
native-tls = ["default-tls"] native-tls = ["default-tls"]
native-tls-alpn = [ native-tls-alpn = [
@@ -292,10 +264,6 @@ @@ -293,10 +265,6 @@
"native-tls-crate?/alpn", "native-tls-crate?/alpn",
"hyper-tls?/alpn", "hyper-tls?/alpn",
] ]
@ -81,8 +81,8 @@
-] -]
rustls-tls = ["rustls-tls-webpki-roots"] rustls-tls = ["rustls-tls-webpki-roots"]
rustls-tls-manual-roots = [ rustls-tls-manual-roots = [
"__rustls", "rustls-tls-manual-roots-no-provider",
@@ -354,14 +322,6 @@ @@ -361,14 +329,6 @@
version = "0.4" version = "0.4"
optional = true optional = true
@ -97,7 +97,7 @@
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.hickory-resolver] [target.'cfg(not(target_arch = "wasm32"))'.dependencies.hickory-resolver]
version = "0.24" version = "0.24"
features = ["tokio-runtime"] features = ["tokio-runtime"]
@@ -425,15 +385,6 @@ @@ -432,15 +392,6 @@
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.pin-project-lite] [target.'cfg(not(target_arch = "wasm32"))'.dependencies.pin-project-lite]
version = "0.2.11" version = "0.2.11"
@ -113,7 +113,7 @@
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.rustls] [target.'cfg(not(target_arch = "wasm32"))'.dependencies.rustls]
version = "0.23.4" version = "0.23.4"
features = [ features = [
@@ -494,10 +445,6 @@ @@ -501,10 +452,6 @@
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.webpki-roots] [target.'cfg(not(target_arch = "wasm32"))'.dependencies.webpki-roots]
version = "0.26.0" version = "0.26.0"
optional = true optional = true

@ -5,7 +5,7 @@
%global crate reqwest %global crate reqwest
Name: rust-reqwest Name: rust-reqwest
Version: 0.12.8 Version: 0.12.9
Release: %autorelease Release: %autorelease
Summary: Higher level HTTP client library Summary: Higher level HTTP client library
@ -307,6 +307,18 @@ use the "rustls-tls-native-roots" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-native-roots-devel %files -n %{name}+rustls-tls-native-roots-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-tls-native-roots-no-provider-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-tls-native-roots-no-provider-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-tls-native-roots-no-provider" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-native-roots-no-provider-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-tls-no-provider-devel %package -n %{name}+rustls-tls-no-provider-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -331,6 +343,18 @@ use the "rustls-tls-webpki-roots" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-webpki-roots-devel %files -n %{name}+rustls-tls-webpki-roots-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-tls-webpki-roots-no-provider-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-tls-webpki-roots-no-provider-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-tls-webpki-roots-no-provider" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-webpki-roots-no-provider-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+slab-devel %package -n %{name}+slab-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch

@ -1 +1 @@
SHA512 (reqwest-0.12.8.crate) = c9f938b5b4fef1302b9901bfa73cfb2acfe78e31fb1f1b5c22efcb65c9b8a4b0c13b70aa0e5dc728562257d29d42c3297b243997c7d5f41edf06717ebbd8ccd6 SHA512 (reqwest-0.12.9.crate) = 027a31a57822a347fcc73101c602a5ec68dcb92f472d85dd76fe3465e45eb1e7ba07477700cb6a55ca77d926f9bc69b56a65499fc4dfebc5fe14732f56fa6441

Loading…
Cancel
Save