epel9
imports/epel9/rust-remove_dir_all0.7-0.7.0-1.el9
parent
251aba4672
commit
4072f86a92
@ -0,0 +1 @@
|
||||
/remove_dir_all-0.7.0.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-remove_dir_all0.7
|
||||
|
||||
The rust-remove_dir_all0.7 package
|
@ -0,0 +1,18 @@
|
||||
--- remove_dir_all-0.7.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ remove_dir_all-0.7.0/Cargo.toml 2023-11-05T10:55:55.614646+00:00
|
||||
@@ -32,15 +32,4 @@
|
||||
version = "3.1"
|
||||
[target."cfg(not(windows))".dependencies.libc]
|
||||
version = "0.2"
|
||||
-[target."cfg(windows)".dependencies.log]
|
||||
-version = "0.4.11"
|
||||
|
||||
-[target."cfg(windows)".dependencies.num_cpus]
|
||||
-version = "1.13"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.rayon]
|
||||
-version = "1.4"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3"
|
||||
-features = ["std", "errhandlingapi", "winerror", "fileapi", "winbase"]
|
@ -0,0 +1,73 @@
|
||||
# Generated by rust2rpm 25
|
||||
# * tests seem to be broken with Rust 1.55+
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate remove_dir_all
|
||||
|
||||
Name: rust-remove_dir_all0.7
|
||||
Version: 0.7.0
|
||||
Release: %autorelease
|
||||
Summary: Safe, reliable implementation of remove_dir_all
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/remove_dir_all
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: remove_dir_all-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A safe, reliable implementation of remove_dir_all for Windows.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENCE-APACHE
|
||||
%license %{crate_instdir}/LICENCE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,3 @@
|
||||
[package]
|
||||
summary = "Safe, reliable implementation of remove_dir_all"
|
||||
|
Loading…
Reference in new issue