import rust-remove_dir_all-0.8.2-1.el9

i9ce changed/i9ce/rust-remove_dir_all-0.8.2-1.el9
Arkady L. Shane 1 year ago
commit df75cdb448
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1,19 @@
--- remove_dir_all-0.8.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ remove_dir_all-0.8.2/Cargo.toml 2023-11-04T23:50:51.144272+00:00
@@ -101,16 +101,3 @@
[target."cfg(not(windows))".dependencies.libc]
version = "0.2"
-[target."cfg(windows)".dependencies.aligned]
-version = "0.4.1"
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.45.0"
-features = [
- "Win32_Foundation",
- "Win32_Storage_FileSystem",
- "Win32_System_IO",
- "Win32_System_Ioctl",
- "Win32_System_SystemServices",
- "Win32_System_Threading",
-]

@ -0,0 +1,39 @@
--- remove_dir_all-0.8.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ remove_dir_all-0.8.2/Cargo.toml 2023-11-04T23:51:34.050434+00:00
@@ -35,22 +35,10 @@
categories = ["filesystem"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/XAMPPRocky/remove_dir_all.git"
-
-[[bin]]
-name = "remove-dir-all"
-required-features = ["cli"]
+autobins = false
[dependencies.cfg-if]
version = "1.0.0"
-
-[dependencies.clap]
-version = "4.1.11"
-features = ["derive"]
-optional = true
-
-[dependencies.env_logger]
-version = "0.10.0"
-optional = true
[dependencies.fs_at]
version = "0.1.4"
@@ -85,12 +73,6 @@
version = "0.2"
[features]
-cli = [
- "dep:clap",
- "dep:env_logger",
- "log",
- "parallel",
-]
default = []
log = ["dep:log"]
parallel = ["dep:rayon"]

@ -0,0 +1,174 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate remove_dir_all
Name: rust-remove_dir_all
Version: 0.8.2
Release: %autorelease
Summary: Safe, reliable implementation of remove_dir_all
License: MIT OR Apache-2.0
URL: https://crates.io/crates/remove_dir_all
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: remove_dir_all-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * prevent unused remove-dir-all executable from being built and shipped
Patch: remove_dir_all-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A safe, reliable implementation of remove_dir_all for Windows.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENCE-APACHE
%license %{crate_instdir}/LICENCE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages which
use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parallel-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parallel-devel %{_description}
This package contains library source intended for building other packages which
use the "parallel" feature of the "%{crate}" crate.
%files -n %{name}+parallel-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.8.2-1
- Rebuilt for MSVSphere 9.3
* Sun Nov 26 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.2-1
- Update to version 0.8.2; Fixes RHBZ#2173156
* Sun Nov 26 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.0-8
- Regenerate with rust2rpm v24
* Wed Dec 29 2021 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.7.0-5
- Rebuild
* Mon Nov 22 2021 Fabio Valentini <decathorpe@gmail.com> - 0.7.0-3
- Disable tests as the seem to be broken with Rust 1.55+.
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed May 19 2021 Fabio Valentini <decathorpe@gmail.com> - 0.7.0-1
- Update to version 0.7.0.
- Fixes RHBZ#1872178
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Fri Jun 19 2020 Josh Stone <jistone@redhat.com> - 0.5.3-1
- Update to 0.5.3
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Thu Jun 20 12:30:09 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.2-1
- Update to 0.5.2
* Sun Jun 09 22:12:17 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-6
- Regenerate
* Sat Mar 09 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-5
- Adapt to new packaging
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Oct 27 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-3
- Adapt to new packaging
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Fri Apr 20 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-1
- Update to 0.5.1
* Mon Mar 12 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-1
- Update to 0.5.0
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Jan 31 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.0-1
- Initial package
Loading…
Cancel
Save