Update to 0.2.5

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 52f7201d7b
commit d56794dfd0

1
.gitignore vendored

@ -1,2 +1,3 @@
/regex-0.2.2.crate /regex-0.2.2.crate
/regex-0.2.3.crate /regex-0.2.3.crate
/regex-0.2.5.crate

@ -1,33 +0,0 @@
--- regex-0.2.3/Cargo.toml 1970-01-01T01:00:00+01:00
+++ regex-0.2.3/Cargo.toml 2017-12-02T17:38:02.425828+01:00
@@ -67,20 +67,16 @@
[dependencies.regex-syntax]
version = "0.4.1"
-[dependencies.simd]
-version = "0.1.1"
-optional = true
-
[dependencies.thread_local]
version = "0.3.2"
[dependencies.utf8-ranges]
version = "1.0.0"
[dev-dependencies.lazy_static]
-version = "0.2.2"
+version = "1"
[dev-dependencies.quickcheck]
-version = "0.4.1"
+version = "0.5"
default-features = false
[dev-dependencies.rand]
@@ -88,7 +84,6 @@
[features]
pattern = []
-simd-accel = ["simd"]
[badges.appveyor]
repository = "rust-lang-libs/regex"

@ -0,0 +1,21 @@
--- regex-0.2.5/Cargo.toml 1970-01-01T01:00:00+01:00
+++ regex-0.2.5/Cargo.toml 2017-12-31T14:30:02.726255+01:00
@@ -73,10 +73,6 @@
[dependencies.regex-syntax]
version = "0.4.1"
-[dependencies.simd]
-version = "0.2.1"
-optional = true
-
[dependencies.thread_local]
version = "0.3.2"
@@ -94,7 +90,6 @@
[features]
pattern = []
-simd-accel = ["simd"]
[badges.appveyor]
repository = "rust-lang-libs/regex"

@ -6,8 +6,8 @@
%global crate regex %global crate regex
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.2.3 Version: 0.2.5
Release: 3%{?dist} Release: 1%{?dist}
Summary: Implementation of regular expressions for Rust Summary: Implementation of regular expressions for Rust
License: MIT or ASL 2.0 License: MIT or ASL 2.0
@ -15,9 +15,7 @@ URL: https://crates.io/crates/regex
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata # Initial patched metadata
# * simd is nightly # * simd is nightly
# * Bump lazy_static to 1, https://github.com/rust-lang/regex/pull/423 Patch0: regex-0.2.5-fix-metadata.diff
# * Bump quickcheck to 0.5, https://github.com/rust-lang/regex/commit/f2ced64455d7e19555ec5bb1456fc073730c3aac
Patch0: regex-0.2.3-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -31,8 +29,8 @@ BuildRequires: (crate(utf8-ranges) >= 1.0.0 with crate(utf8-ranges) < 2.0.0)
%if %{with check} %if %{with check}
# [dev-dependencies] # [dev-dependencies]
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0) BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(quickcheck) >= 0.5.0 with crate(quickcheck) < 0.6.0) BuildRequires: (crate(quickcheck) >= 0.6.0 with crate(quickcheck) < 0.7.0)
BuildRequires: (crate(rand) >= 0.3.15 with crate(rand) < 0.4.0) BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
%endif %endif
%description %description
@ -71,6 +69,9 @@ which use %{crate} from crates.io.
%exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,ci,scripts} %exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,ci,scripts}
%changelog %changelog
* Sun Dec 31 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.5-1
- Update to 0.2.5
* Sat Dec 02 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.3-3 * Sat Dec 02 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.3-3
- Bump quickcheck to 0.5 - Bump quickcheck to 0.5

@ -1 +1 @@
SHA512 (regex-0.2.3.crate) = 639e8f0e62127fa9ba84a53c2b9e4774ed126eb48dc0f3bbe093d8683987d74e90124f5ba1722af9ad5d8487469320f6dd6e5e76bfaa64e170c788c41162b58e SHA512 (regex-0.2.5.crate) = 572f90bdfab4af1eed9905ef1b4ecdb97ad42849000f4efe0d0e24f7c1d4084ea0805dbdb7b18ed553c3ca796d64b5d2c59f4c1667608a7f74e29136172fde8c

Loading…
Cancel
Save