Update to 0.2.9

epel9
Josh Stone 7 years ago
parent 32bab3f15a
commit b55db0fce4

2
.gitignore vendored

@ -2,3 +2,5 @@
/regex-0.2.3.crate
/regex-0.2.5.crate
/regex-0.2.6.crate
/regex-0.2.7.crate
/regex-0.2.9.crate

@ -1,21 +0,0 @@
--- regex-0.2.5/Cargo.toml 1970-01-01T01:00:00+01:00
+++ regex-0.2.5/Cargo.toml 2017-12-31T14:30:02.726255+01:00
@@ -73,10 +73,6 @@
[dependencies.regex-syntax]
version = "0.4.1"
-[dependencies.simd]
-version = "0.2.1"
-optional = true
-
[dependencies.thread_local]
version = "0.3.2"
@@ -94,7 +90,6 @@
[features]
pattern = []
-simd-accel = ["simd"]
[badges.appveyor]
repository = "rust-lang-libs/regex"

@ -0,0 +1,10 @@
--- regex-0.2.9/Cargo.toml 1969-12-31T16:00:00-08:00
+++ regex-0.2.9/Cargo.toml 2018-03-13T21:59:01.505611-07:00
@@ -92,7 +92,6 @@
default = []
pattern = []
simd-accel = []
-unstable = ["pattern"]
[badges.appveyor]
repository = "rust-lang-libs/regex"

@ -6,7 +6,7 @@
%global crate regex
Name: rust-%{crate}
Version: 0.2.6
Version: 0.2.9
Release: 1%{?dist}
Summary: Implementation of regular expressions for Rust
@ -14,8 +14,8 @@ License: MIT or ASL 2.0
URL: https://crates.io/crates/regex
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * simd is nightly
Patch0: regex-0.2.5-fix-metadata.diff
# * unstable features require nightly
Patch0: regex-0.2.9-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -23,7 +23,7 @@ BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(aho-corasick) >= 0.6.0 with crate(aho-corasick) < 0.7.0)
BuildRequires: (crate(memchr) >= 2.0.0 with crate(memchr) < 3.0.0)
BuildRequires: (crate(regex-syntax) >= 0.4.1 with crate(regex-syntax) < 0.5.0)
BuildRequires: (crate(regex-syntax) >= 0.5.1 with crate(regex-syntax) < 0.6.0)
BuildRequires: (crate(thread_local) >= 0.3.2 with crate(thread_local) < 0.4.0)
BuildRequires: (crate(utf8-ranges) >= 1.0.0 with crate(utf8-ranges) < 2.0.0)
%if %{with check}
@ -64,11 +64,14 @@ which use %{crate} from crates.io.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md HACKING.md PERFORMANCE.md
%doc README.md CHANGELOG.md HACKING.md PERFORMANCE.md UNICODE.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,ci,scripts}
%changelog
* Wed Mar 14 2018 Josh Stone <jistone@redhat.com> - 0.2.9-1
- Update to 0.2.9
* Fri Feb 09 2018 Josh Stone <jistone@redhat.com> - 0.2.6-1
- Update to 0.2.6

@ -1 +1 @@
SHA512 (regex-0.2.6.crate) = 69c84096834b794227e4937db7598f35e8c489ef8445d3b5f3c0b2a73fe54be029f6db609b046441fda6374485c16943197f7416ed9545c784d14fb61c9e804d
SHA512 (regex-0.2.9.crate) = f35013e813af0cca21ff859bae06f26a0af48014ac721e57703502c1f5c036173185993a16c37946ccfb61b9172f73b8d08e1cbf3ec010332a4ea61e3d9cbf33

Loading…
Cancel
Save