parent
6053bce6a2
commit
420aa3e904
@ -0,0 +1 @@
|
|||||||
|
/regex-syntax-0.6.29.crate
|
@ -1,3 +0,0 @@
|
|||||||
# rust-regex-syntax0.6
|
|
||||||
|
|
||||||
The rust-regex-syntax0.6 package
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- regex-syntax-0.6.29/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ regex-syntax-0.6.29/Cargo.toml 2023-05-25T12:38:01.360730+00:00
|
||||||
|
@@ -18,7 +18,7 @@
|
||||||
|
homepage = "https://github.com/rust-lang/regex"
|
||||||
|
documentation = "https://docs.rs/regex-syntax"
|
||||||
|
readme = "README.md"
|
||||||
|
-license = "MIT OR Apache-2.0"
|
||||||
|
+license = "(MIT OR Apache-2.0) AND Unicode-DFS-2016"
|
||||||
|
repository = "https://github.com/rust-lang/regex"
|
||||||
|
|
||||||
|
[features]
|
@ -0,0 +1,170 @@
|
|||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate regex-syntax
|
||||||
|
|
||||||
|
Name: rust-regex-syntax0.6
|
||||||
|
Version: 0.6.29
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Regular expression parser
|
||||||
|
|
||||||
|
License: (MIT OR Apache-2.0) AND Unicode-DFS-2016
|
||||||
|
URL: https://crates.io/crates/regex-syntax
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * add missing Unicode license terms to crate metadata:
|
||||||
|
# https://github.com/rust-lang/regex/discussions/933
|
||||||
|
Patch: regex-syntax-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A regular expression parser.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%license %{crate_instdir}/src/unicode_tables/LICENSE-UNICODE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-age-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-age-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-age" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-age-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-bool-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-bool-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-bool" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-bool-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-case-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-case-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-case" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-case-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-gencat-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-gencat-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-gencat" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-gencat-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-perl-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-perl-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-perl" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-perl-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-script-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-script-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-script" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-script-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unicode-segment-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unicode-segment-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unicode-segment" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unicode-segment-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue