parent
e49d81d166
commit
ef8df5bc13
@ -0,0 +1,28 @@
|
||||
From f2ced64455d7e19555ec5bb1456fc073730c3aac Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Wed, 29 Nov 2017 11:06:48 +0100
|
||||
Subject: [PATCH] bump quickcheck to 0.5
|
||||
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
regex-syntax/src/properties.rs | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/regex-syntax/src/properties.rs b/regex-syntax/src/properties.rs
|
||||
index 9e75f99..c1da573 100644
|
||||
--- a/regex-syntax/src/properties.rs
|
||||
+++ b/regex-syntax/src/properties.rs
|
||||
@@ -188,8 +188,8 @@ impl Arbitrary for Expr {
|
||||
ClassBytes(ref cls) => Box::new(cls.shrink().map(ClassBytes)),
|
||||
Group { ref e, ref i, ref name } => {
|
||||
let (i, name) = (i.clone(), name.clone());
|
||||
- Box::new(e.clone().shrink()
|
||||
- .chain(e.clone().shrink()
|
||||
+ Box::new((*e.clone()).shrink()
|
||||
+ .chain((*e.clone()).shrink()
|
||||
.map(move |e| Group {
|
||||
e: Box::new(e),
|
||||
i: i.clone(),
|
||||
--
|
||||
2.15.1
|
||||
|
@ -0,0 +1,9 @@
|
||||
--- regex-syntax-0.4.1/Cargo.toml 2017-05-21T18:24:14+02:00
|
||||
+++ regex-syntax-0.4.1/Cargo.toml 2017-12-02T17:40:02.434555+01:00
|
||||
@@ -9,5 +9,5 @@
|
||||
description = "A regular expression parser."
|
||||
|
||||
[dev-dependencies]
|
||||
-quickcheck = { version = "0.4.1", default-features = false }
|
||||
+quickcheck = { version = "0.5", default-features = false }
|
||||
rand = "0.3.15"
|
Loading…
Reference in new issue