parent
076950b0d4
commit
6b2e60f768
@ -0,0 +1 @@
|
|||||||
|
/regex-automata-0.1.10.crate
|
@ -1,3 +0,0 @@
|
|||||||
# rust-regex-automata0.1
|
|
||||||
|
|
||||||
The rust-regex-automata0.1 package
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- regex-automata-0.1.10/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ regex-automata-0.1.10/Cargo.toml 2023-07-07T18:27:26.582864+00:00
|
||||||
|
@@ -14,7 +14,7 @@
|
||||||
|
name = "regex-automata"
|
||||||
|
version = "0.1.10"
|
||||||
|
authors = ["Andrew Gallant <jamslam@gmail.com>"]
|
||||||
|
-exclude = ["/.travis.yml", "/appveyor.yml", "/ci/*", "/scripts/*", "/regex-automata-debug"]
|
||||||
|
+exclude = ["/.travis.yml", "/appveyor.yml", "/ci/*", "/scripts/*", "/regex-automata-debug", "/data/*"]
|
||||||
|
autoexamples = false
|
||||||
|
autotests = false
|
||||||
|
description = "Automata construction and matching using regular expressions."
|
@ -0,0 +1,99 @@
|
|||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate regex-automata
|
||||||
|
|
||||||
|
Name: rust-regex-automata0.1
|
||||||
|
Version: 0.1.10
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Automata construction and matching using regular expressions
|
||||||
|
|
||||||
|
# Upstream license specification: Unlicense/MIT
|
||||||
|
License: Unlicense OR MIT
|
||||||
|
URL: https://crates.io/crates/regex-automata
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * prevent test data from being installed
|
||||||
|
Patch: regex-automata-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Automata construction and matching using regular expressions.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/COPYING
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%license %{crate_instdir}/UNLICENSE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%doc %{crate_instdir}/TODO
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+regex-syntax-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+regex-syntax-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "regex-syntax" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+regex-syntax-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1,4 @@
|
|||||||
|
[DEFAULT]
|
||||||
|
unwanted-features =
|
||||||
|
fst
|
||||||
|
transducer
|
Loading…
Reference in new issue