Update to version 0.4.2; Fixes RHBZ#2241489

epel9
Fabio Valentini 1 year ago
parent 2fda38f4cc
commit 6bb9c2f956
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

2
.gitignore vendored

@ -8,3 +8,5 @@
/regex-automata-0.3.4.crate
/regex-automata-0.3.7.crate
/regex-automata-0.3.8.crate
/regex-automata-0.4.1.crate
/regex-automata-0.4.2.crate

@ -0,0 +1,34 @@
From fe43117b051983b7869dae45658319becd971534 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Sun, 15 Oct 2023 00:59:37 +0200
Subject: [PATCH] regex-automata: fix compilation of doctests on 32-bit
architectures
---
src/util/captures.rs | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/util/captures.rs b/src/util/captures.rs
index cd3a5f8..05db6a9 100644
--- a/src/util/captures.rs
+++ b/src/util/captures.rs
@@ -433,7 +433,6 @@ impl Captures {
///
/// ```
/// # if cfg!(miri) { return Ok(()); } // miri takes too long
- /// # if !cfg!(target_pointer_width = "64") { return Ok(()); } // see #1039
/// use regex_automata::{nfa::thompson::pikevm::PikeVM, Span, Match};
///
/// let re = PikeVM::new(r"^(?P<first>\pL+)\s+(?P<last>\pL+)$")?;
@@ -445,6 +444,8 @@ impl Captures {
/// assert_eq!(Some(Span::from(6..17)), caps.get_group(2));
/// // Looking for a non-existent capturing group will return None:
/// assert_eq!(None, caps.get_group(3));
+ /// # // literals are too big for 32-bit usize: #1039
+ /// # #[cfg(target_pointer_width = "64")]
/// assert_eq!(None, caps.get_group(9944060567225171988));
///
/// # Ok::<(), Box<dyn std::error::Error>>(())
--
2.41.0

@ -1,10 +0,0 @@
--- regex-automata-0.3.8/Cargo.toml 1970-01-01T00:00:01+00:00
+++ regex-automata-0.3.8/Cargo.toml 2023-09-19T20:25:23.521202+00:00
@@ -31,6 +31,7 @@
categories = ["text-processing"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/regex/tree/master/regex-automata"
+exclude = ["/test/"]
[lib]
bench = false

@ -1,20 +1,18 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate regex-automata
Name: rust-regex-automata
Version: 0.3.8
Version: 0.4.2
Release: %autorelease
Summary: Automata construction and matching using regular expressions
License: MIT OR Apache-2.0
URL: https://crates.io/crates/regex-automata
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * prevent test data from being installed
Patch: regex-automata-fix-metadata.diff
Patch: 0001-regex-automata-fix-compilation-of-doctests-on-32-bit.patch
BuildRequires: cargo-rpm-macros >= 24
@ -411,7 +409,7 @@ use the "unicode-word-boundary" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
@ -427,14 +425,8 @@ use the "unicode-word-boundary" feature of the "%{crate}" crate.
%check
# * integration tests can only be run in-tree
%cargo_test -- --lib
%ifarch %{ix86}
# * ignore harmless test failures on 32-bit architectures:
# https://github.com/rust-lang/regex/issues/1039
%cargo_test -- --doc -- --skip dfa::dense::Config::determinize_size_limit --skip util::captures::Captures::get_group
%else
%cargo_test -- --doc
%endif
%endif
%changelog
%autochangelog

@ -0,0 +1,3 @@
[tests]
run = ["lib", "doc"]
comments = ["integration tests can only be run in-tree"]

@ -1 +1 @@
SHA512 (regex-automata-0.3.8.crate) = 47ad01be2c51fd510576e14f399b7f30d379a2cce2dbef3af4ee3e609859451082885132ae703c810e2b19bb3716976356e057a1a592ed507146aff9e7138dac
SHA512 (regex-automata-0.4.2.crate) = e8d9aa7ab3e86d02c3e72809500f6a1ceb2ce1f06a15af70b697ccd99d7be05a4d8f39f513e16f8f1d1983c805691e663135c0620f9cfd171868e2b0b803f2d0

Loading…
Cancel
Save