parent
2fda38f4cc
commit
6bb9c2f956
@ -0,0 +1,34 @@
|
|||||||
|
From fe43117b051983b7869dae45658319becd971534 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Sun, 15 Oct 2023 00:59:37 +0200
|
||||||
|
Subject: [PATCH] regex-automata: fix compilation of doctests on 32-bit
|
||||||
|
architectures
|
||||||
|
|
||||||
|
---
|
||||||
|
src/util/captures.rs | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/util/captures.rs b/src/util/captures.rs
|
||||||
|
index cd3a5f8..05db6a9 100644
|
||||||
|
--- a/src/util/captures.rs
|
||||||
|
+++ b/src/util/captures.rs
|
||||||
|
@@ -433,7 +433,6 @@ impl Captures {
|
||||||
|
///
|
||||||
|
/// ```
|
||||||
|
/// # if cfg!(miri) { return Ok(()); } // miri takes too long
|
||||||
|
- /// # if !cfg!(target_pointer_width = "64") { return Ok(()); } // see #1039
|
||||||
|
/// use regex_automata::{nfa::thompson::pikevm::PikeVM, Span, Match};
|
||||||
|
///
|
||||||
|
/// let re = PikeVM::new(r"^(?P<first>\pL+)\s+(?P<last>\pL+)$")?;
|
||||||
|
@@ -445,6 +444,8 @@ impl Captures {
|
||||||
|
/// assert_eq!(Some(Span::from(6..17)), caps.get_group(2));
|
||||||
|
/// // Looking for a non-existent capturing group will return None:
|
||||||
|
/// assert_eq!(None, caps.get_group(3));
|
||||||
|
+ /// # // literals are too big for 32-bit usize: #1039
|
||||||
|
+ /// # #[cfg(target_pointer_width = "64")]
|
||||||
|
/// assert_eq!(None, caps.get_group(9944060567225171988));
|
||||||
|
///
|
||||||
|
/// # Ok::<(), Box<dyn std::error::Error>>(())
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
@ -1,10 +0,0 @@
|
|||||||
--- regex-automata-0.3.8/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
||||||
+++ regex-automata-0.3.8/Cargo.toml 2023-09-19T20:25:23.521202+00:00
|
|
||||||
@@ -31,6 +31,7 @@
|
|
||||||
categories = ["text-processing"]
|
|
||||||
license = "MIT OR Apache-2.0"
|
|
||||||
repository = "https://github.com/rust-lang/regex/tree/master/regex-automata"
|
|
||||||
+exclude = ["/test/"]
|
|
||||||
|
|
||||||
[lib]
|
|
||||||
bench = false
|
|
@ -0,0 +1,3 @@
|
|||||||
|
[tests]
|
||||||
|
run = ["lib", "doc"]
|
||||||
|
comments = ["integration tests can only be run in-tree"]
|
@ -1 +1 @@
|
|||||||
SHA512 (regex-automata-0.3.8.crate) = 47ad01be2c51fd510576e14f399b7f30d379a2cce2dbef3af4ee3e609859451082885132ae703c810e2b19bb3716976356e057a1a592ed507146aff9e7138dac
|
SHA512 (regex-automata-0.4.2.crate) = e8d9aa7ab3e86d02c3e72809500f6a1ceb2ce1f06a15af70b697ccd99d7be05a4d8f39f513e16f8f1d1983c805691e663135c0620f9cfd171868e2b0b803f2d0
|
||||||
|
Loading…
Reference in new issue