Initial import (#2290393)
parent
cba8431d92
commit
f3088827c0
@ -0,0 +1 @@
|
||||
/ravif-0.11.5.crate
|
@ -0,0 +1,10 @@
|
||||
--- ravif-0.11.5/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ ravif-0.11.5/Cargo.toml 2024-06-04T14:12:27.706295+00:00
|
||||
@@ -77,7 +77,3 @@
|
||||
asm = ["rav1e/asm"]
|
||||
default = ["asm"]
|
||||
|
||||
-[target."cfg(target = \"wasm32-unknown-unknown\")".dependencies.rav1e]
|
||||
-version = "0.7"
|
||||
-features = ["wasm"]
|
||||
-default-features = false
|
@ -0,0 +1,83 @@
|
||||
# Generated by rust2rpm 26
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate ravif
|
||||
|
||||
Name: rust-ravif
|
||||
Version: 0.11.5
|
||||
Release: %autorelease
|
||||
Summary: Rav1e-based pure Rust library for encoding images in AVIF format
|
||||
|
||||
License: BSD-3-Clause
|
||||
URL: https://crates.io/crates/ravif
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: ravif-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Rav1e-based pure Rust library for encoding images in AVIF format (powers
|
||||
the `cavif` tool).}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+asm-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+asm-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "asm" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+asm-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue