Update to 0.1.2

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent ba8e784649
commit f60db37034
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/rand_pcg-0.1.1.crate
/rand_pcg-0.1.2.crate

@ -1,23 +0,0 @@
--- rand_pcg-0.1.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ rand_pcg-0.1.1/Cargo.toml 2018-12-12T08:18:37.666798+01:00
@@ -23,9 +23,9 @@
categories = ["algorithms", "no-std"]
license = "MIT/Apache-2.0"
repository = "https://github.com/rust-random/small-rngs"
-[dependencies.bincode]
+[dev-dependencies.bincode]
version = "1"
-optional = true
+features = ["i128"]
[dependencies.rand_core]
version = "0.3"
@@ -42,7 +42,7 @@
version = "0.2"
[features]
-serde1 = ["serde", "serde_derive", "bincode/i128"]
+serde1 = ["serde", "serde_derive"]
[badges.appveyor]
repository = "rust-random/small-rngs"

@ -6,28 +6,24 @@
%global crate rand_pcg
Name: rust-%{crate}
Version: 0.1.1
Release: 4%{?dist}
Version: 0.1.2
Release: 1%{?dist}
Summary: Selected PCG random number generators
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/rand_pcg
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Mark bincode as dev-dependency, https://github.com/rust-random/rand/issues/663
Patch0: rand_pcg-fix-metadata.diff
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(rand_core) >= 0.3.0 with crate(rand_core) < 0.4.0)
BuildRequires: (crate(rustc_version/default) >= 0.2.0 with crate(rustc_version/default) < 0.3.0)
BuildRequires: (crate(autocfg/default) >= 0.1.0 with crate(autocfg/default) < 0.2.0)
BuildRequires: (crate(rand_core/default) >= 0.4.0 with crate(rand_core/default) < 0.5.0)
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.38 with crate(serde_derive/default) < 2.0.0)
%if %{with check}
BuildRequires: (crate(bincode/default) >= 1.0.0 with crate(bincode/default) < 2.0.0)
BuildRequires: (crate(bincode/i128) >= 1.0.0 with crate(bincode/i128) < 2.0.0)
BuildRequires: (crate(bincode/default) >= 1.1.2 with crate(bincode/default) < 2.0.0)
%endif
%global _description \
@ -98,7 +94,7 @@ which use "serde_derive" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
@ -113,6 +109,9 @@ which use "serde_derive" feature of "%{crate}" crate.
%endif
%changelog
* Sat Feb 23 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.2-1
- Update to 0.1.2
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1 +1 @@
SHA512 (rand_pcg-0.1.1.crate) = 5104d9a3352f631eb7775218fae6da430d0b26c500aa10a333baa0b1b3d4ff7ff6e8a0162cfe8f514382b0a9342a00e3d2ad6b0313047c5e0c324f3184cfa9e3
SHA512 (rand_pcg-0.1.2.crate) = 6bc684778ba60c2e48793d4759b40cb0d35b0bc20ca0fc39fdff7c3f8fe9082dd7b5d5f26a7f17bafc6f3568924eac1bbe45820b1c2b09c91731ea5487d76d9c

Loading…
Cancel
Save