Update to 0.5.6

epel9
Josh Stone 6 years ago
parent 124a78480a
commit f659318393

1
.gitignore vendored

@ -1 +1,2 @@
/rand-0.5.5.crate
/rand-0.5.6.crate

@ -1,5 +1,5 @@
--- rand-0.5.5/Cargo.toml 1970-01-01T01:00:00+01:00
+++ rand-0.5.5/Cargo.toml 2018-10-27T02:24:57.333044+02:00
--- rand-0.5.6/Cargo.toml 1969-12-31T16:00:00-08:00
+++ rand-0.5.6/Cargo.toml 2019-01-28T13:43:27.101496-08:00
@@ -22,6 +22,7 @@
categories = ["algorithms", "no-std"]
license = "MIT/Apache-2.0"
@ -12,12 +12,12 @@
i128_support = []
nightly = ["i128_support"]
serde1 = ["serde", "serde_derive", "rand_core/serde1"]
-std = ["rand_core/std", "alloc", "libc", "winapi", "cloudabi", "fuchsia-zircon"]
-std = ["rand_core/std", "alloc", "libc", "winapi", "cloudabi", "fuchsia-cprng"]
-[target."cfg(target_os = \"cloudabi\")".dependencies.cloudabi]
-version = "0.0.3"
-optional = true
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-zircon]
-version = "0.3.2"
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-cprng]
-version = "0.1.0"
-optional = true
+std = ["rand_core/std", "alloc", "libc"]
[target."cfg(unix)".dependencies.libc]

@ -6,7 +6,7 @@
%global crate rand
Name: rust-%{crate}0.5
Version: 0.5.5
Version: 0.5.6
Release: 1%{?dist}
Summary: Random number generators and other randomness functionality
@ -24,10 +24,10 @@ ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)
BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
BuildRequires: (crate(rand_core) >= 0.2.0 with crate(rand_core) < 0.3.0)
BuildRequires: (crate(rand_core/alloc) >= 0.2.0 with crate(rand_core/alloc) < 0.3.0)
BuildRequires: (crate(rand_core/serde1) >= 0.2.0 with crate(rand_core/serde1) < 0.3.0)
BuildRequires: (crate(rand_core/std) >= 0.2.0 with crate(rand_core/std) < 0.3.0)
BuildRequires: (crate(rand_core) >= 0.3.0 with crate(rand_core) < 0.4.0)
BuildRequires: (crate(rand_core/alloc) >= 0.3.0 with crate(rand_core/alloc) < 0.4.0)
BuildRequires: (crate(rand_core/serde1) >= 0.3.0 with crate(rand_core/serde1) < 0.4.0)
BuildRequires: (crate(rand_core/std) >= 0.3.0 with crate(rand_core/std) < 0.4.0)
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.0 with crate(serde_derive/default) < 2.0.0)
%if %{with check}
@ -178,5 +178,8 @@ which use "std" feature of "%{crate}" crate.
%endif
%changelog
* Mon Jan 28 2019 Josh Stone <jistone@redhat.com> - 0.5.6-1
- Update to 0.5.6
* Mon Dec 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.5-1
- Initial import

@ -1 +1 @@
SHA512 (rand-0.5.5.crate) = e135a9c97943662bcea9c4730f19ec6e01ea73303801101592c14e97b59adbbc3457ed7a3dd57843776f5febb6fa34890aad9d1c2c596ae89416e1a281062cc8
SHA512 (rand-0.5.6.crate) = 0e2a643eadf6cd9f035eb720b540b838a00d6c790b1a99b36cec349c2e24dcaadcae6607f99fe86957e77b244d356dfba436a03c1d4d0756d6f8362c19087b64

Loading…
Cancel
Save