parent
eff95c6756
commit
caf49649d1
@ -0,0 +1 @@
|
|||||||
|
/rand-0.5.5.crate
|
@ -0,0 +1,34 @@
|
|||||||
|
--- rand-0.5.5/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ rand-0.5.5/Cargo.toml 2018-10-27T02:24:57.333044+02:00
|
||||||
|
@@ -22,6 +22,7 @@
|
||||||
|
categories = ["algorithms", "no-std"]
|
||||||
|
license = "MIT/Apache-2.0"
|
||||||
|
repository = "https://github.com/rust-lang-nursery/rand"
|
||||||
|
+exclude = ["/utils/*", "/.travis.yml", "/appveyor.yml"]
|
||||||
|
[package.metadata.docs.rs]
|
||||||
|
all-features = true
|
||||||
|
[dependencies.log]
|
||||||
|
@@ -48,22 +49,9 @@
|
||||||
|
i128_support = []
|
||||||
|
nightly = ["i128_support"]
|
||||||
|
serde1 = ["serde", "serde_derive", "rand_core/serde1"]
|
||||||
|
-std = ["rand_core/std", "alloc", "libc", "winapi", "cloudabi", "fuchsia-zircon"]
|
||||||
|
-[target."cfg(target_os = \"cloudabi\")".dependencies.cloudabi]
|
||||||
|
-version = "0.0.3"
|
||||||
|
-optional = true
|
||||||
|
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-zircon]
|
||||||
|
-version = "0.3.2"
|
||||||
|
-optional = true
|
||||||
|
+std = ["rand_core/std", "alloc", "libc"]
|
||||||
|
[target."cfg(unix)".dependencies.libc]
|
||||||
|
version = "0.2"
|
||||||
|
-optional = true
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3"
|
||||||
|
-features = ["minwindef", "ntsecapi", "profileapi", "winnt"]
|
||||||
|
-optional = true
|
||||||
|
-[target.wasm32-unknown-unknown.dependencies.stdweb]
|
||||||
|
-version = "0.4"
|
||||||
|
optional = true
|
||||||
|
[badges.appveyor]
|
||||||
|
repository = "alexcrichton/rand"
|
@ -0,0 +1,182 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
# * Tests are run in infrastructure
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate rand
|
||||||
|
|
||||||
|
Name: rust-%{crate}0.5
|
||||||
|
Version: 0.5.5
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Random number generators and other randomness functionality
|
||||||
|
|
||||||
|
# Upstream license specification: MIT/Apache-2.0
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/rand
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Exclude CI files, https://github.com/rust-random/rand/pull/635
|
||||||
|
# * Remove non-unix dependencies
|
||||||
|
Patch0: rand-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
BuildRequires: (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)
|
||||||
|
BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
|
||||||
|
BuildRequires: (crate(rand_core) >= 0.2.0 with crate(rand_core) < 0.3.0)
|
||||||
|
BuildRequires: (crate(rand_core/alloc) >= 0.2.0 with crate(rand_core/alloc) < 0.3.0)
|
||||||
|
BuildRequires: (crate(rand_core/serde1) >= 0.2.0 with crate(rand_core/serde1) < 0.3.0)
|
||||||
|
BuildRequires: (crate(rand_core/std) >= 0.2.0 with crate(rand_core/std) < 0.3.0)
|
||||||
|
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
|
||||||
|
BuildRequires: (crate(serde_derive/default) >= 1.0.0 with crate(serde_derive/default) < 2.0.0)
|
||||||
|
%if %{with check}
|
||||||
|
BuildRequires: (crate(bincode/default) >= 1.0.0 with crate(bincode/default) < 2.0.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%global _description \
|
||||||
|
Random number generators and other randomness functionality.
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md CHANGELOG.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+alloc-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+alloc-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "alloc" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+alloc-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+i128_support-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+i128_support-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "i128_support" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+i128_support-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+libc-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+libc-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "libc" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+libc-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+log-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+log-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "log" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+log-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "serde" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde1-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde1-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "serde1" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde1-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde_derive-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde_derive-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "serde_derive" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde_derive-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "std" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Dec 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.5-1
|
||||||
|
- Initial import
|
Loading…
Reference in new issue