commit
c04aa6fb57
Binary file not shown.
@ -0,0 +1,34 @@
|
|||||||
|
--- rand-0.5.6/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ rand-0.5.6/Cargo.toml 2019-06-22T07:54:04.893889+00:00
|
||||||
|
@@ -22,6 +22,7 @@
|
||||||
|
categories = ["algorithms", "no-std"]
|
||||||
|
license = "MIT/Apache-2.0"
|
||||||
|
repository = "https://github.com/rust-lang-nursery/rand"
|
||||||
|
+exclude = ["/utils/*", "/.travis.yml", "/appveyor.yml"]
|
||||||
|
[package.metadata.docs.rs]
|
||||||
|
all-features = true
|
||||||
|
[dependencies.log]
|
||||||
|
@@ -48,22 +49,9 @@
|
||||||
|
i128_support = []
|
||||||
|
nightly = ["i128_support"]
|
||||||
|
serde1 = ["serde", "serde_derive", "rand_core/serde1"]
|
||||||
|
-std = ["rand_core/std", "alloc", "libc", "winapi", "cloudabi", "fuchsia-cprng"]
|
||||||
|
-[target."cfg(target_os = \"cloudabi\")".dependencies.cloudabi]
|
||||||
|
-version = "0.0.3"
|
||||||
|
-optional = true
|
||||||
|
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-cprng]
|
||||||
|
-version = "0.1.0"
|
||||||
|
-optional = true
|
||||||
|
+std = ["rand_core/std", "alloc", "libc"]
|
||||||
|
[target."cfg(unix)".dependencies.libc]
|
||||||
|
version = "0.2"
|
||||||
|
-optional = true
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3"
|
||||||
|
-features = ["minwindef", "ntsecapi", "profileapi", "winnt"]
|
||||||
|
-optional = true
|
||||||
|
-[target.wasm32-unknown-unknown.dependencies.stdweb]
|
||||||
|
-version = "0.4"
|
||||||
|
optional = true
|
||||||
|
[badges.appveyor]
|
||||||
|
repository = "alexcrichton/rand"
|
@ -0,0 +1,229 @@
|
|||||||
|
# Generated by rust2rpm 13
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate rand
|
||||||
|
|
||||||
|
Name: rust-%{crate}0.5
|
||||||
|
Version: 0.5.6
|
||||||
|
Release: 13%{?dist}
|
||||||
|
Summary: Random number generators and other randomness functionality
|
||||||
|
|
||||||
|
# Upstream license specification: MIT/Apache-2.0
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/rand
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Exclude CI files, https://github.com/rust-random/rand/pull/635
|
||||||
|
# * Remove non-unix dependencies
|
||||||
|
Patch0: rand-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Random number generators and other randomness functionality.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md CHANGELOG.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+alloc-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+alloc-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "alloc" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+alloc-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+i128_support-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+i128_support-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "i128_support" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+i128_support-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+libc-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+libc-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "libc" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+libc-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+log-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+log-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "log" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+log-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+nightly-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+nightly-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "nightly" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+nightly-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "serde" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde1-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde1-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "serde1" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde1-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde_derive-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde_derive-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "serde_derive" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde_derive-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "std" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.5.6-13
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.6-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.6-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.6-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.6-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.6-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Feb 18 03:54:19 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.5.6-8
|
||||||
|
- Disable tests
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.6-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Dec 10 2019 Josh Stone <jistone@redhat.com> - 0.5.6-6
|
||||||
|
- Allow warnings in doctests
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.6-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 22 09:54:04 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.6-4
|
||||||
|
- Regenerate
|
||||||
|
|
||||||
|
* Sat Mar 16 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.6-3
|
||||||
|
- Do not pull optional dependencies
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 28 2019 Josh Stone <jistone@redhat.com> - 0.5.6-1
|
||||||
|
- Update to 0.5.6
|
||||||
|
|
||||||
|
* Mon Dec 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.5-1
|
||||||
|
- Initial import
|
Loading…
Reference in new issue