Disable tests

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 5 years ago
parent 0cfade6c4d
commit 65912ef1f6
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,11 +0,0 @@
--- rand-0.5.6/src/lib.rs.orig 2019-01-26 02:19:33.000000000 -0800
+++ rand-0.5.6/src/lib.rs 2019-12-10 12:35:23.150740539 -0800
@@ -228,7 +228,7 @@
#![deny(missing_docs)]
#![deny(missing_debug_implementations)]
-#![doc(test(attr(allow(unused_variables), deny(warnings))))]
+#![doc(test(attr(allow(unused_variables))))]
#![cfg_attr(not(feature="std"), no_std)]
#![cfg_attr(all(feature="alloc", not(feature="std")), feature(alloc))]

@ -1,12 +1,12 @@
# Generated by rust2rpm 10 # Generated by rust2rpm 13
%bcond_without check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate rand %global crate rand
Name: rust-%{crate}0.5 Name: rust-%{crate}0.5
Version: 0.5.6 Version: 0.5.6
Release: 7%{?dist} Release: 8%{?dist}
Summary: Random number generators and other randomness functionality Summary: Random number generators and other randomness functionality
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
@ -17,7 +17,6 @@ Source: %{crates_source}
# * Exclude CI files, https://github.com/rust-random/rand/pull/635 # * Exclude CI files, https://github.com/rust-random/rand/pull/635
# * Remove non-unix dependencies # * Remove non-unix dependencies
Patch0: rand-fix-metadata.diff Patch0: rand-fix-metadata.diff
Patch1: rand-0.5.6-allow-warnings.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
@ -43,7 +42,7 @@ which use "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE %license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md %doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -55,7 +54,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate. which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+alloc-devel %package -n %{name}+alloc-devel
Summary: %{summary} Summary: %{summary}
@ -67,7 +66,7 @@ This package contains library source intended for building other packages
which use "alloc" feature of "%{crate}" crate. which use "alloc" feature of "%{crate}" crate.
%files -n %{name}+alloc-devel %files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+i128_support-devel %package -n %{name}+i128_support-devel
Summary: %{summary} Summary: %{summary}
@ -79,7 +78,7 @@ This package contains library source intended for building other packages
which use "i128_support" feature of "%{crate}" crate. which use "i128_support" feature of "%{crate}" crate.
%files -n %{name}+i128_support-devel %files -n %{name}+i128_support-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+libc-devel %package -n %{name}+libc-devel
Summary: %{summary} Summary: %{summary}
@ -91,7 +90,7 @@ This package contains library source intended for building other packages
which use "libc" feature of "%{crate}" crate. which use "libc" feature of "%{crate}" crate.
%files -n %{name}+libc-devel %files -n %{name}+libc-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+log-devel %package -n %{name}+log-devel
Summary: %{summary} Summary: %{summary}
@ -103,7 +102,7 @@ This package contains library source intended for building other packages
which use "log" feature of "%{crate}" crate. which use "log" feature of "%{crate}" crate.
%files -n %{name}+log-devel %files -n %{name}+log-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+nightly-devel %package -n %{name}+nightly-devel
Summary: %{summary} Summary: %{summary}
@ -115,7 +114,7 @@ This package contains library source intended for building other packages
which use "nightly" feature of "%{crate}" crate. which use "nightly" feature of "%{crate}" crate.
%files -n %{name}+nightly-devel %files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
@ -127,7 +126,7 @@ This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate. which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde1-devel %package -n %{name}+serde1-devel
Summary: %{summary} Summary: %{summary}
@ -139,7 +138,7 @@ This package contains library source intended for building other packages
which use "serde1" feature of "%{crate}" crate. which use "serde1" feature of "%{crate}" crate.
%files -n %{name}+serde1-devel %files -n %{name}+serde1-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde_derive-devel %package -n %{name}+serde_derive-devel
Summary: %{summary} Summary: %{summary}
@ -151,7 +150,7 @@ This package contains library source intended for building other packages
which use "serde_derive" feature of "%{crate}" crate. which use "serde_derive" feature of "%{crate}" crate.
%files -n %{name}+serde_derive-devel %files -n %{name}+serde_derive-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
@ -163,7 +162,7 @@ This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate. which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -184,6 +183,9 @@ which use "std" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Tue Feb 18 03:54:19 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.5.6-8
- Disable tests
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.6-7 * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.6-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

Loading…
Cancel
Save