parent
f3bea8b5dd
commit
fcec663123
@ -0,0 +1 @@
|
|||||||
|
/rand-0.3.17.crate
|
@ -0,0 +1,8 @@
|
|||||||
|
--- rand-0.3.17/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ rand-0.3.17/Cargo.toml 2017-10-27T17:54:42.049784+02:00
|
||||||
|
@@ -30,5 +30,3 @@
|
||||||
|
[features]
|
||||||
|
nightly = ["i128_support"]
|
||||||
|
i128_support = []
|
||||||
|
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-zircon]
|
||||||
|
-version = "^0.2.1"
|
@ -0,0 +1,74 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate rand
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.3.17
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Random number generators and other randomness functionality
|
||||||
|
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/rand
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * This OS doesn't sound related to Fedora
|
||||||
|
Patch0: rand-0.3.17-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
|
||||||
|
%if %{with check}
|
||||||
|
# [dev-dependencies]
|
||||||
|
BuildRequires: (crate(log) >= 0.3.0 with crate(log) < 0.4.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Random number generators and other randomness functionality.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Oct 27 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.17-1
|
||||||
|
- Update to 0.3.17
|
||||||
|
|
||||||
|
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.15-3
|
||||||
|
- Port to use rust-packaging
|
||||||
|
|
||||||
|
* Fri Feb 24 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.15-2
|
||||||
|
- Use rich dependencies
|
||||||
|
|
||||||
|
* Sun Feb 12 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.15-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue