Merge branch 'rawhide' into epel9

epel9 imports/e9/rust-rand-0.8.5-3.el9
Fabio Valentini 2 years ago
commit a7022c7fd3
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -17,3 +17,4 @@
/rand-0.8.2.crate /rand-0.8.2.crate
/rand-0.8.3.crate /rand-0.8.3.crate
/rand-0.8.4.crate /rand-0.8.4.crate
/rand-0.8.5.crate

@ -1,18 +0,0 @@
--- rand-0.8.4/Cargo.toml 1970-01-01T00:00:00+00:00
+++ rand-0.8.4/Cargo.toml 2021-06-17T08:18:29.182805+00:00
@@ -67,14 +67,11 @@
simd_support = ["packed_simd"]
small_rng = []
std = ["rand_core/std", "rand_chacha/std", "alloc", "getrandom", "libc"]
-std_rng = ["rand_chacha", "rand_hc"]
+std_rng = ["rand_chacha"]
[target."cfg(not(target_os = \"emscripten\"))".dependencies.rand_chacha]
version = "0.3.0"
optional = true
default-features = false
-[target."cfg(target_os = \"emscripten\")".dependencies.rand_hc]
-version = "0.3.0"
-optional = true
[target."cfg(unix)".dependencies.libc]
version = "0.2.22"
optional = true

@ -1,11 +1,11 @@
# Generated by rust2rpm 19 # Generated by rust2rpm 20
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate rand %global crate rand
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.8.4 Version: 0.8.5
Release: %autorelease Release: %autorelease
Summary: Random number generators and other randomness functionality Summary: Random number generators and other randomness functionality
@ -13,14 +13,8 @@ Summary: Random number generators and other randomness functionality
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/rand URL: https://crates.io/crates/rand
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * drop emscripten-specific dependencies and features
Patch0: rand-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
@ -36,7 +30,7 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license COPYRIGHT LICENSE-APACHE LICENSE-MIT %license COPYRIGHT LICENSE-APACHE LICENSE-MIT
@ -50,7 +44,7 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the default" feature of the "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -62,7 +56,7 @@ BuildArch: noarch
%description -n %{name}+alloc-devel %{_description} %description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the alloc" feature of the "%{crate}" crate. use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel %files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -74,7 +68,7 @@ BuildArch: noarch
%description -n %{name}+getrandom-devel %{_description} %description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the getrandom" feature of the "%{crate}" crate. use the "getrandom" feature of the "%{crate}" crate.
%files -n %{name}+getrandom-devel %files -n %{name}+getrandom-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -86,7 +80,7 @@ BuildArch: noarch
%description -n %{name}+libc-devel %{_description} %description -n %{name}+libc-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the libc" feature of the "%{crate}" crate. use the "libc" feature of the "%{crate}" crate.
%files -n %{name}+libc-devel %files -n %{name}+libc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -98,7 +92,7 @@ BuildArch: noarch
%description -n %{name}+log-devel %{_description} %description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the log" feature of the "%{crate}" crate. use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel %files -n %{name}+log-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -110,7 +104,7 @@ BuildArch: noarch
%description -n %{name}+min_const_gen-devel %{_description} %description -n %{name}+min_const_gen-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the min_const_gen" feature of the "%{crate}" crate. use the "min_const_gen" feature of the "%{crate}" crate.
%files -n %{name}+min_const_gen-devel %files -n %{name}+min_const_gen-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -122,7 +116,7 @@ BuildArch: noarch
%description -n %{name}+rand_chacha-devel %{_description} %description -n %{name}+rand_chacha-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the rand_chacha" feature of the "%{crate}" crate. use the "rand_chacha" feature of the "%{crate}" crate.
%files -n %{name}+rand_chacha-devel %files -n %{name}+rand_chacha-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -134,7 +128,7 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description} %description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the serde" feature of the "%{crate}" crate. use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -146,7 +140,7 @@ BuildArch: noarch
%description -n %{name}+serde1-devel %{_description} %description -n %{name}+serde1-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the serde1" feature of the "%{crate}" crate. use the "serde1" feature of the "%{crate}" crate.
%files -n %{name}+serde1-devel %files -n %{name}+serde1-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -158,7 +152,7 @@ BuildArch: noarch
%description -n %{name}+small_rng-devel %{_description} %description -n %{name}+small_rng-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the small_rng" feature of the "%{crate}" crate. use the "small_rng" feature of the "%{crate}" crate.
%files -n %{name}+small_rng-devel %files -n %{name}+small_rng-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -170,7 +164,7 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description} %description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the std" feature of the "%{crate}" crate. use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -182,7 +176,7 @@ BuildArch: noarch
%description -n %{name}+std_rng-devel %{_description} %description -n %{name}+std_rng-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the std_rng" feature of the "%{crate}" crate. use the "std_rng" feature of the "%{crate}" crate.
%files -n %{name}+std_rng-devel %files -n %{name}+std_rng-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

@ -1 +1 @@
SHA512 (rand-0.8.4.crate) = 77ae0e988e31e12f7d3f2c40814f930eecbc94c4aced827c337be78eeeabf39fde2dc5c4fda059afdc01285ff4afe30393c32694377de004feff16207606558e SHA512 (rand-0.8.5.crate) = 8b33a8988906ba5e2057a9a84bdd11f867a5536c22f5056eec59ed4ec4e3a6da2fd773da4c0510d343762e5a4ea0f007db4c4a7cef87a47f90e36c1a84d86fb2

Loading…
Cancel
Save