parent
56f495f305
commit
3e3e2d0749
@ -1,22 +0,0 @@
|
|||||||
--- rand-0.4.2/Cargo.toml 1970-01-01T01:00:00+01:00
|
|
||||||
+++ rand-0.4.2/Cargo.toml 2018-01-06T13:44:52.496038+01:00
|
|
||||||
@@ -22,6 +22,7 @@
|
|
||||||
categories = ["algorithms"]
|
|
||||||
license = "MIT/Apache-2.0"
|
|
||||||
repository = "https://github.com/rust-lang-nursery/rand"
|
|
||||||
+exclude = ["utils/*.py"]
|
|
||||||
|
|
||||||
[features]
|
|
||||||
alloc = []
|
|
||||||
@@ -29,11 +30,6 @@
|
|
||||||
i128_support = []
|
|
||||||
nightly = ["i128_support"]
|
|
||||||
std = ["libc"]
|
|
||||||
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-zircon]
|
|
||||||
-version = "0.3.2"
|
|
||||||
[target."cfg(unix)".dependencies.libc]
|
|
||||||
version = "0.2"
|
|
||||||
optional = true
|
|
||||||
-[target."cfg(windows)".dependencies.winapi]
|
|
||||||
-version = "0.3"
|
|
||||||
-features = ["minwindef", "ntsecapi", "profileapi", "winnt"]
|
|
@ -0,0 +1,34 @@
|
|||||||
|
--- rand-0.5.3/Cargo.toml 1969-12-31T16:00:00-08:00
|
||||||
|
+++ rand-0.5.3/Cargo.toml 2018-06-30T16:50:36.060662-07:00
|
||||||
|
@@ -22,6 +22,7 @@
|
||||||
|
categories = ["algorithms", "no-std"]
|
||||||
|
license = "MIT/Apache-2.0"
|
||||||
|
repository = "https://github.com/rust-lang-nursery/rand"
|
||||||
|
+exclude = ["utils"]
|
||||||
|
[package.metadata.docs.rs]
|
||||||
|
all-features = true
|
||||||
|
[dependencies.log]
|
||||||
|
@@ -48,22 +49,9 @@
|
||||||
|
i128_support = []
|
||||||
|
nightly = ["i128_support"]
|
||||||
|
serde1 = ["serde", "serde_derive", "rand_core/serde1"]
|
||||||
|
-std = ["rand_core/std", "alloc", "libc", "winapi", "cloudabi", "fuchsia-zircon"]
|
||||||
|
-[target."cfg(target_os = \"cloudabi\")".dependencies.cloudabi]
|
||||||
|
-version = "0.0.3"
|
||||||
|
-optional = true
|
||||||
|
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-zircon]
|
||||||
|
-version = "0.3.2"
|
||||||
|
-optional = true
|
||||||
|
+std = ["rand_core/std", "alloc", "libc"]
|
||||||
|
[target."cfg(unix)".dependencies.libc]
|
||||||
|
version = "0.2"
|
||||||
|
-optional = true
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3"
|
||||||
|
-features = ["minwindef", "ntsecapi", "profileapi", "winnt"]
|
||||||
|
-optional = true
|
||||||
|
-[target.wasm32-unknown-unknown.dependencies.stdweb]
|
||||||
|
-version = "0.4"
|
||||||
|
optional = true
|
||||||
|
[badges.appveyor]
|
||||||
|
repository = "alexcrichton/rand"
|
@ -1 +1 @@
|
|||||||
SHA512 (rand-0.4.2.crate) = ac6eaf9f0914fd966c835a04ec644c5a8d62a4a634187d538cecfb711955a977234dc5fe487cd4d351514bc0de4f51cbd0f09a8f6aac56aa0467ae5eb17a4fad
|
SHA512 (rand-0.5.3.crate) = 3296fab41470c798b4ed8b992eae38de8db43ce5a92fc4f07ea6e0385dc816ce3df4abeaa42279de91bc40bd9d4d7d6aaa809e98600012019874e44ff0c3e45d
|
||||||
|
Loading…
Reference in new issue