Update to 0.8.0

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 4 years ago
parent 492be4f62a
commit 251da1e4c4
No known key found for this signature in database
GPG Key ID: 115D5AB89C5C1E1E

1
.gitignore vendored

@ -12,3 +12,4 @@
/rand-0.7.1.crate /rand-0.7.1.crate
/rand-0.7.2.crate /rand-0.7.2.crate
/rand-0.7.3.crate /rand-0.7.3.crate
/rand-0.8.0.crate

@ -3,5 +3,3 @@ unwanted-features =
nightly nightly
packed_simd packed_simd
simd_support simd_support
stdweb
wasm-bindgen

@ -1,11 +1,18 @@
--- rand-0.7.3/Cargo.toml 2020-01-10T21:46:19+00:00 --- rand-0.8.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ rand-0.7.3/Cargo.toml 2020-01-15T23:50:29.531548+00:00 +++ rand-0.8.0/Cargo.toml 2021-01-03T09:43:35.677174+00:00
@@ -67,8 +67,6 @@ @@ -63,14 +63,11 @@
simd_support = ["packed_simd"]
small_rng = []
std = ["rand_core/std", "rand_chacha/std", "alloc", "getrandom", "libc"]
-std_rng = ["rand_chacha", "rand_hc"]
+std_rng = ["rand_chacha"]
[target."cfg(not(target_os = \"emscripten\"))".dependencies.rand_chacha] [target."cfg(not(target_os = \"emscripten\"))".dependencies.rand_chacha]
version = "0.2.1" version = "0.3.0"
optional = true
default-features = false default-features = false
-[target."cfg(target_os = \"emscripten\")".dependencies.rand_hc] -[target."cfg(target_os = \"emscripten\")".dependencies.rand_hc]
-version = "0.2" -version = "0.3.0"
-optional = true
[target."cfg(unix)".dependencies.libc] [target."cfg(unix)".dependencies.libc]
version = "0.2.22" version = "0.2.22"
optional = true optional = true

@ -1,12 +1,12 @@
# Generated by rust2rpm 16 # Generated by rust2rpm 17
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate rand %global crate rand
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.7.3 Version: 0.8.0
Release: 4%{?dist} Release: 1%{?dist}
Summary: Random number generators and other randomness functionality Summary: Random number generators and other randomness functionality
# Upstream license specification: MIT OR Apache-2.0 # Upstream license specification: MIT OR Apache-2.0
@ -79,18 +79,6 @@ which use "getrandom" feature of "%{crate}" crate.
%files -n %{name}+getrandom-devel %files -n %{name}+getrandom-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+getrandom_package-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+getrandom_package-devel %{_description}
This package contains library source intended for building other packages
which use "getrandom_package" feature of "%{crate}" crate.
%files -n %{name}+getrandom_package-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+libc-devel %package -n %{name}+libc-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -115,16 +103,28 @@ which use "log" feature of "%{crate}" crate.
%files -n %{name}+log-devel %files -n %{name}+log-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rand_pcg-devel %package -n %{name}+rand_chacha-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+rand_pcg-devel %{_description} %description -n %{name}+rand_chacha-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use "rand_pcg" feature of "%{crate}" crate. which use "rand_chacha" feature of "%{crate}" crate.
%files -n %{name}+rand_pcg-devel %files -n %{name}+rand_chacha-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde1-devel %package -n %{name}+serde1-devel
@ -163,6 +163,18 @@ which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std_rng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std_rng-devel %{_description}
This package contains library source intended for building other packages
which use "std_rng" feature of "%{crate}" crate.
%files -n %{name}+std_rng-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
@ -182,6 +194,9 @@ which use "std" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sun Jan 03 10:43:35 CET 2021 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.8.0-1
- Update to 0.8.0 (Fixes: RHBZ#1909311)
* Fri Dec 11 2020 Fabio Valentini <decathorpe@gmail.com> - 0.7.3-4 * Fri Dec 11 2020 Fabio Valentini <decathorpe@gmail.com> - 0.7.3-4
- Remove features with missing dependencies (packed_simd, stdweb, wasm-bindgen). - Remove features with missing dependencies (packed_simd, stdweb, wasm-bindgen).

@ -1 +1 @@
SHA512 (rand-0.7.3.crate) = f9b68ef9446f1ca2c8092c50990f15c1b4cb5529eeeac4df8d69755e0b7253c663c587775e7cb0a7298c31edb444975dda34926759306541f6d43d0d3cf57b7e SHA512 (rand-0.8.0.crate) = bae4e0bbdf8e5948db439b1b1e4b7c62b4e2543ee3eb8857afbbb091eb806eafc300cc8204ac85f301647090f76a0847afd4da8e7cfc5b3f3c97ffa4c028efa1

Loading…
Cancel
Save