Initial import (quick-xml 0.30 compat package)

epel9 imports/e9/rust-quick-xml0.30-0.30.0-1.el9
Fabio Valentini 1 year ago
parent 9c19088adf
commit 5f59a36745
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/quick-xml-0.30.0.crate

@ -1,3 +0,0 @@
# rust-quick-xml0.30
The rust-quick-xml0.30 package

@ -0,0 +1,12 @@
--- quick-xml-0.30.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ quick-xml-0.30.0/Cargo.toml 2023-12-02T00:36:54.044683+00:00
@@ -124,9 +124,6 @@
optional = true
default-features = false
-[dev-dependencies.criterion]
-version = "0.4"
-
[dev-dependencies.pretty_assertions]
version = "1.3"

@ -0,0 +1,203 @@
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate quick-xml
Name: rust-quick-xml0.30
Version: 0.30.0
Release: %autorelease
Summary: High performance xml reader and writer
License: MIT
URL: https://crates.io/crates/quick-xml
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency
Patch: quick-xml-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
High performance xml reader and writer.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-MIT.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arbitrary-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arbitrary-devel %{_description}
This package contains library source intended for building other packages which
use the "arbitrary" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-tokio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+async-tokio-devel %{_description}
This package contains library source intended for building other packages which
use the "async-tokio" feature of the "%{crate}" crate.
%files -n %{name}+async-tokio-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+document-features-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+document-features-devel %{_description}
This package contains library source intended for building other packages which
use the "document-features" feature of the "%{crate}" crate.
%files -n %{name}+document-features-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+encoding-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+encoding-devel %{_description}
This package contains library source intended for building other packages which
use the "encoding" feature of the "%{crate}" crate.
%files -n %{name}+encoding-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+encoding_rs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+encoding_rs-devel %{_description}
This package contains library source intended for building other packages which
use the "encoding_rs" feature of the "%{crate}" crate.
%files -n %{name}+encoding_rs-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+escape-html-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+escape-html-devel %{_description}
This package contains library source intended for building other packages which
use the "escape-html" feature of the "%{crate}" crate.
%files -n %{name}+escape-html-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+overlapped-lists-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+overlapped-lists-devel %{_description}
This package contains library source intended for building other packages which
use the "overlapped-lists" feature of the "%{crate}" crate.
%files -n %{name}+overlapped-lists-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-types-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-types-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-types" feature of the "%{crate}" crate.
%files -n %{name}+serde-types-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serialize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serialize-devel %{_description}
This package contains library source intended for building other packages which
use the "serialize" feature of the "%{crate}" crate.
%files -n %{name}+serialize-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio" feature of the "%{crate}" crate.
%files -n %{name}+tokio-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (quick-xml-0.30.0.crate) = e731f9c6795da7ad705c96544b39560dc27e2ea3c468c3dffe9589bb314074e96acbc0ab454f94556e0d9569c55d6cd8d1c7be2c823a77bbb3165ec8393d9aee
Loading…
Cancel
Save